TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Remember to do a search before you ask a question!!!

Problem with having a time delay between drawing processes
Read 1304 times
* October 16, 2017, 04:05:20 AM
Hello TurboCAD forum.

I am a new TurboCAD forum member.
This is my first post to the forum.

I have changed over from AutoCAD LT to TurboCAD 21 Professional 21 - x64

I have loaded TurboCAD 21 onto my desktop PC, and onto my laptop.
Both computers are running Windows 10

TurboCAD appears to be working fine on the laptop, however I am experiencing a time delay problem between commands with TurboCAD on my desktop PC.

As an example:
I draw a simple single line, from a starting point to a second point.

Once I have completed drawing that line at the second point, there is an approx 5 to 8 seconds delay before I am able to commence drawing the next line.

Throughout this delay period, the cursor disappears.
Following this delay period, the cursor re-appears and I am able to commence drawing the next line.

This type of delay happens when drawing other features as well.

I am hoping that the fix for this delay is some sort of setting adjustment, but I cannot find the setting as yet.

I do not experience this delay when using AutoCAD on this desktop PC.
And my laptop doesn't have this delay when running TurboCAD

Can anyone offer any clues as to why this delay is happening on my desktop PC ??

Thank you.
Pete W


* October 16, 2017, 05:07:13 AM
Welcome Pete

Can I ask, are you working in default workspace or LTE workspace, Tools menu - Customise - options tab - workspace (default style drop down box switches default or LTE)

In Options menu (or Options menu - Sub options if LTE) - Native draw, are you using GDI mode or RedSDK Mode (depicted by radio button). If RedSDK, you could try changing to GDI and ticking flicker free draw, and see if that makes any difference (it will ask to restart TC so make sure any drawing is saved first).

« Last Edit: October 16, 2017, 05:12:33 AM by Andy H »


* October 16, 2017, 01:57:35 PM
Hello Andy,
Many thanks for your prompt response to my frustrating little problem.

Your info appears to have fixed the problem, and I can draw multiple lines immediately one after the other now.

I am on the Default workspace.

I did go into "Native Draw", where it was previously set to RedSDK mode.
I changed this over to GDI and ticked "Flicker Free Draw".
I restarted TC, and it appears that the delay problem is solved.

I appreciate your assistance with this.

Kind regards
Pete Weatherby


* October 16, 2017, 02:56:18 PM
Pete,  the fact that it worked suggests RedSDK isn't playing well with the graphic adaptor on the desktop which could be simply a driver issue, or if there is more than one adaptor (card and onboard) TC could be using the wrong one.   anyway, -

If you are planning to do any 3D rendering work, what I would suggest is having both the laptop and desktop using the same mode, If your happy with GDI you could change the laptop to the same mode,  the reason is that if you decide to use RedSDK materials on the laptop, they won't render in GDI mode on the desktop, and keep switching between Lightworks (the normally used GDI materials) and RedSDK materials will become messy.