TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

When posting a problem be sure to include which version you are using.  Give as much information as possible.  If the problem is with a specific file be sure to attache it to your post.

3D printing V21.2 PRO 64 bit
Read 3076 times
* August 03, 2017, 06:55:41 AM
The library by us just bought a 3D printer and wanted to make some of my model boat parts on it. So I took the class on  operation and happened to bring a file(model I created and converted to STL file. They only accept STL and OBJ files. It is and ULTIMAKER 2+ you have to download CURA software  and run your file through it .I guess it makes a g code file to load to the 3D printer. Here were my problems.
1. When I created the STL file a window popped up and said something like it may not create all the information that is there some items of the solid might not be there?
2.When we downloaded my file it rescaled the solid and we learned that the ULTIMAKER printer only works in metric and my file was in English. In other word 1 inch became 1 mm it does not recognize English  and assumes its metric.
So why am I getting a pop up window when I create a STL file saying it may not create all the information in the file shouldn't all the information go into the STL file ?
And how can I change my English drawings to metric before I run it through CURA software so it doesn't rescale it.
« Last Edit: August 05, 2017, 07:23:55 AM by to »


* August 03, 2017, 08:25:59 AM
Can you confirm file type, you mentioned SLA, I though it may be a typo, and .stl is a file type and pla is the plastic, I've no idea about sla file type, but cura can open .stl and obj.

As for the error message is this when saving the file in TC,  do you have an example file which shows the error message.

Personally - after exporting stl from TC I run it through the free MeshLab and / or NetFabb to check for errors and repair errors in the stl (usually using NetFabb) before sending into cura or other slicing software,  I haven't done any tests, but all stl's I've opened in netfabb it has said it corrected a few errors.

As for the scaling, I use metric so hadn't noticed any scaling issues, but you could (on a copy of the file) change your options - space units to metric, select the whole model and scale it by 25.4 in x, y and, z scale boxes, then check if the measurements are correct before exporting to stl. 

## Edit ## just remembered Gary aka lemel_man  uses (or has used) the ultimaker with cura,  so hopefully he will see this thread as he will be able too offer better advice than myself on the setup. ##End Edit ##
« Last Edit: August 03, 2017, 09:25:28 AM by Andy H »


* August 03, 2017, 11:55:18 PM
.sla is the machine instruction file format used by 3DSystems'  rapid prototyping machines.  It's not like 3D printer slicer formats because it's solid, no density to calculate, the infill is simple back-and-forwards, it doesn't have to angle or zig-zag the laser.   It's a proprietary format, I think. 


* August 04, 2017, 12:07:36 AM
Andy's right, I use an Ultimaker 2 with Cura, and have created many models in TC 21 which I save as STLs.
Cura is quite capable of changing the scale of an STL - see the screenshot below. You can also use TurboCad to change the scale and leave the Cura scale alone.
As Andy said, just set the scale to 25.4 to convert inches to millimetres.

Gary Wooding
Win10 64-bit,
TC21.2 x64 Plat, Bld59
TC16.2 Plat, Bld54.0
TCC 3.5

* August 04, 2017, 10:12:49 AM
I am not changing the scale when my file goes into Cura it assumes its in mm and it is not it is in English .So it automatically changes the scale thinking its mm you would never know it without checking the sizing. So I need to convert to mm before Cura. We could not find  a way to change Cure to accept English dimensioning. So the only way is to change to mm before running through Cura software.


* August 05, 2017, 07:19:55 AM
If I go into the top bar menu and chose Options --- Space Units--and in this window is a toggle English -Metric if I toggle from English to Metric and do a save and run the file through CURA software will it then recognize this as a Metric file and not rescale it but keep the English sizes I created?


* August 05, 2017, 08:38:55 AM
When you changed to metric did you then scale the drawing - or at least tick the box in the space unit dialog that says 'convert units after alteration', (I'm no too keen in the auto convert thing).

Someone will correct me if I'm wrong - but this is my understanding, 

The problem is we are going through three essentially incompatible systems, TC which can be set as English or metric scales,  stl which is unit-less i.e. '1' of whatever in TC = '1' in stl whether its inches,  millimetres or furlongs, stl doesn't know its 'inch' from its 'mm', all it sees is 1=1,   then you have cura which the programmers decided what scale it works in,  somewhere along the line - we as users must work to accommodate these changes.

When TC (or any program) saves as stl it saves 1 of whatever unit we are working in, and converts it to 1 unit in stl, so 1 inch = 1 stl unit and 1 mm = 1 stl unit. its up to us to set the necessary scale, whether that is by altering the file in TC, or using the scale factor in Cura is up the the user,  essentially if Cura's base units were inches, I as a metric user would have to rescale my whole drawings by  0.03937 (approximately)

Basically there are only two options, either rescale the drawing in TC (either by changing to metric and ticking convert, or changing to metric, select the whole drawing and multiplying by 25.4 (in x y and z)),  or second option of noting what the units are in TC and scaling in Cura by 25.4 or whatever.

not sure if that explains it well, but its how I see it.



* August 05, 2017, 12:31:08 PM
My understanding is the same as Andy's.

Gary Wooding
Win10 64-bit,
TC21.2 x64 Plat, Bld59
TC16.2 Plat, Bld54.0
TCC 3.5

* August 18, 2017, 10:10:43 AM
That did work click on Options---space/units----change from English to metric click on box at bottom
 --- convert units after alteration and gives example. However I made a new file made it metric and clicked non bottom box convert units and saved it then I extracted to my English file into this file and it auto converted it to metric  and did not change the scale. Now if I have to change my file which did happen I just delete what is in the metric file and extracted into the metric file again with  the alterations.

The pop up window that cam up when I created an STL file said:
You have selected aa file format that may not support all of TC's features.


* August 18, 2017, 05:26:29 PM
It gives a glimpse of why people might like to consider standards - and why international standards are metric....

The pop up message reminds you that .stl is a dumb format that breaks associations, destroys curved-surface recognition, strips part history and most of the features that TC can recognise, except for planar surfaces, edges and vertices.  TC's features also include dimensions, paper spaces, blocks, groupings an so on, no neutral format recognises all of these.  If you want to be able to edit your model easily in the future, save the .stl model separately (export by "save copy as" or select and "save as" with  "selection" checked in lower right corner of the dialogue box (which is probably the best way to specify that you want that particular solid or surface object saved as the .stl).  It's also a sound idea to re-import the .stl into a new file, convert it to solid or perform SAT healing, then re-save as .stl.  This can remove coincident faces and remedy some gaps in meshes.