TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Remember to do a search before you ask a question!!!

Offset line created on wrong face of extruded box
Read 1285 times
* August 17, 2016, 02:25:50 PM
I'm creating a line offset by 0.5 inch from the edge of an extruded box, but the line ends up on the wrong face.  I defined the workplane on the correct face using the 3 point method, and the workplane indicates correctly.  But, when I try to create the line parallel to the edge, the software changes the workplane to the other extrusion face attached to the edge, and the line parallel to the edge is created on that face, not the one that I had selected.  How do you lock the workplane so that this cannot happen?

Logged


* August 21, 2016, 02:15:42 PM
#1
If I understand you correctly, what you are trying to do is not possible. The 'Offset' and 'Parallel' tools only work on 2D objects, and will create the offset on the plane of the original 2D profile used for your extrusion.  Try to offset your line on the original 2D profile, select this offset, define the work plane to the new facet, then use 'Modify' - 'Place on Work Plane' to move the offset.
OR you could draw a new line on the facet you would like, then offset that line (or move it).

Logged
TC 21 Deluxe, TC 20 Platinum, TC 2015 Platinum, TC 2016 Platinum, TC 2017 Platinum
i7- 3770 Ivy Bridge 3.4 GHz, 16G Crucial Ballistic, ASRock Extreme 4, EVGA 1060 SSC, Windows 10 Pro 64 Bit


* August 21, 2016, 08:46:36 PM
#2
the other thing to check is that you don't have auto workplane by facet on.

Logged
Nikki
TC20 platinum
TC 2015 platinum
TC 2017 with lightworks


August 22, 2016, 11:27:36 AM
#3
I'm creating a line offset by 0.5 inch from the edge of an extruded box, but the line ends up on the wrong face.  I defined the workplane on the correct face using the 3 point method, and the workplane indicates correctly.  But, when I try to create the line parallel to the edge, the software changes the workplane to the other extrusion face attached to the edge, and the line parallel to the edge is created on that face, not the one that I had selected.  How do you lock the workplane so that this cannot happen?

Turning off Auto workplane by face will probably work, but if that's a solution, then another is to be careful where you place the cursor when creating the Line.  I put the cursor near the vertex, but definitely over the desired workplane surface, then use V-snap to start the line.  Once started, the Line will remain on that Workplane until you finish it.


Jeff


Logged
TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* August 22, 2016, 05:42:14 PM
#4
Many thanks for the suggestions.  I've found that if I start with Edit-Clear-All Construction lines, then generating the workplane on the desired face, with the 3 point method, paying attention to the X and Y axis and then place new construction lines on those X and Y axis, the offsets generated from those new construction lines are a generally on the correct desired face.  The automatic workplane function is definitely turned OFF.  It also helps to have the Workplane displayed at all times to double check what is being created.  That may be over-kill, but it is getting more consistent results.   

Logged