TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When posting a problem be sure to include which version you are using.  Give as much information as possible.  If the problem is with a specific file be sure to attache it to your post.

How do I knock off corners?
Read 5512 times
* July 13, 2016, 10:19:30 AM
TurboCAD 2016 Deluxe-
So let's say I create a 2x2" box, then I simple extrude it 2 inches in height. How do I chamfer a corner of the box? I want to knock off about 1/4" in, and 1" long down the edge of the box on both sides. Thanks in advance for any and all replies.
Bill

Logged


* July 13, 2016, 10:40:02 AM
#1
One way is to use the 3D Slice tool. Since the chamfer doesn't extend the full height of the box, slice the box first and then use the Slice tool to cut off the corners of one of the pieces. Delete the scraps and weld the good parts back together with 3D Add.

Henry H

Logged


July 13, 2016, 10:49:53 AM
#2
William,

Henry's suggestion will work. Another is to create solids that represent the space you wish to remove from the box and subtract them.

In TurboCAD Pro there are features that allow you to chamfer and fillet edges of 3D objects easily. Not so id Deluxe unfortunately.

It may help to start by filleting the corner of the box before you extrude it as well. You can do this by going to Modify-->Fillet 2D.


Logged


* July 13, 2016, 11:54:39 AM
#3
As unfamiliar I am with TurboCAD, no matter what I tried I can't get the edges trimmed. If the PDF file attaches, I highlighted in red the corners that I need gone. Maybe you could walk me through each step I need to take. The 3d slice was the most promising, and even though I could clearly see the triangle form around the slice area, when I clicked the third time it said something wasn't closed, or something like that. I just don't get it. :(

Logged


* July 13, 2016, 12:50:43 PM
#4
As unfamiliar I am with TurboCAD, no matter what I tried I can't get the edges trimmed. If the PDF file attaches, I highlighted in red the corners that I need gone. Maybe you could walk me through each step I need to take. The 3d slice was the most promising, and even though I could clearly see the triangle form around the slice area, when I clicked the third time it said something wasn't closed, or something like that. I just don't get it. :(

Please post the .tcw file, William. Can't do much with just the PDF.

Henry H

Logged


* July 13, 2016, 01:07:46 PM
#5
Ok, I think this it.

Logged


July 13, 2016, 03:05:22 PM
#6
Ok,

I got your file open and I can tell right off the bat what you've missed here.

If you dynamic rotate this drawing you'll see that those red lines you've got there aren't where you think they are. You've got to set your workplane correctly before you try to draw anything in 3D.

I'm working on a little step by step for you but wanted to let you know the first problem I saw right off the bat.

What are the dimensions of those triangles? That'll help me walk you through this.

Logged


* July 13, 2016, 03:17:57 PM
#7
Dynamically rotate it. Why didn't I think of that!? Wait. What? :)
Being that the thickness of the part is 1/4", I just want 1/16" knocked off (.0625"). Anything close to that with a step-by-step is good enough for me. And thank you for your help!

And then I opened the drawing and rotated it. The triangles, and the slots too, didn't stay with the drawing. So even though the lines were there, they weren't. I don't get it. There has to be a way for me to understand this program. I get some of it but not enough to even get by.
« Last Edit: July 13, 2016, 03:24:36 PM by William LeMieux »

Logged


July 13, 2016, 03:30:26 PM
#8
Press down on the middle mouse button and move the mouse left or right.

See how those things are not where it looks like they are? That's because you didn't have your workplane set correctly when you drew them. Here is a really lengthy explanation I wrote for the blog.

Drawing in 3D requires an entirely different mindset from drawing in 2D. If you’ve spent a good deal of time drafting 2D schematics you’re used to thinking and drawing in 2D, that is with two axes, the x and y. If you want to indicate a spherical object you draw a circle. If you want to indicate a cylinder you might draw a circle or rectangle depending on which view of the object you’re drawing. Likewise a cone might be represented as a circle or triangle depending on whether you are looking at it from the bottom or the side.
But, when we draft in 3D we are in a different environment altogether from start to finish. In 3D we work in 3 Dimensions from the very beginning. There isn’t just an x and y axis. There is also a third axis referred to as the z axis. So in 3D we can’t just draw a circle and tell the program it’s a sphere. We have to actually draw a sphere. We can’t just draw a circle and a rectangle and call them a cylinder. We must draw a circle and extrude it into a cylinder. This concept applies across the board. In 3D we are no longer drawing objects according to the way they would look if we were viewing them from a vantage point. We are drawing objects the way they actually exist, with three dimensions and in TurboCAD we have an infinite space to draw them in. The x, y and z axes on which we draw stretch out into an infinite virtual space.

This concept, while immensely powerful, presents a very unique problem. This infinite space in which we draw is 3 dimensional. It has an infinite width, length and height. But, we access it and view it through a computer monitor, a finite two dimensional surface. So when I click my mouse to draw a line, rectangle, circle or some other two dimensional object that I might later modify into a three dimensional shape how does the software know where I am clicking. I could be clicking literally anywhere. This is the unique problem and it is solved with a deceptively simple solution called the workplane, also known as the user coordinate system or UCS. Specifying and defining coordinate systems is how the software keeps track of where we are performing operations and where we are placing objects.

A 3D coordinate system is like three dimensional graph paper. It has an x axis, y axis and z axis. It also has an origin point – the place where the graph begins, where x = 0, y = 0 and z = 0. From the origin point each of the axes stretches out, perpendicular from the others, to infinity. In TurboCAD there are three main coordinate systems, the world coordinate system, the user coordinate system and the entity coordinate system.

The world coordinate system is the coordinate system of the infinite drawing space. When the software first opens a new file you are looking straight down at the geometric plane defined by the x and y axes of the world coordinate system. 

Part of the solution I'm going to post for you involves setting the workplane by facet.

This will be a good primer for you to understand what you're doing when you do that.

Logged


July 13, 2016, 04:17:41 PM
#9
1. delete those triangles.

2. let's display the workplane. Right click and choose the first icon in the third row of icons. Show/Hide Workplane. Then right click and choose the 3rd icon in the bottom row of icons Fit Workplane to Window. You should then see what is displayed in image01.

3. Right click and choose the Workplane by Facet Tool. This is the 8th tool from the left on the bottom row. This will let you set the workplane congruent to the facets of your object. Set the Workplane congruent to the end of the object by hovering over that facet and clicking when it turns green. If you then zoom in on the end and fit the workplane to the window it should look like image02

4. Now put a horizontal construction line and vertical construction line at the vertex of the corner you want to chamfer and then create parralell construction lines 1/16 of an inch off of each of those so that you have what is shown in image 3

5. Draw a line from the intersection of the construction lines to each other using the intersection snap so that you have what is in image04 (this screenshot didn't come out right. The line should be snapped to both intersections)

5. Use workplane by facet to set the workplane congruent to the top of the object.

6. Go to Edit-->Clear-->All constructions (now you should have something like image05)

7. Zoom out a little and draw angular construction lines along the edges of the object and then a parallel construction line from the end as shown in image06

8. Then dynamically rotate (push down on the middle mouse button and rotate the view) to an angle somewhat like what you see in image07 and draw the new line you see in it.

9. Then use workplane by facet to set the workplane congruent to the third side of the corner and draw the line you see in image08

10. Right click an click on Workplane by Three Points which is the icon just to the left of the Workplane by facet icon. This allows you to define a workplane by the origin point and direction of the x and y axes. After engaging this tool click on the point of the triangle away from the end of the object to define that as the origin point, then click on the vertex of the triangle at the end and on top of the object to define the x direction and then the last corner of the rectangle to define the y direction. Then your workplane will show as in image09

11. Then go to modify-->Modify 3D objects-->3D Boolean Operations-->3D Slice. On the inspector bar turn on the slice by workplane option as shown in image10

12. Click on the object to Slice it by the workplane. This will happen very silently. If it doesn't seem like anything happened you probably did it right.

13. Click on the corner that has been sliced off to select it and then delete it. Voila! You should have image11

« Last Edit: July 13, 2016, 04:20:27 PM by TravisFleenor »

Logged


July 13, 2016, 04:18:44 PM
#10
Here are the rest of the images.

A quick caveat is that you didn't have to draw the triangle. You could just do the construction lines and used the intersection points as snaps for the workplane by 3 points operation but I wanted it to be clear what was going on and drawing the triangle made it less confusing.

Logged


July 13, 2016, 04:23:08 PM
#11
Oh... and I'm available for one on one tutorial sessions by remote screen share for $75.00 an hour Mon-Fri 9am-3pm Pacific :)

Logged


* July 14, 2016, 03:34:02 AM
#12
It's like pulling teeth I tell ya! I have a red cross way off in the distance from the drawing and any construction line that I draw originates from that cross. It won't put it on the corner of my drawing. What's up with the cross thingy?

Logged


* July 14, 2016, 04:47:42 AM
#13
Hi Bill,
see attachment >
Here's a quick and easy method while you're learning. Deluxe will teach you how to use the basic tools of 3d modeling. It's how I used to draw 3d objects years ago. Now a days they have all these fancy tools that do it for ya  ;D
I used 'N" seke to snap to your object when doing the workplane by 3 points. Though your profiles were not on the 3d object they were in line with it. The trick is "NOT' to rotate your view upon opening your drawing. Create a view so you can always go back to it.
« Last Edit: July 14, 2016, 04:57:21 AM by Dean »

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > 2019-2018-2017, TurboCad Platinum 21,20,19 and 18.Using LightWorks, Anilab lab 5.  HP all in one  23" Touch smart screen with Nvidia Geforce 210, open gl 3.3. Intel Core i5 ,2.27GHz,4 GB ram.


* July 14, 2016, 07:08:51 AM
#14
It's like pulling teeth I tell ya! I have a red cross way off in the distance from the drawing and any construction line that I draw originates from that cross. It won't put it on the corner of my drawing. What's up with the cross thingy?

It might be the "Relative coordinates" origin. Press A on your keyboard and see if it goes away.

Henry H

Logged


July 14, 2016, 07:48:55 AM
#15
Bill,

Make sure you have your snap settings set so that intersection and vertex snaps are turned on and any others are turned off. Henry is probably right too. You are making sure to set your workplane congruent to the facet of the object prior to drawing the construction lines right?

Logged


* July 14, 2016, 08:34:03 AM
#16
I turned off all but the vertex and intersection snaps. When I turned off the "relative coordinates" the "absolute coordinates" turned on automatically and I can't turn it off. So I assume one of those has to be turned on. Either way, now I don't have any snap coordinates at all. It's like "no snap" is turned on all the time even when it isn't. I added some snaps again but I get no coordinate snaps, ever. Ok, I really hate this thing! :(

And then just for the hellofit, I opened a new drawing, drew a square, and looked for coordinates. Nothing. Then I opened up a different drawing and the same thing. No snaps anywhere to be found. It all used to work and now they don't. ???
« Last Edit: July 14, 2016, 08:54:13 AM by William LeMieux »

Logged


* July 14, 2016, 08:54:49 AM
#17
Bill,
You can always use the "Local snap" in the right click menu. Enable 'No snap" if you wish so you don't get all those little triangles popping up in the screen and use the "local snap", it's very straight forward. You get one snap then you need to activate it again.

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > 2019-2018-2017, TurboCad Platinum 21,20,19 and 18.Using LightWorks, Anilab lab 5.  HP all in one  23" Touch smart screen with Nvidia Geforce 210, open gl 3.3. Intel Core i5 ,2.27GHz,4 GB ram.


* July 14, 2016, 09:11:43 AM
#18
Tried the local snap, I still get nothing. Come to think of it, I used to get all those snap triangles and construction line things on my other computer (TurboCAD Deluxe 18), and they just quit working one day too. Something's going on here that I can't explain. I tried shutting down my computer and restarting it and that didn't help anything. It's like I just lost all my snaps for some reason. 

Logged


July 14, 2016, 10:05:28 AM
#19
Bill,

Did you click on the word SNAP down in the bottom right hand corner and now it is greyed out? If you right click on it that SNAP brings up the drawing aids window but if you left click on it toggles snaps on and off.


Logged


* July 14, 2016, 11:00:48 AM
#20
Well if I did it was by accident. But I don't know which way it was because I've now been trying to use it both ways; greyed out and white. It doesn't seem to make much difference.

Used to be that I could point at any corner of any drawing and I'd get pretty pink dashed lines going in all directions. I could pick a diagonal corner, with the pink lines still intact, and draw a line to that diagonal corner, because a pink "x" would show up on the corner. Now when I move the pointer the pink lines disappear. Also, I can't draw diagonal anymore unless I use "no snap". But then I have to guess where the line ends up. And now the line that is being drawn only moves up and down or right and left. Again, unless I use "no snap. The pink lines seem to show up only when it wants, and even then it flickers on and off. Grrr!

Logged


July 14, 2016, 11:38:23 AM
#21
Bill,

Makes sure the SNAP and GEO are both lit up not greyed out. Right click on SNAP and then make sure your snap setting look just like in the attached screen shot

Logged


* July 14, 2016, 11:51:01 AM
#22
Well all of a sudden it started working again but I set it up like your screenshot anyway. That's much more goodlier. :) I'm not sure what, but I think I'm learning something here.

Now where were we? Oh yeah, trying to knock off those corners. I think I'll try one more time to make it happen. Then when it fails, I'll take a break from it. I've had enough disappointment for one day. Whew! :)

Oh yes, a big thank you to all!

Logged