TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Remember to do a search before you ask a question!!!

Unhandled exception when opening files in TCW2015
Read 2640 times
* October 21, 2015, 01:17:50 AM
This is a new install of 2015. Trying to open TCW files from the file menu gives an Unhandled Exception message, and the program closes. Opening files from the startup window works fine and these can be edited with no obvious problem. However, attempting to save the edited files results in another UE and any changes are lost.
I've tried all the fixes found in the forum so far, delete Built-in file, Run As Administrator, and so on with no success so far.
Version is 22.2, build 48.2. Windows 10 32bit. Loads of HD space.
At a bit of a loss here. Anyone had this problem and managed to fix it?

Logged


* October 21, 2015, 01:55:03 AM
#1
Can I ask how you obtained build 48.2, i.e. was it already on the disk / download or did auto update kick in one TC was installed, very occasionally auto update can result in something going wrong, not often but has happened in the past, some people (me) tend to get latest build via this forum.

Unfortunately I have no experience of 32 bit W10.

Logged


* October 21, 2015, 02:01:51 AM
#2
48.2 was loaded as an automatic update. However, the problem was present before the update was applied as well.

Logged


October 21, 2015, 02:33:54 AM
#3
I sometimes have this problem. I think it has something to do with Windows Explorer.
I usually restart my computer and the problem goes away for a while on my 64bit laptop.

Also sometimes we can have two instances of TC running even though we think the previous session has ended. When these sort of problems start this is the first thing I check.

On my 32bit Tablet convertible laptop I can have this problem also. I check when TC is not running that the program exe is not still active in Processes. If it is...right click end process in the Windows Task Manager.
« Last Edit: October 21, 2015, 04:19:29 AM by Darrel Durose »

Logged
Daz…

V2020 & V2019 Plat 64bit + REDsdk Plugin, Lenovo P72 Laptop, Window 10 Pro for Workstations, Intel Xeon E-2186 CPU @ 2.90 Ghz (6 cores/12 threads), 32GB RAM, 512GB & 1TB SSD's, Nvidia P5200 c/w Max=Q Design GPU, Display UHD 3840 x 2160 pixels
TurboCAD user since V3 and Turbocad 3D V1.


October 21, 2015, 05:00:55 AM
#4
Also worth checking your system if you have not already:

Run the  SFC   /SCANNOW    command. This will check and repair if necessary any critical Windows system files.


Click on Command Prompt option and select 'Run as administrator'.
(or "Safe Mode" open a Command prompt)
At the command prompt enter:  SFC  /SCANNOW

Logged
Daz…

V2020 & V2019 Plat 64bit + REDsdk Plugin, Lenovo P72 Laptop, Window 10 Pro for Workstations, Intel Xeon E-2186 CPU @ 2.90 Ghz (6 cores/12 threads), 32GB RAM, 512GB & 1TB SSD's, Nvidia P5200 c/w Max=Q Design GPU, Display UHD 3840 x 2160 pixels
TurboCAD user since V3 and Turbocad 3D V1.


* October 21, 2015, 08:35:16 AM
#5
Hi Darrel
Forgive delay in replying.
Hadn't thought about SFC. Used both that and DISM to check the Windows Image. Problems found and fixed - but not the UE problem with TC! Might try to reinstall and see what happens now that SFC etc has done it's thing.

Logged


* October 21, 2015, 08:44:16 AM
#6
Hi Darrel
Just re-read your last but one post. It might be worth pointing out that TC itself runs with no problem. I can create a new drawing or open an existing one, providing it's from the startup window. But I can't use the 'File - Open' or the 'File - Save As'. That's what gives the UE and shuts down the program.

Logged


October 21, 2015, 08:58:22 AM
#7
It could be your Windows User Account. On my 32bit Laptop I sometimes have to create a new User Account as the main account goes bad with TC.

This is mentioned here on the forum. It's worth a try to confirm it..

Logged
Daz…

V2020 & V2019 Plat 64bit + REDsdk Plugin, Lenovo P72 Laptop, Window 10 Pro for Workstations, Intel Xeon E-2186 CPU @ 2.90 Ghz (6 cores/12 threads), 32GB RAM, 512GB & 1TB SSD's, Nvidia P5200 c/w Max=Q Design GPU, Display UHD 3840 x 2160 pixels
TurboCAD user since V3 and Turbocad 3D V1.


October 21, 2015, 11:42:04 AM
#8

Logged
Daz…

V2020 & V2019 Plat 64bit + REDsdk Plugin, Lenovo P72 Laptop, Window 10 Pro for Workstations, Intel Xeon E-2186 CPU @ 2.90 Ghz (6 cores/12 threads), 32GB RAM, 512GB & 1TB SSD's, Nvidia P5200 c/w Max=Q Design GPU, Display UHD 3840 x 2160 pixels
TurboCAD user since V3 and Turbocad 3D V1.


* October 22, 2015, 11:13:32 AM
#9
Hi guys

After a day or so working away, I'm finally back in front of the computer. Just to see what would happen I started in Safe Mode. TC runs and opens files and stuff fine. Reboot normally - and TC still opens files as it should! I have had this before where running in Safe Mode will 'fix' something that was broken. Remains to be seen what happens when the machine if off overnight. Fingers crossed.

Logged