TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When posting a problem be sure to include which version you are using.  Give as much information as possible.  If the problem is with a specific file be sure to attache it to your post.

INSERT OPENING PROBLEM
Read 3032 times
* September 21, 2015, 01:45:53 AM
I have just restarted using turbocad (version 11 pro) after some time and discover I am having a problem creating openings in walls. I have created both a 2D and 3D block for the opening, assigned them to the opening properties, but when I try to insert it for some reason it wont place itself within the wall. I notice there is a message line that says "SPECIFY OPENING POSITION" but cant find a way of doing this. I have attached the file in question, obviously I am doing something wrong but if you could point out what that is I would be most grateful. Thank you

Logged


* September 21, 2015, 03:54:54 AM
#1
When you create the block make sure that the reference point is the middle (bottom) of the wall.

Logged
Nikki
TC20 platinum
TC 2015 platinum
TC 2017 with lightworks


* September 21, 2015, 05:21:07 AM
#2
Many thanks for your reply. I have examined the pdf file you kindly attached but I am not sure how you accomplish the setting of the reference points i.e. is this 2 separate operations?- by that I mean do you set the reference point when you create the block and then set the reference point for the wall?. I apologise for my ignorance but I can assure you I have studied the help files on reference points but they don't seem to help, I suspect I cannot see the wood for the trees! Thanks again for any further assistance you can give

Logged


* September 21, 2015, 05:57:46 AM
#3
When you create the block, before you create the block type d and move the reference point.

Logged
Nikki
TC20 platinum
TC 2015 platinum
TC 2017 with lightworks


* September 21, 2015, 07:59:06 AM
#4
Once again thank you for your reply. Unfortunately I appear to be still looking at this all wrong. I have studied the manual on creating openings and all it says to do is create a 2D and 3D block, assign them to the Opening properties, make sure Anchor to Wall is selected and then drag the block onto the wall. Actually, taking it literally, I am unable to 'drag' the block because as soon as I click on the Openings icon the block automatically appears and although it follows the layout of the wall with the mouse it just wont place itself when I click (as you will see from my example drawing).
Anyway I appreciate the time you have given me and it is obvious I have a lot to learn about reference points - hopefully one day it will all make sense - thanks again

Logged


* September 21, 2015, 10:47:19 AM
#5
it works for me with your example drawing

Logged
Nikki
TC20 platinum
TC 2015 platinum
TC 2017 with lightworks


* September 21, 2015, 10:54:07 AM
#6
Any chance you could attach the drawing with the changes you made? Hopefully I will be able to see how you did it - thanks

Logged


* September 21, 2015, 02:59:21 PM
#7
Go to the "Blocks" palette and select the "garagedoor_2d" block, then click on the "EC" icon (Edit Content).
The block will open in a new window.
Go to "Edit / Relocate Block Ref Point".
Your current Reference point will appear (yellow dot) and your cursor will become a hand.
Middle snap (M) the line representing the door. The point has been moved.
Click on the green "Finish Edit Content" icon in the Blocks palette.
Re-insert the Opening into the wall.

Hope this helps.

Logged
John R.

V17—V21, 2015—2020
Designer, Deluxe, (Basic, Expert, Professional), Platinum
RedSDK enabled
Windows 10 Pro (1909), 64-bit


* September 21, 2015, 08:07:23 PM
#8
Version 11 is really old - I cant save back that far

Logged
Nikki
TC20 platinum
TC 2015 platinum
TC 2017 with lightworks


* September 21, 2015, 10:16:49 PM
#9
Thank you for the example files and I understand now regarding setting the middle snap of the 2D block. However when I do this in my original file it still will not allow me to place the block. Even in the file you sent me if I attempt to place another opening on another part of the wall it will not allow me to do so and the message "SPECIFY OPENING POSITION" appears again (see attached snapshot). This makes me think that I should perhaps be doing something with the wall first? I know I am doing something stupid here but for the life of me I don't know what. Many thanks for your help

Logged


* September 21, 2015, 11:10:09 PM
#10
just click on the wall where you want to place the door

Logged
Nikki
TC20 platinum
TC 2015 platinum
TC 2017 with lightworks


* September 21, 2015, 11:29:45 PM
#11
Obviously I do that but nothing happens, the block continues to move with the mouse along the path of the walls but when I click to insert it wont

Logged


* September 22, 2015, 02:37:38 AM
#12
Okay, sorry about this but it appears this problem is to do with the software. I installed it on another machine and I can now place the openings. I can only imagine the initial install became corrupted. Thank you all for your input, it has been helpful anyway

Logged