TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Be sure your post is relevant to the current discussion.  Create a new topic within the appropriate board if you are unsure.

make solid 3d object for 3d subtraction
Read 2543 times
* September 14, 2015, 07:32:37 AM
Dear All

Got a question here, please help.
As attached, I tried to create 3d object from the red wire frame as, so I can do the subtract from another object.
Please kindly advice how to make it work.

Thanks in advance.

Best Regards
Simon

Logged
=================
Yuansheng Tsai
tsai.yuansheng@gmail.com

Windows 10 Pro
TurboCAD 2015 Professional 64-bit - Platinum Edition
Version: 22.2     Build: 90.0


* September 14, 2015, 08:13:18 AM
#1

Please kindly advice how to make it work.

Simon,
Create polylines of the top and bottom profiles, then use the Loft tool to connect them. The result will be a solid. See attached.
« Last Edit: September 14, 2015, 08:29:54 AM by DonCW »

Logged
DonCW
2017 Pro with Light Works Plug in
2018 Platinum
2020 Platinum

Windows 10
There's so much to learn and not much time left to learn it.


* September 14, 2015, 09:41:00 AM
#2
DonCW
Thank you very much.  :)
One more question, please refer to attached, just wonder what's the cause of the different result on the curvature surface...
Thanks.
Best Regards
Simon

Logged
=================
Yuansheng Tsai
tsai.yuansheng@gmail.com

Windows 10 Pro
TurboCAD 2015 Professional 64-bit - Platinum Edition
Version: 22.2     Build: 90.0


* September 14, 2015, 10:12:57 AM
#3
DonCW
Thank you very much.  :)
One more question, please refer to attached, just wonder what's the cause of the different result on the curvature surface...

Simon, The top and bottom profiles were created using the Polyline tool. The curves in both profiles are true arcs and that is why the blue loft on the left shows a smoother arc surface.
The numerous lines showing in the arc of the right screenshot are caused by the fact that the arc is segmented.

Logged
DonCW
2017 Pro with Light Works Plug in
2018 Platinum
2020 Platinum

Windows 10
There's so much to learn and not much time left to learn it.


* September 14, 2015, 05:17:03 PM
#4
Ah~ Found the problem.

It turns out that if I enable 3D (2D/3D button) for the 'JoinPolyline', the curve will be segmented.
Guess I shouldn't switch to it unless really necessary.

Thanks, DonCW.

Best Regards
Simon

Logged
=================
Yuansheng Tsai
tsai.yuansheng@gmail.com

Windows 10 Pro
TurboCAD 2015 Professional 64-bit - Platinum Edition
Version: 22.2     Build: 90.0


* September 14, 2015, 06:13:34 PM
#5
Ah~ Found the problem.

It turns out that if I enable 3D (2D/3D button) for the 'JoinPolyline', the curve will be segmented.
Guess I shouldn't switch to it unless really necessary.

Thanks, DonCW.

Best Regards
Simon

I glad to be of help when I'm able to.

Logged
DonCW
2017 Pro with Light Works Plug in
2018 Platinum
2020 Platinum

Windows 10
There's so much to learn and not much time left to learn it.


* September 14, 2015, 10:20:00 PM
#6
DonCW...

Even I know I shouldn't apply 3D JoinPolyline, I can't join polyline with 2D only easily.  :(
The only way is to apply on place on workplane. Otherwise I got deformed result, or object not closed.

I had to duplicate both and place on workplane, then move back to their original location.
I also did some searches and found this had been discussed, by you and others.

Just wonder...
1. did you encounter the problem when you create/loft the object? how do you over come the problem (any better approaches)?
2.  as lofting can apply on either all open or all closed object, can I work on my case as open objects?

Thanks in advance.
Best Regards
Simon




Thanks!
Best Regards
Simon
« Last Edit: September 14, 2015, 11:00:34 PM by Yuansheng »

Logged
=================
Yuansheng Tsai
tsai.yuansheng@gmail.com

Windows 10 Pro
TurboCAD 2015 Professional 64-bit - Platinum Edition
Version: 22.2     Build: 90.0


September 16, 2015, 10:58:58 PM
#7
It turns out that if I enable 3D (2D/3D button) for the 'JoinPolyline', the curve will be segmented.
Guess I shouldn't switch to it unless really necessary.

Well, this is fascinating information.  It never occurred to me to try a Loft in 2D mode to prevent segmentation of curves.

Thanks for the information.


Jeff

Logged
TC Pro Platinum 2020, 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1