TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
The purpose of these forums is to discuss TurboCAD.  Please keep the discussion of other products to compatibility issues or how the other software’s can be used with TurboCAD.


Inconsistant Units
Read 2476 times
* August 12, 2015, 03:50:06 AM
Don't you just love it!
I always work in metric and needed a quick answer to a volume query, so I drew a closed polyline and checked the Selection properties to get the area. It was present in square inches. All the other dimensions are metric, but not the area.
After extruding I got the volume in mm3.

Logged
Gary Wooding
Win10 64-bit,
TC21.2 x64 Plat, Bld59
TC16.2 Plat, Bld54.0
TCC 3.5


* August 12, 2015, 04:19:53 AM
#1
yep - same results here,  turning off 'convert units after alteration' in drawing setup - space units,  keeps the area as mm for me.

Though I guess turning this off may cause other problems if one changes the units.

Logged


* August 12, 2015, 05:03:56 AM
#2
I always work in inches, but if I change "Area Units" to mm in Space Units, selection info will show the area in millimeters, even though it will still show the perimeter in inches. At least it does in 2015.

Logged
TC 21 Deluxe, TC 20 Platinum, TC 2015 Platinum, TC 2016 Platinum, TC 2017 Platinum
i7- 3770 Ivy Bridge 3.4 GHz, 16G Crucial Ballistic, ASRock Extreme 4, EVGA 1060 SSC, Windows 10 Pro 64 Bit


* August 12, 2015, 09:48:58 AM
#3
Jason, if you turn off "Show all units", it will show only Imperial units for an Area. I suspect Gary has this turned on also. If it's on, you can select whatever available units that you want the Area to report.

Logged
John R.

V17—V21, 2015—2020
Designer, Deluxe, (Basic, Expert, Professional), Platinum
RedSDK enabled
Windows 10 Pro (1909), 64-bit


* August 13, 2015, 02:18:15 AM
#4
Here's my settings...

Logged
Gary Wooding
Win10 64-bit,
TC21.2 x64 Plat, Bld59
TC16.2 Plat, Bld54.0
TCC 3.5


August 13, 2015, 02:31:52 AM
#5
Gary

This is a bug I think and I find sometimes I have to change the properties to another unit type then back again so the info displays the correct unit measurement again.

This was also noted in another topic here - http://forums.turbocad.com/index.php/topic,16473.msg96839.html#msg96839

Logged
Daz…

V2020 & V2019 Plat 64bit + REDsdk Plugin, Lenovo P72 Laptop, Window 10 Pro for Workstations, Intel Xeon E-2186 CPU @ 2.90 Ghz (6 cores/12 threads), 32GB RAM, 512GB & 1TB SSD's, Nvidia P5200 c/w Max=Q Design GPU, Display UHD 3840 x 2160 pixels
TurboCAD user since V3 and Turbocad 3D V1.


August 13, 2015, 04:10:04 AM
#6
I wonder what happens if you run through the Page Setup Wizard one time (no open Drawings), selecting all the "Metric" options.

Also:  Is there a "Program Defaults" setting for this, available via TcExplorer Palette?  Maybe  review the The Wiki chart, listing the "program defaults" settings, what they do, and the default values.

Logged
Alvin Gregorio
Intermittent TurboCAD user since yr. 2000 (ver6.5).  No formal CAD Training.
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* August 13, 2015, 09:20:30 AM
#7
I wonder if wiping out the "Built-In" files, then starting TC would help here. I don't use the "Area" property enough to notice if it reports the wrong units. I just tried it, but this BUG isn't occurring.

As far as I know, there isn't any visible setting for that "Area" setting in TurboCAD Explorer.

Logged
John R.

V17—V21, 2015—2020
Designer, Deluxe, (Basic, Expert, Professional), Platinum
RedSDK enabled
Windows 10 Pro (1909), 64-bit