TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Remember to do a search before you ask a question!!!

RED Hidden Line
Read 3987 times
* June 04, 2015, 08:10:55 AM
This is probably one of those REDSdk quirks, but I'll throw it out there anyway.

  I have this drawing I'm working on. It is an all metal building for my brother. I have drawn everything as close to actual dimensions as possible. The wall sheets
are drawn as 20 gauge (0.035"). The wall and roof sheet were created by extruding a polyline. The drawing is a 1:1 scale.
 The quirk I see is that when I view the entire drawing from afar, the rafters and wall beams show up through the sheet metal, but fade away as I zoom in closely. I tried moving the sheets away from the rafters about 1/8", but the view persist.
  Is there a way to prevent this from happening? Or do I just live with it as a REDSdk anomaly.
  I should point out that I am using RED in this situation because it is a lot faster to manipulate the drawing in hidden line when compared to Light Works hidden line. The "bleed through" doesn't show up in Light Works. It's a fairly large file at 26KB.
  See attached for views from afar and close, as well as a capture of drawing setup for REDSdk

Logged
TC 21 Deluxe, TC 20 Platinum, TC 2015 Platinum, TC 2016 Platinum, TC 2017 Platinum
i7- 3770 Ivy Bridge 3.4 GHz, 16G Crucial Ballistic, ASRock Extreme 4, EVGA 1060 SSC, Windows 10 Pro 64 Bit


* June 04, 2015, 08:20:01 AM
#1
Try changing Transparency to 0

Torfinn

Logged
V20, V21, 2015/ 16/ 17/ 18/ 19 Pro. Platinum
Deluxe 2015/ 16/ 19
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* June 04, 2015, 10:52:03 AM
#2
Thanks, Torfinn. But that doesn't change the hidden lines when viewed from afar. I tried with different options enable/disable but no change. It's really not a big deal to me, I'll use LW hidden line for printing when I'm done. It's just nice to have the speed response of RED with such a large file when in hidden line.

Logged
TC 21 Deluxe, TC 20 Platinum, TC 2015 Platinum, TC 2016 Platinum, TC 2017 Platinum
i7- 3770 Ivy Bridge 3.4 GHz, 16G Crucial Ballistic, ASRock Extreme 4, EVGA 1060 SSC, Windows 10 Pro 64 Bit


* June 04, 2015, 12:18:11 PM
#3
I think this a BUG with RedSDK.

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1903), 64-bit


June 15, 2015, 02:12:02 PM
#4
Can you post the drawing file?

Also in the RedSDK settings you had posted in your screenshot transparency is still set to 1. I'm assuming you changed that after Torfinns suggestion.

Logged


* June 16, 2015, 05:16:10 AM
#5
Travis, I did changed transparency as requested. To reiterate, I see the hidden lines only when viewing the drawing full screen, but the lines disappear when zoomed in. And it's only part of the structures immediately behind the sheet metal of the building. The file is too big to post here ,it is 29MB. Even zipped it is about 5MB. I posted it to drop box so anyone can take a look. Here is the link:
https://www.dropbox.com/s/uwl4nqr07py46vt/Building%20High%20Peak.zip?dl=0

Logged
TC 21 Deluxe, TC 20 Platinum, TC 2015 Platinum, TC 2016 Platinum, TC 2017 Platinum
i7- 3770 Ivy Bridge 3.4 GHz, 16G Crucial Ballistic, ASRock Extreme 4, EVGA 1060 SSC, Windows 10 Pro 64 Bit


June 16, 2015, 05:58:08 AM
#6
Jason,

I downloaded and tried this, but, I cannot repeat your problem.  :-[
I have no suggestions.  However, it may be graphic card related

Regards Tim

Logged
Regards Tim

You can design without engineering, but you cannot engineer without design.
Using Win 10 with Designer 2016/2017 and TurboCAD Pro. Plat. 2018/2019 + Lightworks (64-bit versions) + AnimationLab 5.2.
Windows 10 Pro (1909) 64-bit


* June 16, 2015, 07:00:56 AM
#7
I see the hidden lines only when viewing the drawing full screen, but the lines disappear when zoomed in. Here is the link:

I Just downloaded your file and can replicate your findings (so its not just your computer), sorry - no idea what causes it. my graphics card is Nvidia  660 which is on the Red supported list.

Logged


* June 16, 2015, 11:57:58 AM
#8
Thanks for taking a look Tim and Andy. Odd that one of you see it, the other doesn't. It's really not a big deal. I normally used LW hidden line, but as you may have noticed this file is big. LW hidden line is very sluggish with this file, where as the RedSDK hidden line has quick response. I did see this glitch on both my PC's, so I didn't think it a computer problem.

PS. The reason I don't stick with RED, is I don't like the fuzzy lines with view ports in paper space.

Logged
TC 21 Deluxe, TC 20 Platinum, TC 2015 Platinum, TC 2016 Platinum, TC 2017 Platinum
i7- 3770 Ivy Bridge 3.4 GHz, 16G Crucial Ballistic, ASRock Extreme 4, EVGA 1060 SSC, Windows 10 Pro 64 Bit


June 16, 2015, 12:41:36 PM
#9

Jason,

I have tried this file again, by saving as a v21 file - v22/RedSDK doesn't like my Nvidia Quadro graphics card.  ::)
And, I can now replicate the problem when running with RedSDK.
Now that I can see the problem, I have to say it looks very much like software related - i.e. RedSDK!
I appears to be connected to the distance the camera is away from each unwanted line.
Zooming in removes the lines but more slowly the greater the distance.
I know this is of little help, but, we'll just have to wait for the developers to improve things.

Regards Tim

Logged
Regards Tim

You can design without engineering, but you cannot engineer without design.
Using Win 10 with Designer 2016/2017 and TurboCAD Pro. Plat. 2018/2019 + Lightworks (64-bit versions) + AnimationLab 5.2.
Windows 10 Pro (1909) 64-bit


June 17, 2015, 01:43:22 PM
#10
I forwarded this thread and the dropbox link to the product manager and he was able to duplicate the issue so it's something we'll be trying to fix sooner or later.

Logged


* June 17, 2015, 02:01:59 PM
#11
Thanks for the feedback Tim.  I can confirm this problem with your file.  We'll get this sorted out ASAP.

Jason regarding your comment.
Quote
PS. The reason I don't stick with RED, is I don't like the fuzzy lines with view ports in paper space.

Sounds like either you need to hit F5 to refresh and/or enable anti-aliasing under Options |  Native Draw.
« Last Edit: June 17, 2015, 02:05:29 PM by Dave Taylor »

Logged


* June 18, 2015, 07:18:17 AM
#12
Dave, I set anti-alias to 8 and this seemed to clear up the fuzzy in model space. But I found that while I had Native Draw set to Red and Render Type as Red and mode as Red Hidden Line in model space, I had my view port as Hidden Line/Hidden Line. When I switch the view port render to Red Hidden Line, that cleared up the fuzzy.

But note that I get the unwanted hidden lines as discussed earlier. See the attached file "Capture 1". Also notice that if I "Save As" PNG directly in TC, those lines don't show. See attached 'HPU Skid".

Logged
TC 21 Deluxe, TC 20 Platinum, TC 2015 Platinum, TC 2016 Platinum, TC 2017 Platinum
i7- 3770 Ivy Bridge 3.4 GHz, 16G Crucial Ballistic, ASRock Extreme 4, EVGA 1060 SSC, Windows 10 Pro 64 Bit


* June 18, 2015, 01:35:18 PM
#13
This is what I get in a YouTube movie: JasonB Hidden Line Problem. It fades away as I zoom in and returns as I zoom out.

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1903), 64-bit