TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
All posts discussing pricing or where to buy TurboCAD will be deleted.

Paper Space to Paper
Read 3031 times
* March 22, 2014, 01:55:49 PM
For years, I have been avoiding paper space because I was always wanting a slightly different view and it was easiest to just set that up in model space and take it from there.  Following some leads in another thread about another problem, now solved (hooray), I got introduced to paper space and I can see that, for the current project, it has some real attractions since I can create and edit some standard views and print them all to the same scale.  The drawing in this case is of a garden which is 110' on a side with a fence in 11' from the outside and gateways and walks coming in from the center of each side.  Each quadrant inside the fence is run by a different group and thus makes a sensible view.  Each of the four borders is also run by a separate group.  That is very long and thin, so we want to break that into two pieces and print them over and under (from a landscape perspective).

So, for the quadrants, I create a landscape paper space, a view in the model, then put a viewport on the paper.  I diddle with the sizes and alignment and apply a standard fixed scale and we are in business.  I just print that to a laser using View and Landscape and I have a nicely filled page.

For the North border, i.e., the one at the top of the drawing, I create the landscape paper space, two views for the left and right half, and put two viewports on the paper over and under.  Diddle as above and print as above and I get exactly what I expect.

For the West border, the one at the left of the drawing, I have an issue because the two halves run the wrong way for a landscape sheet so I either need to rotate the viewport on the paper or lay it out portrait.  So, I since I haven't been able to figure out how to rotate, I created a paper space, converted it to portrait, zoom extents so I can see it all, drew the two views, and put two viewports on the paper left and right, i.e., the same size and placement on the paper as if the paper were the North border example.   On the screen, it looks ducky.   When I print it using View and Portrait, however, I am ending up with two viewports which are much smaller than the others, despite the fact that I can see they have the same size.  They are correctly oriented on the paper, but much too small.  This also happens if I print to PDF.

So, what am I missing?

Logged
Thomas Mercer-Hursh, TC Pro 15


* March 22, 2014, 03:47:48 PM
#1
re: Rotating a viewport…

You can go to the "Camera" page for a Viewport and change the "UP Vector" settings. A normal plan view is 0,1,0. To Rotate Left use 1,0,0. To Rotate Right use -1,0,0. You can also do this in Modelspace with Camera Properties (Ctrl+Alt+C), then save as a Named View. I used named views on Paper1, 2 & 3, with a custom VP boundary on Paper3.

Hope this helps.

Logged
John R.

V17—V21, 2015—2020
Designer, Deluxe, (Basic, Expert, Professional), Platinum
RedSDK enabled
Windows 10 Pro (1909), 64-bit


March 22, 2014, 03:51:21 PM
#2
...

For the West border, the one at the left of the drawing, I have an issue because the two halves run the wrong way for a landscape sheet so I either need to rotate the viewport on the paper or lay it out portrait.  So, I since I haven't been able to figure out how to rotate, I created a paper space, converted it to portrait, zoom extents so I can see it all, drew the two views, and put two viewports on the paper left and right, i.e., the same size and placement on the paper as if the paper were the North border example.   On the screen, it looks ducky.   When I print it using View and Portrait, however, I am ending up with two viewports which are much smaller than the others, despite the fact that I can see they have the same size.  They are correctly oriented on the paper, but much too small.  This also happens if I print to PDF.

So, what am I missing?

When you go to Print, in the Printer settings that come up, when you check Print Range= "View", TurboCAD automatically checks the "Fit on 1 page" box.  See if that happens in your case; and see if un-checking it helps you out.

____
There are a couple of better alternatives than the method you just described:

One is to first have created a rotated View in Modelspace, then save that View by going to View/"Named View".
We can get a rotated View in Modelspace by using the Camera Tools (Camera Rotate Left; or Camera Rotate Right... they usually move one-quarter of 90° with each click (with the Scroll Speed set at its default, I think), but with your Drawing, I'm not having that luck... of course).
   Alternatively, we can rotate the View in Modelspace* by going to the Camera Properties page and changining the values in the "Up Vector".  For what I think you are after, that would be: X= -1; Y=0; Z=0 (if that's wrong for what you are asking, play around with it).

*This can also be done from within Paperspace:  Select the Viewport; in Menu/Workspace, click on "Model Space (Floating)", and you are now (temporarily) working in Modelspace.  But be careful, if you don't have the right things checked in Viewport Properties, you can completely mess up your View in the Viewport.

____
Layer Sets:  As you may already know, we can assign Layer Sets in Modelspace and in a Viewport's Properties.  That's very handy.
When I'm working in Modelspace, I only want to be working with a particular set of Layers that I want to eventually be visible in a Paperspace Viewport; I want to work with what is actually going to be in the Viewport, and I want to see what it's going to look like as I'm drawing in Modelspace.
« Last Edit: March 22, 2014, 03:54:43 PM by Alvin Gregorio »

Logged
Alvin Gregorio
Intermittent TurboCAD user since yr. 2000 (ver6.5).  No formal CAD Training.
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* March 23, 2014, 07:21:46 AM
#3
The fit on one page did not help.  I get the output at the right size, but positioned incorrectly on the paper, as if TC thought the layout was landscape, but printing it to portrait paper.

I'm going to try John R's suggestion and then explore your suggestions as needed. 

BTW, I like the fact that I can change the visible layers in paper space for different effects.

Logged
Thomas Mercer-Hursh, TC Pro 15


* March 23, 2014, 08:34:30 AM
#4
John, worked a treat!  Just exactly what I wanted!

Logged
Thomas Mercer-Hursh, TC Pro 15


* March 23, 2014, 11:08:07 AM
#5
One problem I came across was that the checkboxes in the "Visible Layers" list in the Selection Info palette and the checkboxes in the "Layer Name" list (Properties dialog, Viewport page) didn't always match. I found it best (in this particular version) to use the Properties dialog to turn layers on/off in a Viewport. I think everything else is pretty well connected between Properties and Selection Info. In later versions they fixed this particular Visible Layers problem and the ability to expand the list to make Layer selection/deselection easier.

Logged
John R.

V17—V21, 2015—2020
Designer, Deluxe, (Basic, Expert, Professional), Platinum
RedSDK enabled
Windows 10 Pro (1909), 64-bit


* March 23, 2014, 11:34:13 AM
#6
I haven't run into a lot of problem with this area ... at least not yet.  My manipulation is limited to turning on and off one layer in a few spots so far.

Logged
Thomas Mercer-Hursh, TC Pro 15


* March 23, 2014, 11:30:35 PM
#7
...
*This can also be done from within Paperspace:  Select the Viewport; in Menu/Workspace, click on "Model Space (Floating)", and you are now (temporarily) working in Modelspace.  But be careful, if you don't have the right things checked in Viewport Properties, you can completely mess up your View in the Viewport.

____


That's an easy fix though, if you do mess things up and you want to start over, by clicking view name in viewport in either selection info pallette, or properties dialog, and selecting the view name you started with.

Dan
« Last Edit: March 23, 2014, 11:32:57 PM by Wooddan »

Logged
Deluxe 16.2
Pro Platinum 18.2
Running on HP HDX laptop w/win7 Home Intel Duo Core, 2.53GHz 4GB RAM, 64Bit OS


March 24, 2014, 06:48:57 AM
#8
...
*This can also be done from within Paperspace:  Select the Viewport; in Menu/Workspace, click on "Model Space (Floating)", and you are now (temporarily) working in Modelspace.  But be careful, if you don't have the right things checked in Viewport Properties, you can completely mess up your View in the Viewport.

____


That's an easy fix though, if you do mess things up and you want to start over, by clicking view name in viewport in either selection info pallette, or properties dialog, and selecting the view name you started with.

Dan

Yes.  In addition:  In recent versions of TurboCAD, we can choose Lock Camera and/or Lock Scale in Viewport Properties/Viewport page.

Credit John R. for reminding of this the other day.

Logged
Alvin Gregorio
Intermittent TurboCAD user since yr. 2000 (ver6.5).  No formal CAD Training.
---TurboCAD: V21PP; V20.2PP; V19DL; V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* March 24, 2014, 09:10:46 AM
#9
BTW, for the record I now have captured all of my views in paper space and it is really quite lovely.  The only problem I have is scale.  I have a series of detail views at 1:75 that fill the paper nicely although it ends up with the print being 6' = 7/8", which is a little hard to measure ... although I'm not sure that is important.  But, if I want to print the whole garden and keep to some even multiple of this scale, I can fit everything on the paper at 1:225, but then it doesn't fill the paper very well.  I'm not sure that it matters to keep something even, particularly if it is something not easily measured anyway, but it is my one awkwardness at this point.

Logged
Thomas Mercer-Hursh, TC Pro 15