TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When posting a problem be sure to include which version you are using.  Give as much information as possible.  If the problem is with a specific file be sure to attache it to your post.

Quick Help needed for TC 19 Platinum
Read 5097 times
* May 01, 2013, 04:43:16 AM
Two quick items

Page setup wizard will not save settings. This was true for all previous versions I have owned since TC 5


Major problem right now is my Dimensioning in Viewports in a scaled drawings will not show calculated correct values.

ie; Draw a 1 in block, make a viewport in paperspace, scale veiwport to 2:1,  Dimensions will show actual size at 2 inches and not calculate back to 1 inch.

It has happened in other versions but corrects itself in new drawings and such. TC 19 is not correcting now.  I have restarted TC and rebooted
my win 7 64bit computer. still no go.

Thanks in advance,

Malodave

Logged


* May 01, 2013, 04:55:59 AM
#1
Are you placing the dimension first? The dimension will not show the correct value, until you left click the dimension in place.

Only thing I can thing of offhand.

Logged
AMD Phenom 1090T
8GB RAM
Radeon 5450 1GB
Windows 7
Redsdk  - Off
Editing History - On
v19.2 Platinum, x64


* May 01, 2013, 05:40:15 AM
#2
Yes I am using snaps to verticies and centers.

Malodave

Logged


* May 01, 2013, 05:46:01 AM
#3
I wasn't talking about using snaps...

Logged
AMD Phenom 1090T
8GB RAM
Radeon 5450 1GB
Windows 7
Redsdk  - Off
Editing History - On
v19.2 Platinum, x64


* May 01, 2013, 05:55:56 AM
#4
If I just click both points in paperspace I get the true paperspace dimensions.

I am using snaps in a viewport that normally recalculate to model space true dimensions on a scaled object in Paperspace Viewport

Malodave

Logged


* May 01, 2013, 05:57:42 AM
#5
What happens after you make the third click... after you place the dimension? Does it update to the correct value then?
« Last Edit: May 01, 2013, 06:31:58 AM by GregT »

Logged
AMD Phenom 1090T
8GB RAM
Radeon 5450 1GB
Windows 7
Redsdk  - Off
Editing History - On
v19.2 Platinum, x64


* May 01, 2013, 09:05:12 AM
#6
No, it puts the actual paperspace dimension. It does not recalculate to the scaled dimension. It just started doing this about two days ago. But the same thing happens occasionally in previous versions.

Malodave

Logged


* May 01, 2013, 09:13:36 AM
#7
Post the drawing or a sample drawing where this problem occurs.

Logged
John R.

V17—V21, 2015—2020
Designer, Deluxe, (Basic, Expert, Professional), Platinum
RedSDK enabled
Windows 10 Pro (1909), 64-bit


* May 01, 2013, 09:27:34 AM
#8
It is something in the program.  I can start a new file, draw a one inch box, create a viewport, make viewport in paperspace, Scale to 2:1, click orthogonal dimension tool, snap points to two of the verticies and finish. The dimension will show 2 inches and not recalculate to the one inch measurement like it should.

Malodave

Logged


* May 01, 2013, 09:56:09 AM
#9
Maybe you have a corrupt ini file. Close Tc and delete the tcw19_xml.inii file and restart. Make a backup of the ini file first... just in case.

Logged
AMD Phenom 1090T
8GB RAM
Radeon 5450 1GB
Windows 7
Redsdk  - Off
Editing History - On
v19.2 Platinum, x64


* May 01, 2013, 10:11:13 AM
#10
The only way I can make a dimension in a paperspace not work, is to dimension off of the leg of an existing dimension. If I click both dimension points on the object in paperspace, I get the correct dimension, once it has been placed. I doubt if this is your case. Maybe Greg's suggestion of deleting the INI file will work.

Logged
John R.

V17—V21, 2015—2020
Designer, Deluxe, (Basic, Expert, Professional), Platinum
RedSDK enabled
Windows 10 Pro (1909), 64-bit


* May 01, 2013, 01:09:08 PM
#11
I tried renamed the ini file. when I restarted TC it regenerated the file. I renamed that one too, then restarted TC. I made a 2D square 1" x 1". created a viewport in paperspace and scaled the viewport to 2:1. Dimensioning is still giving me 2 inches instead of the 1" the square actually is.

I know if I just click somewhere or use something drawn in paperspace the dimensioning would be for the item on paperspace and not what is drawn on modelspace.

Malodave

Logged


* May 02, 2013, 07:43:00 AM
#12
This problem seem to stem from Associative Dimensions. The Box is tick in properties/format  dialog box, but there is no association performed. It gives me actual paper space dimensions and not scaled viewport dimensions.

Malodave

Logged


* May 02, 2013, 08:06:39 AM
#13
I cannot duplicate your problem either with, or without Associative being checked.

Logged
AMD Phenom 1090T
8GB RAM
Radeon 5450 1GB
Windows 7
Redsdk  - Off
Editing History - On
v19.2 Platinum, x64


* May 02, 2013, 10:31:06 AM
#14
I found this online and it seems to have fixed the problem:


Common troubleshooting procedures for TurboCAD

Run as administer… (Vista/Win7 only)

The first step in trouble shooting just about any problem with TurboCAD is starting TurboCAD by right clicking the desktop icon and choosing run as administrator.

This will fix problems related to registry virtualization.

The most common issues related to registry virtualization.   TurboCAD asking for activation every time you load, and TurboCAD not being able to read the serial number resulting in the error message “Your serial number is either missing or incorrect”

Other problems could occur from TurboCAD not being able to load .dll files correctly because registry virtualization has not raised the user level for running TC.

This can result in tools not being available, TC not behaving correctly.  TurboCAD not starting correctly and TurboCAD crashing.

So Run as administrator is a good place to start troubleshooting any issue.

Logged


* May 02, 2013, 10:46:51 AM
#15
Glad you've discovered a fix.

Logged
AMD Phenom 1090T
8GB RAM
Radeon 5450 1GB
Windows 7
Redsdk  - Off
Editing History - On
v19.2 Platinum, x64