TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Remember to do a search before you ask a question!!!

I can't get my new TurboCad 17 to load
Read 2082 times
* October 20, 2012, 09:13:12 PM
Hi everyone, a real noobe here.

I can't get TurboCAD 17 to load on to my HP Lap Top.  I am using Microsoft windows XP.

I went to control panel add/remove programs, add new program, clic on from cd, and it could not find the install program on install wizard.
It seams to me that TurboCAD does not have a user friendly way to install its self all on its own.

I typed in c:\setup.exe and d:\setup.exe and both could not be found.

Any sugestions, please.  :)


* October 21, 2012, 03:12:27 AM
If you dont have autorun on your cd player, go to my computer-cdplayer(D:) and find the setup.exe inside there, click and run


V20, V21, 2015/ 16/ 17/ 18/ 19 Pro. Platinum
Deluxe 2015/ 16/ 19
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB

* October 21, 2012, 06:00:59 AM
I'm wondering, is V17 on a DVD and you have a CD player? I remember running into that problem with my XP machine and had to get an external DVD player to read those incompatible discs.

John R.

V17—V21, 2015—2020
Designer, Deluxe, (Basic, Expert, Professional), Platinum
RedSDK enabled
Windows 10 Pro (1909), 64-bit

* October 21, 2012, 07:51:05 AM
v17 is on a dvd and i bet you only have cd drive on that laptop .     copy the dvd to a jumpdrive from a computer that has a dvd drive then install on your laptop .   good luck and enjoy v 17 i have that one and find it meets my needs

Win 10  TC 17 Pro Plat

* October 21, 2012, 10:30:32 AM
Thank you
Torfinn,John R, Knuckelhead

I will try the transfer From CD to DVD.

I sent an e-mail to TurboCAD along with my new serial # and asked for a v17 on a CD.  Not available on CD.
They sent me a downloadable link, so I could load the v17, directally.
Mark was very helpful he gave me all of the info needed to load it up.
Now trying to learn v17

« Last Edit: October 22, 2012, 12:28:44 PM by Jay Stratton »