TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
The purpose of these forums is to discuss TurboCAD.  Please keep the discussion of other products to compatibility issues or how the other software’s can be used with TurboCAD.


Turbocad 2016 Pro Platinum closing automatically when idle
Read 1329 times
* October 12, 2019, 09:15:38 AM
HI everyone. This has been happening for a while and is frustrating. I don't believe it always did this on this computer. With the program open and a drawing open, whether a new blank or large project it doesn't matter, the program will close after about 5 minutes or so on it's own. Giving no chance to save it. Yesterday with the program open but no drawing open, it stayed up for a long time till I closed it. My little 11" laptop does not do this. The suspect computer is running windows 10 64bit and this is TCad 2016's most recent update. I deleted the built in folder already and that didn't do anything. I am thinking I am looking at an reinstall but am hoping to not have to do that. I also have TC 14, 18, and 2015 installed. Anyone have any ideas? 

Logged
TC 14 pro.  TC 18, 21,22 pro platinum. 3 s10's and an s4. Creality Ender 5.


October 12, 2019, 09:51:17 AM
#1
I have not seen this issue, but does the issue go away if you turn off autosave in the program options? Just a thought....


October 12, 2019, 01:06:05 PM
#2
While not exactly the same, this sounds very much like another of the Windows 10 complaints I have been seeing (from afar, thankfully).

Here's a related link: https://www.windows10forums.com/articles/shutdown-after-pc-has-been-idle.41/

This one refers to a specific Windows 10 update and points out that you can roll back to an earlier version: https://www.bleepingcomputer.com/forums/t/682188/computer-constantly-shutting-down-within-minutes-after-recent-w10-update/

In Windows 7, I call up Power Options, maybe it's abilities have been upgraded for Windows 10.


Good luck,

Jeff




Logged
TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* October 12, 2019, 03:47:57 PM
#3
Thanks guys. Don, I turned off the auto save and the program has been on for many hours now without shutting down. So that seems to have perhaps bandaided the issue. I opened 2015 and that one worked just fine but did have a strange error message on startup. Jeff, I think the windows 10 update is the issue as these programs have been on the computer since I went from windows 8 to 10 or at least for as long as 10 came out. My little laptop that works flawlessly I have only had for a year so it hasn't gone through as many updates. I am wondering if the programs didn't get messed up somewhere along that time frame. I dislike the idea of uninstalling and reinstalling anything and with Don's suggestion things seem ok as of now. The program was crashing alot on me while I work on projects and I am wondering if it wasn't because it would try to autosave at the moment I was doing something else. So I will play it as it lays for a bit and also look into what you posted Jeff. Thanks guys.

Logged
TC 14 pro.  TC 18, 21,22 pro platinum. 3 s10's and an s4. Creality Ender 5.


October 12, 2019, 05:46:26 PM
#4
Thanks guys. Don, I turned off the auto save and the program has been on for many hours now without shutting down. So that seems to have perhaps bandaided the issue. I opened 2015 and that one worked just fine but did have a strange error message on startup. Jeff, I think the windows 10 update is the issue as these programs have been on the computer since I went from windows 8 to 10 or at least for as long as 10 came out. My little laptop that works flawlessly I have only had for a year so it hasn't gone through as many updates. I am wondering if the programs didn't get messed up somewhere along that time frame. I dislike the idea of uninstalling and reinstalling anything and with Don's suggestion things seem ok as of now. The program was crashing alot on me while I work on projects and I am wondering if it wasn't because it would try to autosave at the moment I was doing something else. So I will play it as it lays for a bit and also look into what you posted Jeff. Thanks guys.

I am happy to hear that my thought was helpful. I turned off autosave years ago (and with each install/update since) because it would inevitably start to autosave during a render or render save and ruin the process. I think the autosave needed/needs some help to know when it would be okay to autosave. I wouldn't know what that looks programming wise, but it should be possible.