TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Interested in some really terrific mobile apps? Visit www.turboapps.com for details.

No Line / Shape Preview
Read 1693 times
* January 14, 2018, 03:27:07 PM
Not sure if I hit something to cause this.  When I go to draw and click I do not get the outline and/or preview of whatever it is that I am going to draw.  When I click a second time...somewhere else on the screen the object I was attempting to draw completes.

So if I am drawing a circle I select the circle object from the toolbar, then I go to my model space and left click to commence drawing.   I get the fields in the bottom for radius etc but in the model space there is not dashed outline of the object.  If I fill thje field or click again the object is drawn.

Any idea what I hit?

Windows 10-  latest updates...Turbocad 2017 Platinum



Logged


* January 14, 2018, 04:08:07 PM
#1
If I change to GDI in native draw everything works as should.
The computer is a surface book with an onboard integrated graphics board and a separate Nvidia GPU.  Any thoughts.  Seemed to have happened after a firmware update and series of Patch Tuesday patches.

Logged


* January 14, 2018, 05:22:54 PM
#2
See if what's offered in this Post helps you any.  (Reply #14, that thread)

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* January 15, 2018, 06:34:12 AM
#3
So...after hours of messing around I shut down the computer and brought it to work today.....and now it works as expected in both modes...so as I used to preach in my previous life as a tech...reboot and call me back if you still have a problem.  :)

Logged


January 19, 2018, 11:47:01 PM
#4
What a relief. I was experiencing exactly the same issue after the most recent update to Windows 10 today. I also noticed that besides this rubber band / outlining effect not working, the snap aperture was not visible. I also have a Surface Book i7 with 16 gig Ram with the on board intergrated graphics and Nvidia GPU. I run Turbocad 2016 Pro Platinum. I uninstalled and reinstalled, deleted default folder etc... to no avail.

After reading http://forums.turbocad.com/index.php/topic,22080.msg133008.html#msg133008 and this thread, I decided to try and see if I could force Turbocad to utilise the on board integrated graphics via the Nvidia Control Panel. After achieving this I restarted Turbocad and hey presto, the rubber banding/ outlining / preview / whatever you want to call it was back.

So 4 hours of messing about, I find that it is some form of graphics driver incompatibility causing a key feature of Turbocad to stop working. My disappointment with my top of the line Surface Book continues. Having the Nvidia graphics card for this laptop and its supposed compatibility with 3D cad packages was the reason for buying it, and now I am forced to stop it working with Turbocad.

Logged
TurboCAD Pro Platinum 2018 64 bit
Civil Design Suite Plug In
Windows 10, i5 750@2.67, NVIDIA GeForce 1060 3GB
12GB Ram, SSD 1TB


* January 28, 2018, 11:39:46 AM
#5
So i never really solved this except to use the integrated processor, ignore the GPU and turn off REDSDK''....until today....

The auto-update of the NVIDIA driver for the surface book pro 1 in October breaks TurboCAD.

Here is what i did to be able to use the GPU again....

Go to the control panel and uninstall any and all references to nvidia.
Click windows button and type "System Settings" this opens system properties.
Click the hardware tab
Click Device Installation Settings
Select NO

This will automatically stop any hardware updates pushed down by MS.
I would suggest to periodically check for new updates firmware etc...use at your own risk

Driver version by nvidia that appears to still work is 378.49

There may also be a way to do this via the NVIDIA GEFORCE app...and simply back rev the graphics driver only. 





Logged


* January 28, 2018, 12:34:32 PM
#6
Well....back to where I started.  I can say for sure the new NVIDIA driver is causing the problem...i cannot keep windows from installing though.  Very frustrating.

Logged


January 29, 2018, 05:11:23 AM
#7
I share your frustration, although I have been able to keep REDSDK switched on.

Logged
TurboCAD Pro Platinum 2018 64 bit
Civil Design Suite Plug In
Windows 10, i5 750@2.67, NVIDIA GeForce 1060 3GB
12GB Ram, SSD 1TB