TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Interested in some really terrific mobile apps? Visit www.turboapps.com for details.

Version 19 Platinum: Problems At StartUp- Won't Start Up
Read 2883 times
* August 09, 2012, 02:54:01 PM
Hello All,

Finally got around to downloading and installing the Free Trial Version of TurboCAD 19 Platinum Edition.  I haven't downloaded or worked with any version more current than my installed/purchased ver. 11.2.  I have a 64-bit system and downloaded/installed the 64-bit TC 19 version.

The program is not Starting.  I am continually receiving the Error Messages shown in attached screen-captures.  It doesn't matter if I try to create a New drawing, or Open Existing, I receive the errors.  However, if I Start the program, without  creating a New drawing or Opening Existing there is no Error message- though, of course, I can't actually draw anything or use any tools.

When I do proceed to creating a New Drawing or Open an Existing drawing, I get the dialogue box regarding my graphic-card not being certified (it's an Intel HD graphics "card" on an HP laptop), followed by another dialogue box indicating that Redsdk needs to turn of Windows Aero (which I click to allow it to).

-----
I installed, un-installed, and installed again- with Windows 7 User Account Control "off", and Anti-Virus/Firewall disabled.  I used the Serial Number and Activation Code provided to me via e-mail by IMSI; that doesn't at all seem to be the issue.

----
I also attached a screen-capture of my system properties.  And a copy of the Error Report (if anyone knows what any of that stuff contained in the report means; I sure don't).

Any ideas anyone?
« Last Edit: August 09, 2012, 02:56:01 PM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* August 09, 2012, 03:07:49 PM
#1
"When I do proceed to creating a New Drawing or Open an Existing drawing, I get the dialogue box regarding my graphic-card not being certified (it's an Intel HD graphics "card" on an HP laptop), followed by another dialogue box indicating that Redsdk needs to turn of Windows Aero (which I click to allow it to)."

If the Options menu is available after you get to that point, go to "Native Draw" and enable GDI. I also recommend NOT enabling "Flicker free draw."

Henry H


Logged


* August 09, 2012, 03:25:35 PM
#2
"When I do proceed to creating a New Drawing or Open an Existing drawing, I get the dialogue box regarding my graphic-card not being certified (it's an Intel HD graphics "card" on an HP laptop), followed by another dialogue box indicating that Redsdk needs to turn of Windows Aero (which I click to allow it to)."

If the Options menu is available after you get to that point, go to "Native Draw" and enable GDI. I also recommend NOT enabling "Flicker free draw."

Henry H



Hi Henry- And Thanks for the Help.  That did it.  By doing what you advised (well, sort of what you said- instead of attempting to Open an existing drawing or Create New drawing- with no drawing open, I went to Options|Native Draw and selected GDI there) TurboCAD 19 Starts Up and behaves normally.

----
I might persue this on another thread, but:  Why did this happen?  Is it something about my system that won't allow the use of Redsdk? (my System properties are in a screen-capture in my post above)  If so- if I do go on to purchase the program- what limitations (or other concerns) are there if I have to use GDI and not Redsdk?  EDIT:  Upon Startup, I do receive a Window with a message indicating that my graphics card is supported, and suggesting that I enable Redsdk (attached screen-capture)

----
But, Thanks again! Henry on the quick reply and remedy to my original issue.

-Alvin
« Last Edit: August 09, 2012, 03:32:38 PM by Alvin Gregorio »

Logged
Alvin Gregorio
(mostly Residential Architectural 2D; no formal CAD Training; intermittent TurboCAD user since yr. 2000 [ver6.5])
---TurboCAD: V20.2PP(57.0)[as of 3/12/15]; V19DL(54.2); V11.2Pro; Windows-7-Pro/64-bit; Intel-Core-i3 CPU; 2.27ghz; 4GB RAM; Intel HD Graphics (CPU based)


* August 09, 2012, 04:29:10 PM
#3
Update your video drivers. Take two aspirins and call me in the morning.

Logged
WillR
SW:TC 21 Pro Platinum, FM15, 20 Pro Platinum 64 Bit, also V 19.1 64Bit & 32 bit 17.2 and 18.1; Furniture Maker 14 and 10. HW: Vista 64 Ultimate, AMD 1090 (6 core) 8GB memory Plus also an AMD  8 core systemFX


* August 09, 2012, 07:51:51 PM
#4
Re "Why did this happen?":

Don't really know, but I'm strongly inclined to believe it's because RedSDK is inherently a bag of worms. The one and only thing I like about it is that the RedSDK Draft rendering mode is incredibly fast. There are several things I strongly DISlike about it.

I have no complaints at all about GDI. As far as I can tell, that's what TCad has always used.

Henry H
« Last Edit: August 09, 2012, 07:55:42 PM by Henry Hubich »

Logged


* August 09, 2012, 09:06:00 PM
#5
If delete ini file it will reload itself.Might clear the error thing;Here is the file path.


"C:\Users\WD\AppData\Roaming\IMSIDesign\TurboCAD\19\Professional\Profiles\Built-in".

Logged
Even a mistake may turn out to be the one thing necessary to a worthwhile achievement Henry Ford
If I have ever made any valuable discoveries it has been owing more to patient attention than to any other talent Isaac Newton
I have not failed Ive just found 10,000 ways that won't work Thomas Edison