TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When replying to a specific statement be sure to quote the previous post.

Need advice from rendering experts
Read 3165 times
June 11, 2012, 02:41:16 PM
Hello Tcad fans..

I guess I am not really too much of an artist, but I was wondering if anyone could help me with rendering tips on this... It just does not seem to have any pizazz.. Trying to get to look like a shiny new car on the show room floor..

I know it probably is getting into the art side of things, but I have trouble rendering it nicely. Any advice?

Aram :o

Logged
1) Tcad V20 on HP Z10 Workstation 3.3ghz-4gb- 64bit- Nvidia Quadro 2000 Win 7
2) Tcad V20 on Lenovo D30 Workstation 2x- Xeon, 64bit, 16gb -Nvidia Quadro K2000 Win 8


* June 11, 2012, 09:03:55 PM
#1
I gave it a shot, but it's not shiny. Others do that better than I. I changed the bracket material to a Blue Plastic Coated enamel, turned off all the lights and used "Options / Render Scene Luminance". I created a luminance with "Simple Sky" using the settings shown below. You could probably get away with 400 for Samples. For Render Scene Environment I just used a dark Plain background (16,16,16), not black.
The other render used a graduated background and 400 Samples in the Luminance.

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1803), 64-bit


June 12, 2012, 09:59:21 AM
#2
John that is nothing short from amazing.  I think the rendering is almost a whole different program within tcad.

Did you modify any properties of the objects aside from the bracket? or just environment after that?

Thanks for the shot. This is a starting point perhaps..

Logged
1) Tcad V20 on HP Z10 Workstation 3.3ghz-4gb- 64bit- Nvidia Quadro 2000 Win 7
2) Tcad V20 on Lenovo D30 Workstation 2x- Xeon, 64bit, 16gb -Nvidia Quadro K2000 Win 8


June 12, 2012, 10:02:04 AM
#3
Also.. I have to apologize.. I posted the wrong drawing.. this is just a partial.. here is the complete..  Arrgggg!!

Logged
1) Tcad V20 on HP Z10 Workstation 3.3ghz-4gb- 64bit- Nvidia Quadro 2000 Win 7
2) Tcad V20 on Lenovo D30 Workstation 2x- Xeon, 64bit, 16gb -Nvidia Quadro K2000 Win 8


* June 12, 2012, 03:18:14 PM
#4
Same as before; no lights, just the above luminance. Custom Graduated background. Quality render: LW Raytrace Full (w/perspective @45). Rendered as-is and with the material changed on two parts.

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1803), 64-bit


June 13, 2012, 11:57:36 AM
#5
Geez that's awesome John... I should practice this... Still trying to get my background enviroments to show up.. T19 is quite diff from 17.2.

Thanks.. Let me study what you have done and take a crack at this.. I am also open to anyone else with ideas and techniques.

Aram ;)

Logged
1) Tcad V20 on HP Z10 Workstation 3.3ghz-4gb- 64bit- Nvidia Quadro 2000 Win 7
2) Tcad V20 on Lenovo D30 Workstation 2x- Xeon, 64bit, 16gb -Nvidia Quadro K2000 Win 8


* June 13, 2012, 12:32:23 PM
#6
re: …Still trying to get my background environments to show up…

"Options / Render Scene Environment". Use the "Background" category and pick "Graduated" from the Environment list. Click on "Edit Environment" to open the editor to this particular environment. Right-click on the highlighted Graduated name and choose "Copy Environment Here". Give it a unique name. Go to the new environment and edit the "graduated" shader section choosing/specifying any colors you want. OK out of the editor and your new environment should already be selected to use. OK back to the drawing.

You could also select any thumbnail from Environment palette, then right-click and choose "Set Environment".

If you're going to edit any of the supplied LightWorks Materials, Environments, etc., do it with a new named copy.

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1803), 64-bit


June 13, 2012, 03:52:43 PM
#7
I gave it a shot, but it's not shiny. Others do that better than I. I changed the bracket material to a Blue Plastic Coated enamel, turned off all the lights and used "Options / Render Scene Luminance". I created a luminance with "Simple Sky" using the settings shown below. You could probably get away with 400 for Samples. For Render Scene Environment I just used a dark Plain background (16,16,16), not black.
The other render used a graduated background and 400 Samples in the Luminance.

I think there is some missing info after Options/render Scene luminance.. Complex? Spots? etc..??? Then I can go to Simple Sky..

Aram

Logged
1) Tcad V20 on HP Z10 Workstation 3.3ghz-4gb- 64bit- Nvidia Quadro 2000 Win 7
2) Tcad V20 on Lenovo D30 Workstation 2x- Xeon, 64bit, 16gb -Nvidia Quadro K2000 Win 8


* June 14, 2012, 02:11:15 AM
#8
re: I think there is some missing info after Options/Render Scene Luminance.

…turned off all the lights and used "Options / Render Scene Luminance". I created a luminance with "Simple Sky" using the settings shown below.…

When in the LightWorks Editor you can create a sub-menu (Category) or add a new Luminance to an available Luminance Category. Once the luminance is created, select one of the "None" lights from the list and change it to "Simple Sky". Edit the settings. This newly named luminance should then be available in "Options / Render Scene Luminance".

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1803), 64-bit


June 14, 2012, 08:51:51 AM
#9
Aram, are you using TC V19? If so you might try the RedSDK Quality render mode. It provides a really nice global illumination to a scene. I'll try to come up with an example later today.
« Last Edit: June 14, 2012, 08:57:22 AM by Brad Easterday »

Logged
BradE [ dean3Design ]
Core i7-3930K CPU @ 4.20GHz, 32GB 1333 DDR3, FirePro V5900
TC 21 Platinum (64-Bit) Running on Win7 Pro SP1


June 14, 2012, 09:46:26 AM
#10
Thanks I am.... and using red sdk... but with this new workstation, and v19.. I guess I was expecting rendering to be instantaneous... I guess I am discovering that some of you actually wait overnight for some of your renders.. Yeow!! I am too impatient. I like to change and view, change and view.. but it's only change wait, change wait, change wait..  Arrrgg!!

Seems like my set up is no faster that my old set up: win 32/tcad 17.2

Aram

Logged
1) Tcad V20 on HP Z10 Workstation 3.3ghz-4gb- 64bit- Nvidia Quadro 2000 Win 7
2) Tcad V20 on Lenovo D30 Workstation 2x- Xeon, 64bit, 16gb -Nvidia Quadro K2000 Win 8


June 14, 2012, 11:14:14 AM
#11
re: …Still trying to get my background environments to show up…

"Options / Render Scene Environment". Use the "Background" category and pick "Graduated" from the Environment list. Click on "Edit Environment" to open the editor to this particular environment. Right-click on the highlighted Graduated name and choose "Copy Environment Here". Give it a unique name. Go to the new environment and edit the "graduated" shader section choosing/specifying any colors you want. OK out of the editor and your new environment should already be selected to use. OK back to the drawing.

You could also select any thumbnail from Environment palette, then right-click and choose "Set Environment".

If you're going to edit any of the supplied LightWorks Materials, Environments, etc., do it with a new named copy.

John.. went back a bit and did this, and when I punched the render butto.. it did as expected on the background, but the re-swept back to a gray background.. This was in RedSDK.. I tried turning the ambient lights on and off with no diff.  Setting?

Yes.. messing with this more, it seems zooming in and out you can see the first pass correctly, but the reverts to gray background.. weird.

Aram
« Last Edit: June 14, 2012, 11:25:30 AM by Aram »

Logged
1) Tcad V20 on HP Z10 Workstation 3.3ghz-4gb- 64bit- Nvidia Quadro 2000 Win 7
2) Tcad V20 on Lenovo D30 Workstation 2x- Xeon, 64bit, 16gb -Nvidia Quadro K2000 Win 8


June 14, 2012, 11:27:35 AM
#12
Ahha .. Background shows up in draft rendering only.  Setting?

Logged
1) Tcad V20 on HP Z10 Workstation 3.3ghz-4gb- 64bit- Nvidia Quadro 2000 Win 7
2) Tcad V20 on Lenovo D30 Workstation 2x- Xeon, 64bit, 16gb -Nvidia Quadro K2000 Win 8


June 14, 2012, 03:58:53 PM
#13
Welp.. no matter what I do.. I can not change the material on the main body.. plus it always looks transparent...  I goofed something up real bad..

Is their some sort of relationship between Redsdk and Lightworks???  Do you only use one at a time? I notice now hidden lines can not be examined without the drawing disappearing...   I am so confused.. and it looks like my drawing is getting worse by the minute..

Any help would be appreciated.

Aram

Logged
1) Tcad V20 on HP Z10 Workstation 3.3ghz-4gb- 64bit- Nvidia Quadro 2000 Win 7
2) Tcad V20 on Lenovo D30 Workstation 2x- Xeon, 64bit, 16gb -Nvidia Quadro K2000 Win 8


* June 14, 2012, 06:53:22 PM
#14
See here:
http://forums.turbocad.com/index.php/topic,9324.0.html


...
Yes... well time to break out the facet editor...

Boolean and Facet tool bar -- Select a facet, then Ctrl+A to select all the facets  (or howeveer...) Set all the facets to none -- then "re-materialize" (couldn't resist making up that word).

It's explained in Don Cheke's Architectural Presentation tutorial.

I figured it out before -- but was not as well organized as Don's explanation.

Logged
WillR
SW:TC 21 Pro Platinum, FM15, 20 Pro Platinum 64 Bit, also V 19.1 64Bit & 32 bit 17.2 and 18.1; Furniture Maker 14 and 10. HW: Vista 64 Ultimate, AMD 1090 (6 core) 8GB memory Plus also an AMD  8 core systemFX


June 15, 2012, 08:57:21 AM
#15
Okay.. Thanks.. I did not get any warnings though.. so let me try messing with this after reading your post. I'll report back.

Aram :)


Logged
1) Tcad V20 on HP Z10 Workstation 3.3ghz-4gb- 64bit- Nvidia Quadro 2000 Win 7
2) Tcad V20 on Lenovo D30 Workstation 2x- Xeon, 64bit, 16gb -Nvidia Quadro K2000 Win 8


June 15, 2012, 10:38:37 AM
#16
Wow that was a major pain in the butt!.. I think I "dematerialized" most of it, but the insides.. not too sure. Was there an easier way to select all the facets, on a particular object element, and the apply none?

Aram

Logged
1) Tcad V20 on HP Z10 Workstation 3.3ghz-4gb- 64bit- Nvidia Quadro 2000 Win 7
2) Tcad V20 on Lenovo D30 Workstation 2x- Xeon, 64bit, 16gb -Nvidia Quadro K2000 Win 8


June 15, 2012, 11:28:19 AM
#17
http://forums.turbocad.com/index.php/topic,5214.0.html

May be on to something here. Still looking.

Logged
1) Tcad V20 on HP Z10 Workstation 3.3ghz-4gb- 64bit- Nvidia Quadro 2000 Win 7
2) Tcad V20 on Lenovo D30 Workstation 2x- Xeon, 64bit, 16gb -Nvidia Quadro K2000 Win 8


June 15, 2012, 11:35:19 AM
#18
Okie Doke.. I was able to bring all facets on the (main support bar only) back to a material of none.. But for some reason the front facet doesn't seem to be part of the rest of the square pipe. Is their a way to join facets together? I think I will recover the item if I can achieve that goal!!

Aram :o

Logged
1) Tcad V20 on HP Z10 Workstation 3.3ghz-4gb- 64bit- Nvidia Quadro 2000 Win 7
2) Tcad V20 on Lenovo D30 Workstation 2x- Xeon, 64bit, 16gb -Nvidia Quadro K2000 Win 8