TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Interested in some really terrific mobile apps? Visit www.turboapps.com for details.

"file name is invalid" error message while opening drawings folder
Read 3249 times
* April 13, 2012, 07:44:43 AM
Can anyone tell me why upon navigating from the start window to the drawings folder I get this error message?

C:\Documents and Settings\user\My Documents\_briefcase\TurboCAD Professinal 18\Documents\Drawings\*.tcw;*.tct;*.tcx;*.3ds;*.3dv;*.dgn;*.dwf;*.dwg;*.dxf;*.plt;*.eps;*.fcd;*.fcw;*.fp3;*.bmf;*.geo;*.wrl;*.wrz;
*.cgm;*.dc;*.dcd;*.wmf;*.igs;*.mtx;*.sat;*.stl;*.step;*.stp;*.skp
The above file name is invalid.
                                               - OK -                                                       

Dismissing the message seems to let things proceed as normal, but it happens every time, and I wonder what else is broken related to this.

Logged
Dave Oliff
TurboCAD Pro Platinum 18.2 Build 73.1               Windows XP Pro SP3


* April 13, 2012, 07:57:41 AM
#1
Wild guess here, but could it be this part of the path: "TurboCAD Professinal 18"? (Note misspelling of Professional) Or does that (misspelled) folder actually exist?

If that was just a typo when transcribing the message, never mind :)

Logged


* April 13, 2012, 10:34:47 AM
#2
I looked at V18 in XP and my "Drawings" folder is at: C:\Documents and Settings\John R\My Documents\TurboCAD Professional 18\Drawings.

Did you accept the default locations during installation or did you specify a custom location? I'm wondering how the "Briefcase" got into the mix.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


* April 13, 2012, 11:25:07 AM
#3
I misspelled "Professional" in the message. I guess that makes me not one, huh.

The "_briefcase" directory was added by me. Everything else was default. I can't imagine adding a folder to the path causing this, although I am wondering about the underscore at the beginning of that directory name. Never had a problem with it on anything else for years.

Logged
Dave Oliff
TurboCAD Pro Platinum 18.2 Build 73.1               Windows XP Pro SP3


* April 13, 2012, 11:47:49 AM
#4
I gather you're attempting to open a TCW file via "Start / Documents /…*.tcw". I didn't experience any problems, but normally I go through "File / Open" in TurboCAD to open a drawing due to similar problems like this. Since I have multiple versions of TC installed, Windows is not reliable at starting the proper Version.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


* April 13, 2012, 11:54:17 AM
#5
I gather you're attempting to open a TCW file via "Start / Documents /…*.tcw". I didn't experience any problems, but normally I go through "File / Open" in TurboCAD to open a drawing due to similar problems like this. Since I have multiple versions of TC installed, Windows is not reliable at starting the proper Version.

I can make it do it either way, and I don't even get so far as to touch a file, it's apparently the directory navigation that triggers it.
That is: start window>(left pane) select drawings>DING! and error message.
-or-
Dismiss start window, go to file>open>(if already in drawings directory) DING! and error message.

And either way, I can say OK, and keep going.

Logged
Dave Oliff
TurboCAD Pro Platinum 18.2 Build 73.1               Windows XP Pro SP3


* April 13, 2012, 12:32:23 PM
#6
I don't know for sure where the problem is, but my first guess would be the Briefcase. I've never used that option, so I haven't a clue if that is causing it.

Another place to look is "Options / File Location". Possibly the Drawings location is wrong there.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


* April 13, 2012, 12:44:23 PM
#7
I wonder why it's referring to all those file extensions?

Logged
Dave Oliff
TurboCAD Pro Platinum 18.2 Build 73.1               Windows XP Pro SP3


* April 13, 2012, 12:51:47 PM
#8
I count about 262 characters and spaces in that file path. Do you suppose that is over the long file name limit?

Logged
Dave Oliff
TurboCAD Pro Platinum 18.2 Build 73.1               Windows XP Pro SP3


* April 13, 2012, 01:23:44 PM
#9
It's possible that you've gone over the 255 limit for long filenames.

Did you create a custom "Favorite Folder" in the "File / Open" dialog (left-hand pane)? That's the only place where I've run into the list of Extensions that you show.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


* April 13, 2012, 01:57:30 PM
#10
Inserting that "_briefcase" directory was my only customization. In the start window everything else is default. The " "drawings" that folder is the one specified in my custom path at time of installation, which I verified from options>file locations.

I've noticed that if I try to select the other folders (templates, history), and leave it set there, the next time I select file>open, it behaves. Any other method of making the program see MY drawings directory, and it balks.

I'm goin to try to migrate everything up to a shorter path to see what happens.
If I count the characters and spaces right, and 255 characters is the limit, then the default installation was only about 3 characters away from that limit. Seems hard to believe they would allow that. I always did wonder if the long folder name "TurboCAD Professional 18" was asking for trouble.

By the way, my "_briefcase" is just a folder, and not the synchronization utility that came with some windows. That thing was scary.

Logged
Dave Oliff
TurboCAD Pro Platinum 18.2 Build 73.1               Windows XP Pro SP3


* April 13, 2012, 02:21:15 PM
#11
I shortened the "TurboCAD Professional 18" directory and used the options>file locations dialog to correct the paths for everything that was affected, and the program seems to work. The only other thing I don't like, is that wehn the program starts up, it will recreate the "TurboCAD Professional 18" folder and rewrite a few basic empty directories under it.

Anyone know what is regenerating that?

Logged
Dave Oliff
TurboCAD Pro Platinum 18.2 Build 73.1               Windows XP Pro SP3


* April 13, 2012, 11:08:12 PM
#12
I'm not sure what regenerates missing files/folders, but I find it useful. The only "empty" directories in a new install would be AutoSave, BackUps, Drawings and Symbols. Each is necessary. "Config" is where your customized Workspace will be saved to, if you choose to create one. It also contains samples to try. The "…Print Styles" folders are needed if you use those options. "Shapes" is needed for your custom Line Styles.

If you want the "TurboCAD Professional 18" directory in a different location from the default, reinstall the program. Change the location for the "User Data Folder" during the install process.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


* April 17, 2012, 06:00:36 AM
#13
I'm not sure what regenerates missing files/folders, but I find it useful. The only "empty" directories in a new install would be AutoSave, BackUps, Drawings and Symbols. Each is necessary. "Config" is where your customized Workspace will be saved to, if you choose to create one. It also contains samples to try. The "…Print Styles" folders are needed if you use those options. "Shapes" is needed for your custom Line Styles.

If you want the "TurboCAD Professional 18" directory in a different location from the default, reinstall the program. Change the location for the "User Data Folder" during the install process.

Thanks John, I was wondering what the config folder was about. It appears that you can't mess with that one's relative location. I did what you said and reinstalled in order to get my cutom paths corrected, and I shortened them at the same time. The problem turned out to be as a result of file paths being too long (over 255 characters). Correcting this appears to have solved the problem.

Thanks to everyone else too for your consideration on this.
Dave

Logged
Dave Oliff
TurboCAD Pro Platinum 18.2 Build 73.1               Windows XP Pro SP3


* April 17, 2012, 12:20:26 PM
#14
Good to hear that you got this problem straightened out.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit