TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
All posts discussing pricing or where to buy TurboCAD will be deleted.

Background color in edges when saved as image.
Read 2117 times
* August 15, 2009, 07:29:14 PM
Hello,

I'm using TurboCad 15 Deluxe.  I have an object that I'm saving as a .PNG file and choosing the background color as a transparent color.  The problem is the background color is slightly merged with the edge of the object as it's rendered and so still remains, although not at exactly the same RGB value, as a thin border around the image.

Does anyone know how to solve this problem so that no color from the background ends up in the edge of the object?

Thanks
 :)

[attachment deleted by admin]
« Last Edit: August 15, 2009, 07:30:46 PM by BubbleOne »

Logged


* August 15, 2009, 07:37:55 PM
#1
I've seen that, too, but never really tried to fix it. Only possibilities I can think of offhand are to try different render modes, and to try editing the image in your favorite image editor (perhaps "replacing" the offending color with the correct one).

Henry H

Logged


* August 16, 2009, 05:43:33 PM
#2
Thanks for the reply Henry,
I have tried different render modes but no luck.  There are too many images to work with in an image editor, in the end there will be several thousand.  Hopefully someone will have an answer :)

Logged


August 16, 2009, 06:21:46 PM
#3
Thanks for the reply Henry,
I have tried different render modes but no luck.  There are too many images to work with in an image editor, in the end there will be several thousand.  Hopefully someone will have an answer :)

One can't get a better job from TurboCAD in this regard. I was so excited when this filter appeared but that was short lived. However, it is not a total loss as you can still save to png as you do. You can then open in Photoshop and feather the edge in a matter of seconds for great results. I understand that you have lots of images to work with but so do I and this is just part of the process, well worth the extra time.

[attachment deleted by admin]


* August 16, 2009, 06:39:00 PM
#4
Hi Don,

Feathering, great idea, had not thought of that method.  I guess I can create a macro to do all the work too :)

Thanks

Logged


* August 16, 2009, 08:50:07 PM
#5
Thought I would let others know that I have found an answer to the problem as it saves a great deal of time.


Under Render Scene Environment,
Catagory Background
Environment Image
Choose Edit Environment
Under "Plain" select Plain
Then choose the color that is to be set to transparent in the .PNG setup options when saving the image as .PNG

Hope this helps someone out as much as it has me

Logged


August 16, 2009, 09:03:24 PM
#6
Thought I would let others know that I have found an answer to the problem as it saves a great deal of time.


Under Render Scene Environment,
Catagory Background
Environment Image
Choose Edit Environment
Under "Plain" select Plain
Then choose the color that is to be set to transparent in the .PNG setup options when saving the image as .PNG

Hope this helps someone out as much as it has me


You will still have a different color edge as TurboCAD can't make the separation as accurate as needed. I alway change my background to something so different and easily identifiable but alway have the edge remaining.


* August 16, 2009, 10:07:39 PM
#7
I have just done some more testing, the original .PNG was saved at 4000x4000, it still has the color around the border though I did not see it due to the size on screen in which it was displayed.

Also I'm resizing the images down which totaly removes it, so it's not the solution I thought it was.  Even so the resizing of the resulting .PNG image, in my case down to 500x500 does the job perfectly for me and is easy.

Oh well, still works well if you dont need the images at full res of the original.

Logged