TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When replying to a specific statement be sure to quote the previous post.

Can I suppress the red triangles?
Read 2369 times
* February 22, 2012, 08:12:07 AM
Hi,  I have seen posts on this before but I cannot find out how to suppress the red triangles.

It seems that when I boolean add (or subtract) 2D objects the resulting region will always break into red triangles as I move the curser over the region. I can see that the triangles are relevant to the shape, but are not of any practical use (as I can see).

Is there any way to suppress the triangles?  They are particularly annoying when I am trying to explain to a client various aspects of a design and all the red triangles flashing on and off are very confusing.

I attach a scrap view showing a red triangle as I mouse over the drawing.

Kind regards

Martin

Logged
MS Win10 Pro, i7-3770K processor, Nvidia GeForce GTX, 500GB SSD, 2T HD, 16GB RAM (32GB Virtual). Gigabyte Mobo.  TC since 3.5" floppy days.  Now 2018 Platinum although still use Ver 11 for beam tool (not compatible with Ver18, or version 21).   Cannot get TurboCadCam ver 3.0 to work on Win 10 machin


* February 22, 2012, 08:17:43 AM
#1
Turn off Auto Workplane by Face, and see if that cures your problem.

Logged
AMD Phenom 1090T
8GB RAM
Radeon 5450 1GB
Windows 7
Redsdk  - Off
Editing History - On
v19.2 Platinum, x64


February 22, 2012, 07:58:06 PM
#2
rift

diamonds perhaps?

snaps on?

show magnetic points?

did not open drawing.
probably wouldn't open in my 2D.

you can 'save as' drawing as .pdf or .jpg and show them that. :)

Have A Nice Day!


Logged
Turbocad Deluxe 16


* February 23, 2012, 12:28:41 AM
#3
Thanks for your help guys, but the plot thickens.

Thank you for the tip I deselected Workplane By Face mode in Drawing Aids and the red triangles disappeared.

However, I seem to have another problem, perhaps I ought to start another thread.

When I create a group I always as a matter of good practise put all the components of the group on Level_0 then group them and then move them to the appropriate layer.

However, I am getting a weird resultwith TCW18.2.  I create a group and move it to a layer say layer_1 the situation then is:-

both layers 'on' = group visible.

Switch EITHER layer off = group invisible.

The problem is actually worse than this as in my current work I made some groups light grey and whilst they appear the correct colour on the appropriate layer the incorrect appearance  of the group on layer_0 is always black.  Also the incorrect appearance of the group on the wrong layer is non-selectable.

Unfortunately the file that exhibits this behaviour is on a drawing that has an NDA so I cannot post it here.  I have posted a sample that doesn't exhibit all the issues, but does have the odd effect between two layers.

I think it is something to do with the copy-in-place tool.

I can correct the effect by selecting the correct layer, exploding the group, moving it to layer_0.  Going to layer_0 and the 'ghost' image then becomes selectable so I can delete it and then I can move the exploded group back to the correct layer - Phew!

So I think there is a bit of a conflict between groups, layers and the copy-in-place tool. Unfortunately I don't seem able to use the BCi copy iin place tool in ver 18.2.

Things are just getting worse and worse! I now have copies of groups that I cannot select or delete, I have tried making all layers visible and making each layer the working layer in urn but I cannot select some of the groups.  This is making working with TCW18 almost impossible (if Iuse groups and try to move duplicates to different layers following a 'copy in place')


Kind regards

Martin
« Last Edit: February 23, 2012, 02:03:42 AM by Riftvalley »

Logged
MS Win10 Pro, i7-3770K processor, Nvidia GeForce GTX, 500GB SSD, 2T HD, 16GB RAM (32GB Virtual). Gigabyte Mobo.  TC since 3.5" floppy days.  Now 2018 Platinum although still use Ver 11 for beam tool (not compatible with Ver18, or version 21).   Cannot get TurboCadCam ver 3.0 to work on Win 10 machin


February 23, 2012, 04:40:57 PM
#4

rift

can you put your OS and turbocad version in your signature?

can you post 'dummy' drawing with the error occuring?

Have A Nice Day!

Logged
Turbocad Deluxe 16


* February 23, 2012, 10:50:42 PM
#5
re: …color of the Group.

You should set the objects within the Group to "By Layer" or "By Block" for Color, Pen Pattern and Pen Width. With "By Layer", the settings are controlled by the Layer palette. With "By Block", the settings are initially controlled by the Layer palette, but changing the color for the Group object in the Properties toolbar will override the Layer color.

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1803), 64-bit


* February 25, 2012, 01:19:18 AM
#6
Many thanks for all your help.

I am now back on the straight and narrow with all your help.

I have turned RedSDK OFF, this cured the prolem with parts of groups appearing in strange places and not being selectable etc.

I have turned 'Workplane by face mode' OFF and this has got rid of the irratating red triangles.

Everything is working just fine now and I have taken JohnR's advice and now the colours/layers/fills are all well organised and make the drwaing process much more systematic (I tended in the past to just change the colours of an object by whim to make it stand out).

So it appears that with my setup RedSDK is not a good option, also I don't notice any speed advantage in redraw in wireframe (so fast I never have to wait).  So I am not sure what the advantage of RedSDK is (apart from the very attractive and useful coloured hidden lines).

M
« Last Edit: February 25, 2012, 01:23:47 AM by Riftvalley »

Logged
MS Win10 Pro, i7-3770K processor, Nvidia GeForce GTX, 500GB SSD, 2T HD, 16GB RAM (32GB Virtual). Gigabyte Mobo.  TC since 3.5" floppy days.  Now 2018 Platinum although still use Ver 11 for beam tool (not compatible with Ver18, or version 21).   Cannot get TurboCadCam ver 3.0 to work on Win 10 machin