TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When posting a problem be sure to include which version you are using.  Give as much information as possible.  If the problem is with a specific file be sure to attache it to your post.

Turbocad 10.5 Pro problem with snaps for measurements.
Read 5374 times
* August 08, 2009, 06:22:06 PM
I have Turbocad V10.5 build 77.5 and I am seeing some problems with it. I am using 2 dimensional drawing to create a drawing that has many parts. When I start dimensioning the parts I use snap to vertex hot keys and then left click on the location for the dimension display. In some cases, the second "measurement point" suddenly shifts to a point somewhere in space that is not part of the drawing. The dimension displayed is correct (or at least the expected value), but the reference point is not on the drawing. Is there something I am doing wrong or is this a bug in the software. This is not a new development, but I need to show the correct dimension location to a client.
Thanks for your help.
Greg

Logged


* August 08, 2009, 08:23:23 PM
#1
Sonds like a Workplane problem. For best results, a dimension should be drawn on the same Workplane as the entity being dimensioned. If it's a 3D entity, the dimension Workplane should be chosen to include the points being dimensioned. (For example, to dimension the height of a cube, create a Workplane in one of the vertical faces and then dimension one of the vertical edges in that face.)

Henry H

Logged


* August 09, 2009, 07:56:35 AM
#2
Hi Henry,
   Thanks for the reply. My drawing is in 2 dimension, so I don't think workplanes are involved. (I have been planing to move into 3 dimensional drawing, though so the tip on dimensioning is much appreciated.) Is there something else that I am doing/not doing that would correct this problem?
Greg

Logged


* August 09, 2009, 08:11:12 AM
#3
Hi Henry,
   Thanks for the reply. My drawing is in 2 dimension, so I don't think workplanes are involved. (I have been planing to move into 3 dimensional drawing, though so the tip on dimensioning is much appreciated.) Is there something else that I am doing/not doing that would correct this problem?
Greg

It could still be a Workplane problem. Hard to tell without seeing the file, however. Can you post it?

Henry H

Logged


* August 12, 2009, 05:47:07 PM
#4
Hi Henry,
    Thanks again for replying.
    How do I post the file? I am a little new to this (or any) forum.
    I did manage a work around. After every measurement, I save the drawing. If it points somewhere else, I just quit without saving and start over with the file that was last saved. Ir's cumbersome, but seems to work. I would prefer a cleaner solution, though.
Greg

Logged


* August 12, 2009, 09:26:32 PM
#5
How do I post the file?

At the bottom of the "form" in which you type a message you'll see, "Additional Options..." Click that and you will then see a window labeled, "Attach:" Click the Browse button, navigate to your drawing file, and click "Open." Then post the message in the usual way.

Henry H

Logged


* August 13, 2009, 06:58:40 PM
#6
Thanks. I've attached it.


[attachment deleted by admin]

Logged


* August 13, 2009, 08:22:41 PM
#7
Thanks. I've attached it.

Pretty busy drawing ;-)

Where should we look to see the dimension problem?

Henry H

Logged


* August 16, 2009, 11:38:06 AM
#8
Oops, I deleted the screwy dimensions from the drawing. I can try to get them back and re-post the file.
Yes, it is very busy. That's why I want to switch to 3-d drawings. I think it would simplify the drawings.

Logged


* August 16, 2009, 12:05:38 PM
#9
Thanks. I've attached it.

Just looking at some of the other layers, I find many of the objects on different workplanes. Since everything in the drawing is 2D, I would use Select All, then "Format/Place on WorkPlane".

How do you move things in TurboCAD?
Windows drag-n-drop is not used to move objects, for the most part.


Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1803), 64-bit


* August 20, 2009, 05:36:49 PM
#10
Hi John,
    I generally don't move objects around. I draw them in place. I use the SEKE snaps and draw the objects. I use the construction lines to position the point I want to start  and then snap to the intersections.
    When I draw objects, I don't select a work plane. I draw on the plane that I am on. I didn't realize that it changed on me. I do use different layers for different components of my drawings. This allows me to show 2 pieces joined with mortise and tenon joint without the mortise or tenon in the view. Then when I want to size the whole piece (say with the tenon) I have a separate layer I use to display this and the rail (which is on it's own layer.) I put dimensions on another layer as well, otherwise my drawings get cluttered.
    I took your advice to "Select All" and then "Format/Place on WorkPlane". I hope this clears up my problem. I can work around it, but it is inconvenient to do so.
Greg

Logged