TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Be sure your post is relevant to the current discussion.  Create a new topic within the appropriate board if you are unsure.

How to get same grid appearance in paperspace as in model space?
Read 6024 times
* April 13, 2011, 09:27:54 PM
I have a layout that 's about 50' by 22'. I have the grid set up the way I like it in model space, with 6" spacing. I can't use this grid spacing in in paperspace, because then there would only be about 3 grid lines. I thought there must be some setting in the viewport that would allow the original grid to show through, but that doesn't seem to be how it works. It appears I can only specify a grid that fills the entire paper space. So far the solution I've worked out is to make the viewport a fixed scale, and then divide 6" by that scale and then apply the result as the spacing factor inside the paperspace. This sort of works, but it seems crude.

Is there an official way to see the "same" grid in paperspace as in model space?

Thanks!
Mark

Logged
TCW Pro 14.2
TC Deluxe 16.2 Build 53.2


* April 13, 2011, 10:12:25 PM
#1
One way that comes to mind is to select the Viewport, then use "Workspace / Model Space (Floating)". Now you are actually back in Modelspace; much like work through a hole in the paper.

Another, instead of changing the Paperspace Scale, do the math on the Paperspace "Grid". With MS Grid at 6" and you have a Viewport with a Fixed Scale at 1:48, I did 1÷48(VP scale)=0.020833×6(MS Grid)=0.125. I set the Paperspace Grid to 0.125 and it matches the grid in Modelspace when using "MS Floating".

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1803), 64-bit


* April 14, 2011, 07:30:38 AM
#2
Thanks John --

Number 2 was what I was already trying. But it seems a bit inaccurate -- there must be rounding errors in there. Oh well, if that's all there is ....

My next problem is that TC won't print the grid. I have the "print grid" option on, and I've set the "hide grid when smaller" option to something like 0.0001 ". But it still won't come through in the preview or  the actual print. Finally I changed the grid color to black. Now I could see the grid lines -- just barely. I couldn't find a setting to specify the width of the grid lines -- apparently they're rendered as zero-width lines.

I suppose I could create my own "grid" lines and paste them in linearly, but I'd rather that TC would just print the original if possible with the same visibility I'd get with graph paper.

Thanks!
Mark


Logged
TCW Pro 14.2
TC Deluxe 16.2 Build 53.2


* April 14, 2011, 01:36:33 PM
#3
re: printing Grid lines

While the default color is on the light side when printed, I found "0, 27, 255" for the Major color and Med. Turquoise "112, 219, 219" for the Minor color came out nicely on my little HP. It looked like regular graph paper to me when printed, though it is a bit much on screen.

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1803), 64-bit


* April 14, 2011, 02:19:44 PM
#4
Thanks John!

That does look very nice!

Question: How do I return the grid to its default? When you first open up the grid color selector, it doesn't seem to show you which (if any) of the swatches it is using. So how do you know which color to set it back to?

Thanks!
Mark

Logged
TCW Pro 14.2
TC Deluxe 16.2 Build 53.2


* April 14, 2011, 02:46:05 PM
#5
You could open a new drawing to get the numbers. They're also listed in the Wiki on the Drawing_Defaults page.

$GRIDMSORTHOCLRMAJ = 194,194,255
$GRIDMSORTHOCLRMIN = 230,230,255

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1803), 64-bit


* April 14, 2011, 06:45:35 PM
#6
Hi You didn't say what size plot so I assumed setting it up for 11x8.5. 50'x20' is 100x40 6"squares. The plot viewport is 1"=6' the grid is 85/1024. Is this what you are looking for? Try the file below. It was created in Tcad16.2. It should open in paperspace. Go to file print hit ok. Don't expect too see the grid in print preview. I'm using a standard type hp printer with this file. I am going to blame this one on the "foreground color conversion" try using a white backround with the foreground color conversion off. I have dots in paperspace but the lines will print. For keeping the grid within your border you need to adjust the margins.  :-[Oh I'm sorry I see you have the delux version. Maybe this still might help or someone can convert it for you. here is a pic of what the plot looks like. The grid is contained within the thick line border on a print.
« Last Edit: April 14, 2011, 07:15:58 PM by Dean »

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2019-2018-2017, TurboCad Platinum 21.Using LightWorks, Anilab lab 5. ATI Mobility Radeon HD 4500/5100 and HP all in one desktop with Nvidia Geforce 210, open gl 3.3


* April 14, 2011, 08:28:31 PM
#7
Hi Dean,

Yes, your approach is the same as that of John and myself -- cut down the spacing in proportion to the scaling factor. This just seems to be a bit imprecise, though maybe it doesn't matter beyond 3 sig figures since that's all the printer can manage anyways. The other problem with this approach is that the grid isn't going to have the same origin as in model space. I suppose you could move the viewport around until it locked in at the right position.

The dots in your paperspace did not print out on my brother printer.

The two things I was hoping to find were:

  1. A way to have the grid show up the exact same in paperspace as in modelspace.
  2. A way to specify the width of the printed grid lines.

John's colored grid approach seems to work best so far. For some reason the "blue" grid was more visible than the black grid. For my purposes I'm set to go, but still a bit surprised there isn't more control over the grid.

Thanks!
Mark

Logged
TCW Pro 14.2
TC Deluxe 16.2 Build 53.2