TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When replying to a specific statement be sure to quote the previous post.

xref layer control
Read 2814 times
July 06, 2009, 07:44:44 AM
I think I know the answer to this question but I will ask it anyway.

Does 16 have any way of controlling layer visibility in xrefs?  I know previous versions did not, but thought something was being done about that.

Maybe I dreamed it in my fantasy for more flexibility with xrefs.

Logged
Jon Coxwell, AIA
Windows Win 7x64
TC19,20 32 bit, 20,21,22 64 bit (Platinum)
RedSDK usually off  Win 10 pro

Save the Planet
Conserve & Recycle


* July 06, 2009, 08:02:59 AM
#1
I would love if this is possible as well.

Logged
Cameron Blair


* July 06, 2009, 01:35:40 PM
#2
re: controlling layer visibility in xrefs

The only way I see is to go to the Blocks palette,
click on the External Reference icon,
select the External Reference,
right-click and choose Open.
Make your changes to the Layers,
Save and Close the XRef file.
Select the XRef again in the Blocks palette,
right-click and choose Reload
That should be it.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled
Windows 10, 64-bit


July 08, 2009, 01:17:29 PM
#3
Thanks John,

That works but a little cumberson.  I think AutoCad has had layer control on xrefs back to version 14.  Hope it bubbles to the surface with the developers as with being to able to xref sketchup files I am finding I want to use xrefs more.

Logged
Jon Coxwell, AIA
Windows Win 7x64
TC19,20 32 bit, 20,21,22 64 bit (Platinum)
RedSDK usually off  Win 10 pro

Save the Planet
Conserve & Recycle


* July 08, 2009, 02:19:33 PM
#4
Yes, that would be a nice feature.


Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled
Windows 10, 64-bit


* August 10, 2009, 09:33:16 AM
#5
Sorry to bring this up again.  I'm now having difficulty because a layer that I have turned off in a xref (I can see that it's turned off because it does not show up in wireframe mode) is showing up when I render that object in the current drawing.  Any ideas why this happens?

[attachment deleted by admin]

Logged
Cameron Blair