TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
The purpose of these forums is to discuss TurboCAD.  Please keep the discussion of other products to compatibility issues or how the other software’s can be used with TurboCAD.


Coordinate systems
Read 5413 times
* June 27, 2009, 08:13:58 AM
Items in DXF files we receive from customers sometimes need to to be rotated.  Once rotated I would like their CS to be the same as the WCS - thus the handles for further rotation or manipulation are aligned with WCS vertical and horizontal axis. 

Selecting a vector then right click brings up choices but nothing seems to accomplish what I'm after - which is canning the items CS and making it like newly created objects.

Logged


* June 27, 2009, 08:26:09 AM
#1
How to change an object's own Workplane (and thus its own CS):

For a 2D object, establish the desired WP; select the object; go to Format|Place on WorkPlane.

For a 3D object, establish the desired WP; create a new 3D object; 3D-Add it to the target object, being sure to click on the new object first. I recommend that the new object be a Sphere, very small compared to the target object, and that you place it at the target's Center of Extents before adding. In most cases, the sphere will be swallowed by the target object and for all intents and purposes will no longer exist. If the target's COE happens to be an empty spot, leaving the sphere exposed after adding, you can Explode the result one time -- which will separate the sphere and the target into separate objects -- and then delete the sphere.

Henry H

Logged


* June 28, 2009, 10:46:38 AM
#2
How to change an object's own Workplane (and thus its own CS):

For a 2D object, establish the desired WP; select the object; go to Format|Place on WorkPlane.
Henry, when I do this I get a message like "Selecting the object in 2D mode changes the drawing's Workplane. Do you want to continue?". If I continue, and say Format, Place on Workplane, what workplane is it placed on?

Logged
Gary Wooding
Win10 64-bit,
TC21.2 x64 Plat, Bld59
TC16.2 Plat, Bld54.0
TCC 3.5


* June 28, 2009, 10:58:54 AM
#3
If I continue, and say Format, Place on Workplane, what workplane is it placed on?

It is placed on your current Workplane -- which is why I specified that you "establish the desired WP" first. Guess that instruction coulda been clearer, though.

Henry H

Logged


* June 30, 2009, 01:09:09 PM
#4
Quote
Selecting the object in 2D mode changes the drawing's Workplane. Do you want to continue?".
 

Let's start with the basics.   Watch what happens to the User Coordinate System (UCS) indicator when the workplane changes.



[attachment deleted by admin]
« Last Edit: June 30, 2009, 04:00:26 PM by Dave Taylor »

Logged


* July 01, 2009, 02:04:19 AM
#5
It is placed on your current Workplane -- which is why I specified that you "establish the desired WP" first. Guess that instruction coulda been clearer, though.
I'm using TC Pro 11.2.
Screen 1 shows a 2D circle on the World plane, and a 3D block that's been rotated a little about the X-axis.
Screen 2 shows the WP defined on the front facet of the block.
Screen 3  shows selecting the circle.
Screen 4 shows the circle has been selected, and the WP changed to World.
Screen 5 shows the circle about to be placed on the WP.
Screen 6 shows that the circle's WP hasn't changed.

I thought that I had established the desired WP in screen 2.
What did I do wrong?

[attachment deleted by admin]

Logged
Gary Wooding
Win10 64-bit,
TC21.2 x64 Plat, Bld59
TC16.2 Plat, Bld54.0
TCC 3.5


* July 01, 2009, 05:11:12 AM
#6
In screen 3 it shows that the drawing work plane is being changed to work plane that the circle is on.  This happens once you select the circle.  Therefore its actually moving the work plane of the the circle to the drawings work plane, which is in fact the work plane of the circle.  So in reality it's not moving anywhere.

If you select the circle in 3D mode instead of 2D mode, by selecting the circle first, switching it into 3d mode, and then going through Henry's steps, you should be good.
« Last Edit: July 01, 2009, 05:17:09 AM by CoasterGuy2 »

Logged
Cameron Blair


* July 01, 2009, 06:59:03 AM
#7
In screen 3 it shows that the drawing work plane is being changed to work plane that the circle is on.  This happens once you select the circle.  Therefore its actually moving the work plane of the the circle to the drawings work plane, which is in fact the work plane of the circle.  So in reality it's not moving anywhere.

If you select the circle in 3D mode instead of 2D mode, by selecting the circle first, switching it into 3d mode, and then going through Henry's steps, you should be good.
Well, it doesn't work that way on my system.
The circle was selected in 3D mode, and the result was what you see in the screen shots.
To make it work, I have to insert an extra step before the FPOW: Workspace|Workplane|Previous
How does it work on your system, and if its different, why is it different to mine?
Any ideas?

Logged
Gary Wooding
Win10 64-bit,
TC21.2 x64 Plat, Bld59
TC16.2 Plat, Bld54.0
TCC 3.5


* July 01, 2009, 07:20:37 AM
#8
Well, it doesn't work that way on my system.
The circle was selected in 3D mode, and the result was what you see in the screen shots.
To make it work, I have to insert an extra step before the FPOW: Workspace|Workplane|Previous
How does it work on your system, and if its different, why is it different to mine?
Any ideas?


I apologize if I'm wrong with this, but it seems, at least according to screen 3, that you're selecting it in 2D mode, hence the warning dialog, saying that by selecting it in 2D mode, it changes the current workplane.  After selecting it in 3D, which does not change the current workplane (your workplane should still be set on whatever was previously set), I follow Henry's steps by going to Format|Place on Workplane.  Note that I am using Deluxe, but this shouldn't be different.

Logged
Cameron Blair


* July 01, 2009, 10:07:39 AM
#9
The circle was selected in 3D mode, and the result was what you see in the screen shots.
...............
How does it work on your system, and if its different, why is it different to mine?

On your Inspector Bar, click the "Selector 2D [or 3D] Properties" icon and enable "3D Mode for Model Space." Then when you establish a WP on the face of the tilted block and try to place the circle on that Workplane, it will actually move onto the current WP.

Your Screen 4 through Screen 6 pics show that the circle has actually been selected in 2D mode, the reason being that your Selector Properties are set up so 2D objects are always selected thus. Had it been selected in 3D mode, it would display three coordinate axes and three rotation handles rather than just one.

...Sorry about the confusion. My Selector Properties are always set to "3D Mode for Model Space" and I tend to forget that other users have different preferences :-(

Henry H

Logged


* July 01, 2009, 10:12:48 AM
#10
IAfter selecting it in 3D, which does not change the current workplane (your workplane should still be set on whatever was previously set), I follow Henry's steps by going to Format|Place on Workplane.  Note that I am using Deluxe, but this shouldn't be different.
I stand corrected. I thought I selected the circle whilst in 3D mode, but I was wrong. I've just tried again after making sure I was in 3D mode and it worked as you and Henry said it should.
Thanks for your assistance.

Logged
Gary Wooding
Win10 64-bit,
TC21.2 x64 Plat, Bld59
TC16.2 Plat, Bld54.0
TCC 3.5