TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When posting a problem be sure to include which version you are using.  Give as much information as possible.  If the problem is with a specific file be sure to attache it to your post.

How to convert units
Read 3962 times
August 07, 2010, 06:25:34 AM
I have quite an interesting situation here...

I want to import a bunch of step files into Turbocad v16 pro, in this example, a 3" u channel

They were created in Siemens NX in mm.

When I set the space units in Turbocad to inches, my u channel comes in at 76.2.  (3x25.4)

When I set the space units in Turbocad to MM, my u channel comes in at 1935.48. (76.2x25.4)

I want the u channel to come in at 3.0.

What do I do?

I've attached the file in case you want to experience the sensation...  :-\

Remember, all I want to do is measure the distance across the channel, and come up with 3". And scaling the part after it's been imported doesn't qualify. I have too many files, and too much complexity to do that.



Mike...

Logged


* August 07, 2010, 07:22:56 AM
#1
Under "Workspace setup: Model Space" (access by right clicking on the model space tab and choose properties) there is a checkbox "convert units after alteration".  I'm really not sure, but it might affect what you are trying to do.

Good luck!

JoeM

EDIT - I experimented some with this.  If I use the drawing setup wizard to configure turbocad to create new drawings with mm as the base unit, then open the .stp file you posted, it comes in correctly at 76.2mm.  You can then change the workspace units to inches, with "convert units after alteration" checked, and it will measure 3 inches.  I realize this is not what you want - I'm not sure if you can do this in one step.

JoeM
« Last Edit: August 07, 2010, 07:53:47 AM by JoeM »

Logged


* August 07, 2010, 01:41:39 PM
#2
I think I've got it figured out.

Open the STP drawing. Size Z for the channel is 76.2 in.
Go to "Options / Space Units" and change the System to Metric; leave the "Convert units..." unchecked.
Size Z for the channel is now 76.2mm
Reopen "Options / Space Units" and change the System back to English; this time checkmark the "Convert units..." box.
The channel now reports X=96 in, Y=1.75 in, Z= 3in.

I hope this works for you.

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1803), 64-bit