TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

When posting a problem be sure to include which version you are using.  Give as much information as possible.  If the problem is with a specific file be sure to attache it to your post.

Cannot Load "TcUI" plug-in.
Read 5309 times
* February 27, 2010, 11:45:01 AM
Back in October 2009 I purchased IMSI's TurboCAD Furniture Maker v7 plugin during their half-price sale.

Unfortunately, to this day I have not been able to even install the plugin, much less try it out or get my money's worht out of it.   

Back in October I contacted IMSI via their support page to request either a resolution to this issue or a refund.  Unfortunately the only assistance IMSI ever provided were instructions to download from another URL.  I did so, but like the 8 downloads before that each were byte-per-byte identical downloads (compaired with diff).  So download corruption is unlikely.  My suspicion rather is that the downloadeded installer is itself broken.

To this day, IMSI has failed to respond to any additional requests for assistance, nor requests for refund of my purchase price.  Obviously my preference would be to install a working copy of TCFMv7, but this issue just irks me each and every time that I start TurboCAD because this plugin could be useful to me, but I ultimately paid $100 for a digital/virtual paperweight!

Since then, I hoped that maybe it was just an issue unique to the Windows XP Pro SP3 machine I was trying to install it on.  Maybe a .Net issue since that specific machine only had .Net 1.1 installed.

I have more recently tried to install this plugin to 3 addtional Windows machines to test that hypothesis (including another Windows XP Pro SP3 machine, a Windows Vista Home laptop and a Windows 7 machine with .Net 3.5 installed).

Every machine that I have attempted to download to has the same issue generated by the Ghost Installer extraction issue.  My best guess is that the online-download installer that came with this version of TCFMv7 is the source of the corruption.

The odd thing is, when I go to Window's temp folder, while the error is displayed on-screen, I can indeed find the TCUI.DLL file that the installer complains about.  The specific error message is as in the title of this topic "Cannot load "TcUI" plug-in."

Does anyone have a solution to this issue so that I can get past this frustration. Otherwise, does anyone know how to get IMSI to actually HONOR its user satisfaction guarantees???

I have screenshots if anyone is interested -- or if I can figure out how to post them here. Any help is greatly appreciated.  I love TurboCad Platinum and this one issue just diminishes my overaall satisfaction with IMSI products.

Thanks in advance for any help others may offer!


March 02, 2010, 11:10:44 AM
I am unsure why this has been so much trouble to install or get support.  Please send me an e-mail directly and we will get this resolved as quickly as possible.


Rip Fowler

* April 27, 2010, 03:16:00 AM
Once I get my primary laptop back up and running I'll contact you.  I've been too busy to make the repairs lately, just need to track down a suitable source for thermal pads when I get a chance (likely from DigiKey, just have not had time to research).

I was hoping if I posted the issue here and gave it some time, someone would have come up with a solution by now since it affects every PC and MS operating system I have tried the install with (XP Pro 32-bit, Vista 64-bit, Win7 32-bit). 

Leads me to conclude that either IMSI had a corrupted download available for download during the weeks my downloads were performed in, or the Ghost Installer wants a library file that, while it might be commonly available on *many* windows PCs, is nonetheless not a standard base library for any distributed MS operating system.  I initially thought it might not have liked that my primary laptop only had .Net 1/1.1 installed.  However, after it failed on a Win7 netbook with .Net v1 through v4, I think we can rule out a .Net dependency issue.

Any how, when I get my laptop in good working order once again, I will drop you a line.  Thank you for your response.   If anyone else has any ideas as to how to work around this issue, please feel free to post your suggestions as well!