TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Be sure your post is relevant to the current discussion.  Create a new topic within the appropriate board if you are unsure.

what file operations is TC doing that causes AntiMalware to use 25% CPU for 30s?
Read 467 times
* March 12, 2019, 02:52:42 AM
What MS Windows file operations during a File Save As is TurboCAD doing that causes MsMpEng.exe (the Antimalware Service executable) to use 25% CPU for 30 seconds? I have no other software that causes MsMpEng to behave this way. Doing a Save As in Word, Excel, text editor, graphics editor, all bring up the Save As dialog nearly instantaneously. With TC 2018 Deluxe this sometimes results in a huge amount of disk operations as if TC is scanning folders - possibly to display it's History list, Template List on the LHS. It seems to be the first time after starting TC that it happens, or is the worst, on subsequent occasions, the dialog is also displayed nearly instantaneously.

I'd be happy to disable the LHS list if this were the cause.

TC Deluxe 64-bit
V25.0
build 49.0

Logged


March 12, 2019, 04:32:51 AM
#1
Does the same problem occur if you use Save or Save Copy As?


Jeff

Logged
TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* March 19, 2019, 10:11:42 PM
#2
Sorry Jeff for the delay in my reply. Was expecting your reply to trigger an email to me (PS. have turned on Notifications). No, it seems to be just the 1st open. I guess all the history for the dialog is cached at that point.

Logged


* March 21, 2019, 02:40:37 AM
#3
Further to the previous post, opening a TCW from Windows Explorer takes a long time, but then the 1st main menu > File > Open will take a long time too. The 2nd & subsequent file open is fairly responsive.

I uninstalled some older IMSI products, retaining TurboCAD Deluxe 2018, and now the File Open dialog comes up in a much more reasonable amount of time. Who knows what terrible interaction that was causing ;-(

uninstalled Turbo Floor Plan
uninstalled TurboCAD Deluxe 2017
uninstalled TurboCAD Deluxe 2017 Symbols
uninstalled TurboCAD Basic Training Guide 2017
« Last Edit: March 21, 2019, 02:51:29 AM by andrewheard »

Logged


March 21, 2019, 05:23:45 AM
#4
I uninstalled some older IMSI products, retaining TurboCAD Deluxe 2018, and now the File Open dialog comes up in a much more reasonable amount of time. Who knows what terrible interaction that was causing ;-(

uninstalled Turbo Floor Plan
uninstalled TurboCAD Deluxe 2017
uninstalled TurboCAD Deluxe 2017 Symbols
uninstalled TurboCAD Basic Training Guide 2017

This is very interesting (also disconcerting).  I have several versions of TurboCAD on my system (21 onward).

How much of a speed increase did you get?

Also, if you were to re-install each of the programs and time file loads, I wonder what you would get.


Jeff

Logged
TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* March 21, 2019, 02:24:00 PM
#5
As I had said, the 1st File Open was taking ~30s. Something in TurboCAD was triggering a huge amount of disc file activity with the Microsoft MsMpEng.exe process using a lot of the CPU. Now I have uninstalled the unused programs each File Open dialog comes up nearly immediately. I had left TC2017 on the PC until now because TC2018 is just an upgrade, and I was concerned uninstalling it would muck something up. And yes, it did! The Windows Explorer thumbnail renderer stopped working, so the icons just displayed a static TC icon instead of the contents of the drawing. In desperation I did a new TC2018 install > Repair, and luckily this fixed the problem. I'm not willing to experiment further as it has already wasted a lot of time but hopefully if anyone else experiences a similar problem they may stumble across this forum topic.

Logged


March 21, 2019, 04:13:12 PM
#6
There are solutions that are unrelated to TurboCAD (specifically, at least).

Do a Google search for these terms: "msmpeng.exe high cpu".

Or you could just go to this site and follow the instructions: https://windowsreport.com/msmpeng-exe-high-cpu/


Jeff

Logged
TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* March 28, 2019, 11:26:48 PM
#7
Thanks Jeff. You may be correct... but it only happened with TC2018, and was fixed by uninstalling TC2017

Logged


March 29, 2019, 12:04:11 AM
#8
I have just, within the last 12 hours, discovered that the latest installation of TurboCAD installed files in the directory path for the earliest installed TurboCAD version (21).  It's been reported, but no response, yet.

If 2017 is the earliest version installed on your system, then this could be a similar bug (maybe even the same one).


Jeff

Logged
TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* March 29, 2019, 03:39:20 AM
#9
Fortunately I don't think so.

C:\Program Files\IMSIDesign\TCW2017
C:\Program Files\IMSIDesign\TCW2018

Uninstalling 2017 would have deleted the newer 2018 files?

Logged