TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When posting a problem be sure to include which version you are using.  Give as much information as possible.  If the problem is with a specific file be sure to attache it to your post.

view in 3D - Hiddenline mode - very slow
Read 271 times
* March 04, 2019, 02:55:46 PM
as per subject, im looking for advice please.

im drafting 3d modeling , very simple, and view in 3d mode - hidden line. it is very slow.

if i move the parts, it take a blink of 2 second then move.

any help or advice / hack / tuning the PC performance is very much appreciated.

my cad is 2016 pro, running on win7-64b, graphic card is gts 1060 - 6gb, core i7 and 16gb ram


Also, weird thing happens every time i run turbocad, i lost copy/paste functions from right mouse click menu, i copy/move and paste the file from Window Explorer. When it happens, i have to restart my PC, then i works, and gone when turbocad is running.


Please help

Logged


* March 04, 2019, 04:23:12 PM
#1
Are you using GDI mode with the lightworks plug-in, or are you using RedSDK mode.

If Lightworks, - I don't have it. 

If RedSDK, you could switch the hidden line rendering from hidden line - hidden line,  to RedSDK - RedSDK Hidden line.    you may need to tweak some settings in options menu, this depends on how you want the hidden line to look.  for example, options menu - drawing setup - RedSDK, set the background line colour swatch to the same as TC's background (black in your case).  Experiment with width, untick the Line - width by graphic, and try something like 0.1 or 0.2.

RedSDK isn't perfect when it comes to hidden line, but generally works ok.   but as I say if you use lightworks, I cannot comment.

all that said,  I would think normally one would create a viewport and insert in paper space, and do hidden line in there. 
« Last Edit: March 04, 2019, 04:33:44 PM by Andy H »

Logged


* March 04, 2019, 05:15:31 PM
#2
It's normal for screen update to be a little slow in Hidden Line mode and in Quality render mode.

Henry H

Logged


* March 05, 2019, 01:47:40 PM
#3
thank you gents for your comment.

i did change to RedSDK, its faster, and with matching hiddenline to back gnd color, and bit of tweaks, its now shown like GDk mode, and all hideenlines blended in to backgnd. Feeling much better now.

also, any idea on what happened to my Copy and Paste function from right click mouse, its gone everytime i run turbocad, and will need a restart PC to get these function back to normal.

Logged


* March 05, 2019, 03:53:47 PM
#4
also, any idea on what happened to my Copy and Paste function from right click mouse, its gone everytime i run turbocad, and will need a restart PC to get these function back to normal.

Sorry. I don't have any answers,.   I have known copy/paste to go 'south' before, but in my case it wasn't attributed to TC.  For a few weeks. in task manager.  I had to right click on Windows Explorer app, and choose restart. to get copy/paste working again (without a reboot).  Then it just started working ok.  don't know why.

Andy

Logged


* March 05, 2019, 05:42:19 PM
#5

You could try "System Restore" via windows >> Set windows back to a previous date when it was working fine.
Just make sure you do a Backup of files before attempting it.

Cheers
Mike

Logged