TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Remember to do a search before you ask a question!!!

Circles are visible while revolve tool is in Rendering mode
Read 435 times
* March 04, 2019, 06:47:38 AM
Issue:
Circles are visible while revolve tool is in Advanced/Quality/Draft Rendering mode

Solution:
2D objects are visible in any rendering mode if option 'Nonrenderable objects' is on.
See the attached screenshot

Logged
Shaheryar Rafiq
SQA Engineer | Technical Support
IMSIDesign


* March 04, 2019, 09:02:13 AM
#1
That is "not" the issue :)
The issue is why that stupid box is checked by default at all ??
Same thing with Advanced render, why is it set to Depth by Field in default ??, it only work when perspective is on.

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* March 04, 2019, 07:53:56 PM
#2
That is "not" the issue :)
The issue is why that stupid box is checked by default at all ??
Same thing with Advanced render, why is it set to Depth by Field in default ??, it only work when perspective is on.

Torfinn

They could change the "Camera Properties" setting in the "…ini.xml" file. I do this in TurboCAD Explorer palette, "Drawing Defaults" category and change the Camera Properties from 8458 to 266.

"Depth of Field" is active because it is the first on the Category list. It's set to "None", so it's not really 'turned on'. Something has to be listed, so DOF is the one.

Same thing applies to the Configuration list when then program is first installed; "CADCourse" is shown because it's first on the list, but the settings from the "Default" button are actually loaded. Once you choose and "Load" a configuration, then that particular configuration will show in the list windows.
« Last Edit: March 04, 2019, 07:58:07 PM by John R »

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled
Windows 10 Pro, 64-bit


* March 04, 2019, 08:32:22 PM
#3
Why do they need to check Non Rendable at all is my point, im pretty sure it's possible to not have it checked
The A render will trow up a warning about that Depth of Field not work if the perspective is not on, so why not change it to Final Gather/ 10 meter or something similar, and move the DOF to the bottom of the list if that is the issue.
It's a boring message and i also think New users will think, perspective what/ where ?

And "by default" i think of a New from scratch.

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* March 04, 2019, 08:41:53 PM
#4
re: …Why do they need to check Non Renderable at all is my point…

I suppose some customer convinced management that this was a good thing to have turned on.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled
Windows 10 Pro, 64-bit


* March 04, 2019, 09:00:57 PM
#5
Yeah :)
I think it is the same People that told them to Automatic make New layers active in viewport's in v 2015-2017, luckily that is over.

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB