TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Be sure your post is relevant to the current discussion.  Create a new topic within the appropriate board if you are unsure.

TC2018 Deluxe 64 bit, ignoring snap modes and ortho setting
Read 314 times
* February 14, 2019, 05:33:22 AM
More troubles from me.  Today, TC2018 Deluxe 64 bit, refuses to pay attention to set snap modes, or to the ortho setting.   this is not just from the toobar, but also by doing it via the menu. I have even tried uninstalling, deleting every reference to TC that I can find, and reinstalling, but it still comes back the same.  It must still have left some remnants, because when I reinstall and start, it suggests the last drawing I was doing, which obviously means it is remembering something.

Short of changing to an affordable CAD program that doesn't keep going strange and not doing what it is supposed to, has anyone got any suggestions? It is currently unusable.  The only way I can get any plausible snap behaviour is by using running snaps, i.e. by right clicking and selecting the snap modes every single time, which is more laborious than watching paint dry.  I am getting really, really fed up with TC's flakiness.

Logged


* February 14, 2019, 05:48:14 AM
#1
Maybe you have checked the first one in snap menu, that have a mouse symbol, that means No Snap, or maybe you have turned it of down on Inspecto Bar, a bit to the rigth side there is 2 button's Snap and Geo.

Else, try go to Tools/ Customize/Options and reload your cfg (UI), if that not work, try one of the others or Default on left side to see if one of them work, if they do, go back and try to re-load the one you normally use.

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* February 14, 2019, 07:00:55 AM
#2
Hmm, Tried all that, and I made sure I definitely didn't have the no snap option set.  Cleared out even more traces of TC (they hide bits everywhere, why can't "uninstall" actually do as it says?) Reinstalled several more times, after clearing out the trash bin, and restarting the PC just to make sure, and sure enough it STILL started up showing my last drawing, and didn't work. 
Perversely what did work was changing the desktop UI to one of the horrible ones (I normally use "classic") and it went away, and the snaps and ortho work.  Now somehow I have the tooltips following my cursor around all over the place, which is annoying, and turning screentips off doesn't stop it.  And now I have to go and delete that damn splash screen (again) to stop it trying to sell me the version of TC I already bought last year.  Getting increasingly fed up with this, I just need to work, and time is short.

Before anyone asks, I do have the latest updates to Windows 10, and a current subscription to Norton internet security!

Logged


* February 14, 2019, 08:27:25 AM
#3
Instead of un-re-install, you should just go to windows apps and function an do a repair.
But you need to delete the built-in folder to take away the history etc.
All your personal settings of TC is stored there

C:\Users\Your Username\AppData\Roaming\IMSIDesign\TurboCAD 2018\Your Version of TC\Data\Profiles
Appdata is normally a Hidden folder, but rigthclick on the windowsflag Down in left corner, click on Run and
 type   %appdata%   will bring yo to the Roaming folder and you click the rest of the path.
It's told to only delete whats inside the folder, but i just delete the Built-in folder, finish

Tc have to be off when doing this and the Built in will renake it self when you start TC again, and then it will be like it come when it was New, factorysettings i Guess.
Then you need to run the wizard if you use metric system TC default to inch, set the cfg(UI), template etc and you should be good to go.

Tooltips follow cursor, can it be that you are in LTE mode if Deluxe have that in v 2018, that you can change in Customize/ Options >> Workspace
Edit:
Or turn it of in Customize/ Dynamic Input if you want to be in LTE, see attached

Torfinn
« Last Edit: February 14, 2019, 09:38:48 AM by Torfinn »

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* February 16, 2019, 08:51:57 AM
#4
Ah, many thanks for that.  I was foxed by the numerous places which TC hides its various settings.  When uninstalling, I wish it would do what some other software does, and ask if you want to remove all settings as well?  I'll make a note of what you have said!

Logged