TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
The purpose of these forums is to discuss TurboCAD.  Please keep the discussion of other products to compatibility issues or how the other software’s can be used with TurboCAD.


Saving drawings
Read 647 times
* February 05, 2019, 04:45:47 AM
I have a new PC and am experiencing a problem saving drawings. When first saving a new drawing the screen will hang for 25 seconds before displaying the dialog box. Subsequent saving of the updated drawing does not seem to be a problem.
I then do a copy of the drawing or part of and paste it to a new template so that it can be saved as a new format ie STL for 3d printing. That is OK but as I attempt to save it the screen hangs again for 25 seconds before displaying the dialog box.

Any ideas please? I have Turbocad profesional 2016.

Dave Steward

Logged
Dave


* February 05, 2019, 05:58:07 AM
#1
Dave, 

 I too have this frustration and have asked the question.   It seems to be related to the STL thumbnails that are stored in the history for display in the file dialog form.   If you delete all the STL thumbnails from the history it will open very quickly. But they get repopulated with time and you have to frequently delete the thumbnails to hold on to your sanity.

Another factor is the default count of 50, which you can change.  I recommend  you reduce this number to 10 or less which will also make it open quicker.

Unfortunately for me, the setting changes will not stick and It dutifully goes back to the default of 50 after a week or so. 
I have also tried to use the custom view and only show .TCW files, but that has its own weirdness.  Hopefully you can figure out how create a better outcome.

You can access the custom filters by right clicking in the history.
 
This is a big deal to someone who values his time and waiting to save a file is a frustration I would like eliminate.  Good luck.

Logged


* February 05, 2019, 09:08:04 AM
#2
Thanks for the reply. My problem is even before saving as a .stl. Saving a drawing for the first time as a .tcw file also makes the screen hang before the save as dialog box appears.

Dave Steward

Logged
Dave


* February 05, 2019, 04:16:52 PM
#3

(Im using Win 8.1)
Window "User Account"

Try altering the "User Account Control Settings"
Control Panel > User Account > Change user Account Control Setting > Slide the BAR to "Never Notify.

Close it and fire up TC2016 ... and see if it behaves itself.



For what it's worth ...
I have 2016 Pro Plat ... and have never got it to work flawlessly ...
I reverted back to TC21 as a every day workhorse (never gives grief)

Cheers
Mike

Logged


* February 06, 2019, 03:41:03 AM
#4
Thanks for that Mike but it still is not the answer. Now I have been using it for a while I find that there are some strange things going on. I will come back to the forum when I can make sense of what is actually happening.
Thanks again,
Dave

Logged
Dave


* February 06, 2019, 05:18:06 AM
#5
Mike,  I too made the user account changes and it had no effect on the slow dialog opening.   It is apparent to me that the first time this dialog is  opened, that the software is building a list or other operation that is taking a very long time, relatively speaking.  As a windows programmer,  I know this because if I clear the history, close the software and reopen it, the dialogs open immediately.  Speaking for myself, this delay,  of up to 35 -40 seconds, with no apparent permanent fix is very very frustrating. 

Logged


* February 07, 2019, 02:03:26 PM
#6
I find that there are some strange things going on.

Dave and Icemoore

Ive had most of the TC versions since V4 ... Some versions were great and others just a fail.
For me >> V2016 PP is a fail

I did settle it down via >> installing the 32bit & 64bit programs, and changing some the user settings .... but as Dave mentions, some strange things going on.  .... I had to abandon it.

Cheers
Mike
 




Logged


February 08, 2019, 12:15:26 AM
#7
Personally, it is annoying that the HD Saver setting (which I can change in my BIOS) results in my hard drives being turned off after several minutes of inactivity.

It would seem to me that one solution would be to transition from a spinner (traditional hard drive) to a solid state drive (SSD or NVMe).  I've only gone part way (programs on NVMe and data on spinners).


Jeff

Logged
TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* February 11, 2019, 05:37:09 AM
#8
I don't think it has anything to do with the type of HD you have.  I have 2 SSD's in my machine and most save/open dialogs in other windows programs open in less than 1 second.  This is all Turbocad.

Logged


* March 15, 2019, 05:22:59 PM
#9
I believe we experienced the same thing moving from v21 to 2018.

I'm a "save often save different" guy so I noticed the TC was very slow on the Save As. Maybe not 25 seconds but enough for some finger tapping and looking out the window.

I have recently
- updated graphics drivers
- cleared out the built-in folder as recommended in https://forums.turbocad.com/index.php/topic,9797.0.html

tying to toubleshoot other issues and have noticed that the Save As is back to nice and fast, less than a second. Hope that helps some of those viewing this topic.

Logged
TurboCAD Pro Platinum 2018 64 bit