TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
The purpose of these forums is to discuss TurboCAD.  Please keep the discussion of other products to compatibility issues or how the other software’s can be used with TurboCAD.


Unsafed resp. lost data in TC2018PP version
Read 712 times
January 08, 2019, 04:28:51 PM
Hello,

my name is Manfred. Just did first constructions in TC2018PP and got severe issues with the software. Parallel TC2017PP and TC2015PP is installed and working under Windows 10 / 64.

   Made a construction by using among other things the bending tool, chamfer and radius tool. After saving the file and opening again the parameters were lost!
Bending parameters:
   - Bend 1:
      - Bending angle: was set to 90° and was reset to 57.29779°
      - Bending radius: was set to 1 mm and reset to 1 mm
      - Neutral depth: was set to 0.75 mm and reset to 0 mm
   - Bend 2:
      - Bending angle: was set to 45° and was reset to 0°
      - Bending radius: was set to 0.1 mm and reset to 0 mm
      - Neutral depth: was set to 1.25 mm and reset to 1 mm
   It seems that Bending radius and Neutral depth are round off to integer.
   The bending angle at 90° is 90°/(π/2) = 57.295779° !!! (π/2 = 90°)
     
   Out of this all construction on the bent latches like holes got lost when the bending angle got corrected. The points for the holes went to max. 9,25596E+61 mm and cannot be selected and corrected only deleted!!!

   The chamfer and radius parameters seems also to be round off to integer. Also some of the corners in the selection got lost and have to be add again!!

When the file is stored in TC2017 Format and loaded in TC2017 then the failures are also present. With the bending parameter correction the elements placed on the bent parts are automatically corrected. The chamfer and radius parameters have to be corrected as well. When the file is stored and loaded again the construction retains.

When this (correct) file is loaded again in TC2018PP then immediately the failures are present again!!

Are these issues already known?

Are there any solutions or workarounds?

Logged


January 10, 2019, 10:29:59 AM
#1
   Hello,
was investigating more details to the bending angle!

When the bending angle is 90° the radiant to it is π/2 = 1,57079. This value get round off to integer -> 1. Converting this to degree this will result in 57.295779°.
When the bending angle is 45° the radiant to it is π/4 = 0,78539. This value get round off to integer -> 0. Converting this to degree this will result in 0°.

Where the definition has to be set so that instead of integer real numbers will be used.

Logged


* January 10, 2019, 11:11:16 AM
#2
   Hello,
was investigating more details to the bending angle!

When the bending angle is 90° the radiant to it is π/2 = 1,57079. This value get round off to integer -> 1. Converting this to degree this will result in 57.295779°.
When the bending angle is 45° the radiant to it is π/4 = 0,78539. This value get round off to integer -> 0. Converting this to degree this will result in 0°.

Where the definition has to be set so that instead of integer real numbers will be used.

Go to Options>Drawing Setup>Angle>Precision. Use a value of at least 6.

Henry H

Logged


January 10, 2019, 11:23:05 AM
#3
   Hello Henry,

have the same issues with chamfers and radius that the values are round off to integer. The accuracy is set to 5 digits. It seems more a parameter in the system defaults!!
« Last Edit: January 10, 2019, 11:24:59 AM by ManniBlue »

Logged


* January 10, 2019, 12:29:29 PM
#4
Can I ask.  What do you have options menu - drawing setup - space units set at.  As far as I can tell,  the bend parameters are taken from the space units. 

Maybe best to post a screen shot of the space units dialog, and possibly post the .tcw file for someone to check.

Logged


January 10, 2019, 01:11:14 PM
#5
   Hi Andy,

see in the attachment the settings and a construction saved under TC2018PP and under TC2017PP.

In 2017 everything is okay, in 2018 the bending, chamfer and radius information got lost!

Logged


* January 10, 2019, 04:53:33 PM
#6
Thanks for the files.  Only had a quick look up to now, and although I now understand what you mean about the bending,  I have not yet been able to replicate the fault.   I'll try again later (UK time), but hopefully some one will be able to replicate the error.   

Logged


January 11, 2019, 12:39:30 PM
#7
   Hi Andy,

please note as well that when you are using the bending pipe module you have the same issues with the bending angle and azimuth angle!

The bending radius, neutral depth, the chamfer sizes and radius are round off to the next integer!!!!! This let you construct correctly but after loading the file again all values are changed! Even after correction saving and loading everything is gone!  >:(

Logged


* January 11, 2019, 06:27:30 PM
#8
HI. 

I tried a few different things, but cannot get the bend to fail, even after multiple closing and opening the file in 2018.  and given that it looks like others have downloaded the file, and not commented on a problem, I assume they couldn't replicate the fault neither.  Why your bend angle is being converted to the degree equivalent of 1 radian, I've no idea.

I tried bend sheet and bend tube, both work fine every time, after multiple saving / opening of files.

Normally for 'odd' faults I'd suggest deleting built in folder or repair or re-install,  but on this occasion I'd suggest having a word with IMSI Support..  The only odd things was,  according to the tcw file, you are using TC 2018 build 50.1, whereas I only have build 49.0.  Whether this is because you have a German version I don't know.  Maybe someone with build 50.1 can check the file.  But I would advise contacting support, and pointing them to this thread.  (though they may not be in work until Monday).

Andy

Logged


* January 11, 2019, 07:16:47 PM
#9
Like Andy, I cannot replicate the problem.

Henry H

Logged