TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
The purpose of these forums is to discuss TurboCAD.  Please keep the discussion of other products to compatibility issues or how the other software’s can be used with TurboCAD.


Definition
Read 487 times
* November 29, 2018, 02:01:08 AM
Hello. I've been trying to work out the following issue without success. I'm using Turbo Cad 2016. Non horizontal or vertical lines are made up of a series of smaller vertical and horizontal segments. With very shallow gradients I get two long horizontal/vertical lines (i.e.big segments) instead of a smooth shallow gradient. Is there any way that I can set these vertical and horizontal segments to be as small as possible so that my non horizontal/vertical lines look smoother. I've tried to set the definition as high as possible but this has not helped. Any thoughts? Thanks. Timsboats 

Logged


* November 29, 2018, 02:09:56 AM
#1
Are the lines jagged when you print them?
« Last Edit: November 29, 2018, 02:14:51 AM by nikkipollard »

Logged
Nikki
TC20 platinum
TC 2015 platinum
TC 2017 with lightworks


* November 29, 2018, 02:32:27 AM
#2
Thanks for the reply. No, the lines aren't jagged as such.  The specific problem is as follows: If you're drawing a long tapering item say 5 mm width at one end, 70 mm long and 4mm width at the other end. Each edge line is not a gradient (as it should be) but is formed by two long horizontal lines at different levels (i.e. 4 and 5 mm) joined in the middle. These lines are then printed as described (i.e. stepped) and not as the required gradient.   

Logged


* November 29, 2018, 03:48:31 AM
#3
Hi.  You may need to add some info so someone can try to replicate.  I just gave it a try and obviously it depends on zoom level, but I get anything from 12 segments at zoom extents of an angled line ( with a 1mm rise at 70mm ), to 2 segments if I zoom out to 40% which is about what I would expect.

My screen is 1920 X 1280, using TC full screen.  I use RedSDK mode with hardware aliasing turned off,

The questions would be. Graphics card,  what screen size. TC 2016 pro / deluxe / designer.  Native draw mode (GDI or RedSDK).  if RedSK, a screenshot of the Native draw dialog box  (from the options menu, which will show your setup).  Maybe someone with the same set-up as yourself can see how things look on their computer.

### Edit ###  Oops. I missed reading this bit.  "These lines are then printed as described (i.e. stepped) and not as the required gradient." so the above test I did was probably wrong.  ### End Edit ###
« Last Edit: November 29, 2018, 05:16:45 AM by Andy H »

Logged


* November 29, 2018, 04:21:43 AM
#4
So it is not a display problem? Are you using a polyline with different starting and ending widths?
If you are I can  see what you are talking about but I thought it was a display problem because when I zoom in the Jags disappear.
Try printing to see if there is still a problem
« Last Edit: November 29, 2018, 04:26:10 AM by nikkipollard »

Logged
Nikki
TC20 platinum
TC 2015 platinum
TC 2017 with lightworks