TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Interested in some really terrific mobile apps? Visit www.turboapps.com for details.

Can't select following 3d boolean operations
Read 646 times
* November 27, 2018, 06:35:57 PM
This problem existed in TC 2017 Deluxe as well, but is much more frequent in TC 2018. 
The problem is related to selecting objects following 3D Boolean operations.   It goes like this:  I do a 3D Boolean operation, doesn’t matter which, and when attempting to do a follow on 3d Boolean operation I will often be unable to select the new just created composite object.  Alternately I might be able to select the first object for the operation but not the second one.
I have tried switching from the model space to the paper space and then back, but that never corrects the problem.  The only thing that works is save the file, restart TC and then reopen the file, which works every time.
I’ve been using TC for about a year and have done thousands of these operations. Originally this only occasionally occurred, but currently I have this problem 1 out 4 Boolean operations and it costs me a lot of wasted time.
This occurs regardless of rendering mode and regardless of which rendering engine is used.
Any thoughts.

Logged


November 28, 2018, 03:07:36 AM
#1
Under the Windows Device Manager, find the TurboCAD program listing in the main window and then click on Repair (just above the main window).


Jeff

Logged
TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* November 28, 2018, 04:55:59 AM
#2
Jeff,   I assume you mean "Programs and Features" not "Device Manager" as you know, the device manager lists devices not software. At any rate I recently did a software repair because immediately following the TC 25, build 49 install all 2D boolean tools disappeared. The repair operation restored these tools but didn't seem to have an effect on this post 3D boolean selection problem. 

I will of course run the repair and followup up on this post with results in a couple of days. 

Thanks for weighing in on this.  Resolving these sort of problems are very frustrating. You never know if you are somehow causing it or its a software/hardware issue.


Logged


November 28, 2018, 10:53:46 PM
#3
Jeff,   I assume you mean "Programs and Features" not "Device Manager"...

Actually, I meant "Uninstall a program", but your method took you to the same place.

Thanks for weighing in on this.  Resolving these sort of problems are very frustrating. You never know if you are somehow causing it or its a software/hardware issue.

Happy to help.  I've gotten enough of it here over the years.


Jeff

Logged
TC Pro Platinum 2019, 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* December 05, 2018, 04:56:41 AM
#4
update

Well after running the repair process several times, I still find that frequently following 3D Boolean operations I can no longer select the new compound object.  So far the only fix for me is to close the file and reopen it and I've got to tell you when you doing thirty or forty of these operations, it makes you want to find another piece of software.

Logged


* December 05, 2018, 05:37:08 AM
#5
If Repair don't fix it, and a reload of your's or Default cfg (UI) dont work.
Close TC
Delete the bult-in folder
( if the problem is "sticky" i also close and start pc again ( cold start) to make sure nothing hang in the system )
Open TC and and load your cfg, set template etc etc and se if it help in your drawing.
If not, open a New from scratch drawing and see if the problem is gone , in case, copy everything from drawing over to a New drawing and see if that help.

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* December 06, 2018, 05:52:51 AM
#6
I went ahead and deleted the built-in folder and we'll see if problem persist, but I need to point out that this behavior is not unique to this project file.  It has been a recurring issue with TC 2017 and is worse with TC 2018, especially after build 49.  I've also noted a similar issue when selecting just created prism lofts and when selected just copied objects, 2D or 3D.   

Logged