TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When posting a problem be sure to include which version you are using.  Give as much information as possible.  If the problem is with a specific file be sure to attache it to your post.

TC 2018 Platinum - Named Workplane problem
Read 380 times
October 30, 2018, 03:46:40 PM
Hi

I have a problem with the "Named workplane" function. I can place the Workplane where I want , after I'm going to name my view and name it. I move to another named Workplane still in the "Named Workplane" dialogue and the workplane I'd just selected had move just l little bit. I try the new Named Workplane had moved a little bit too. Same thing for others named workplane

Is someone got an idea what cause this problem?

See attached file

Thanks and have a great day!

Jean

Logged
TC  Pro Platinum 2018
Windows 10, AMD Ryzen 2500u @ 2.0ghz
16 gigs RAM, Radeon Vega 8

Believe you can do something or not, in both cases you are right     Henry Ford


November 05, 2018, 03:18:46 PM
#1
I made the request to technical support. I'll come back with their answer

Logged
TC  Pro Platinum 2018
Windows 10, AMD Ryzen 2500u @ 2.0ghz
16 gigs RAM, Radeon Vega 8

Believe you can do something or not, in both cases you are right     Henry Ford


November 05, 2018, 04:25:17 PM
#2
One odd thing is that, when you look at the list of Named Workplanes (first thing after opening the file), two different ones are simultaneously selected.  I occasionally see two Layers selected as the Active Layer.  That's not supposed to happen, either.

My question, however, remains the same... how do you know that a de-selected Workplane has moved?  The list shows the Origins of each Workplane, but I don't see any of them changing when I click to activate any other Workplane.


Jeff

Logged
TC Pro Platinum 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* November 05, 2018, 05:12:00 PM
#3
My question, however, remains the same... how do you know that a de-selected Workplane has moved?  The list shows the Origins of each Workplane, but I don't see any of them changing when I click to activate any other Workplane.
Jeff

I looked in front view, where one can normally see the 'Red' workplane line changing,  though occasionally it gets stuck.

Is someone got an idea what cause this problem?
Jean

Sorry you didn't get an answer previously,  I looked at the file when you posted it,  but I could not recreate the problem.  I edited the existing workplanes and created new ones.  Every time I Saved and opened the file or did anything, the workplanes remained as I set them.

One minor note,  I don't know if deliberate or not, but the first two workplanes are upside down, (Z axes faces downwards), as I say this could be deliberate.   

One thing I just thought of,  If for some reason the 'space unit precision' was set to '0' when the workplane was created.  This rounds the workplane 'Z' coordinate to an integer, thus will shift the workplane to match this whole number. Though I can't think of any reason for the space units to change to '0' precision.

Logged


November 10, 2018, 05:11:44 AM
#4
Hi Jeff

Sorry for the delay...busy week!

I just tried to name somes workplanes and the same thing happen. To response to your question, I'm going to "[email protected] dialogu and choose differents workplane I set before the  workplanes appears at differents worplanes levels than I set

Maybe the response is on the Andy's post. See my response to Andy

Thanks and have a great day!

Jean
« Last Edit: November 10, 2018, 05:22:56 AM by linuxbbas »

Logged
TC  Pro Platinum 2018
Windows 10, AMD Ryzen 2500u @ 2.0ghz
16 gigs RAM, Radeon Vega 8

Believe you can do something or not, in both cases you are right     Henry Ford


November 10, 2018, 05:22:27 AM
#5
Hi Andy

Sorry for the dealy, busy week!

To your comment

"One thing I just thought of,  If for some reason the 'space unit precision' was set to '0' when the workplane was created.  This rounds the workplane 'Z' coordinate to an integer, thus will shift the workplane to match this whole number. Though I can't think of any reason for the space units to change to '0' precision."

I think it makes sense, but I don't know to set the Space unit with more precision. How can I do that? And I have little control over the Workplanes settins. Sometimes the origin of a Workplane isn't on the workplane I create or far away on the drawing area. How can I fix it please?

Thanks and have a great day!

Jean

Logged
TC  Pro Platinum 2018
Windows 10, AMD Ryzen 2500u @ 2.0ghz
16 gigs RAM, Radeon Vega 8

Believe you can do something or not, in both cases you are right     Henry Ford


* November 10, 2018, 08:30:50 AM
#6
"I think it makes sense, but I don't know to set the Space unit with more precision. How can I do that?"

Go to Options>Drawing Setup>Space Units. Set the Precision in the box at the right side of the dialog, about halfway down, then click the "OK" button at the bottom. I recommend using a Precision of at least 6. 

Henry H

Logged


* November 11, 2018, 04:14:32 AM
#7
Jean

The reason I mentioned "Though I can't think of any reason for the space units to change to '0' precision."
, was because your drawing had a decent space unit precision set.  So for it to revert to zero I cannot explain, I would not think it was deliberate.  but reverting to zero was the only thing I could think of (and replicate), to account for the integer values of your workplanes.  It could quite easily be an 'odd' bug, that requires a specific set of circumstances to present itself.

I cannot say this is what actually happened, but is something to check when setting your workplanes in future.

As for origin and the red dashed workplane indicator.  I've no idea what parameters TC uses to display it.  But to be honest, I don't bother about it.  For example if it is a plan view workplane, as long as the plane height is correct, the x, y can be anywhere.  Sorry I can't provide better details,  but its possible only the programmers know what calculations they use to display the plane.

Logged


* November 11, 2018, 10:54:45 AM
#8
re: …I've no idea what parameters TC uses to display it.… 

Most times, the WorkPlane indicator will use "Screen Extents" to display; so the indicator rectangle fills the entire screen. When using a side view to the WP, it seems to use screen height to determine the length, though that may not always be the case.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


November 12, 2018, 06:06:47 AM
#9
Henry

I did what you suggest, it wa already set to 6. I changed it to 4 and nothing change


Andy

I tried to set the precision in Space unit to zero, nothing change the problem subsist. I'm gonna make another drawing and make Space unit settings before start it

I'll be back with that this week

Logged
TC  Pro Platinum 2018
Windows 10, AMD Ryzen 2500u @ 2.0ghz
16 gigs RAM, Radeon Vega 8

Believe you can do something or not, in both cases you are right     Henry Ford


November 12, 2018, 06:24:00 AM
#10
To everyone

I start this simple drawing (see attached file) and try with Precion in Space unit to  0 and to 6. I put the Worplane on the top of each object and Named it after each change

With the precision to 6, Workplane stays on basic workplane (by world). When I set the Precision to 0, the top WP of the bigger object shift to a defferent level and the top of the smaller object stay to basic level

I don't know what I,m doing to have this result :-\  Yet I lead a good life 8) haha


Logged
TC  Pro Platinum 2018
Windows 10, AMD Ryzen 2500u @ 2.0ghz
16 gigs RAM, Radeon Vega 8

Believe you can do something or not, in both cases you are right     Henry Ford


* November 12, 2018, 08:19:04 AM
#11
Hi Jean.

It is probably myself who may not have explained properly.  setting space units to zero, is actually bad, unless one specifically wants everything to be whole numbers.

What you see with units = zero, is actually correct,  the smaller object is only 0.23 inch tall, so a workplane on top will reset itself to 0 inch position in 'z' direction, and the taller one, which is 0.9 inch tall, will reset to 1 inch (position in the 'z' direction). it is essentially rounding the workplane to a whole number.  Hence why its not a good idea for space units to be zero.

With the space units at precision 6.  Could you please explain the steps your using to place the workplane, as there are a few variables.  For example. If one is using workplane by 3 points, it should (in my opinion) be done in an isometric view to ensure snapping to correct points, and workplane by entity may not snap where one thinks it should.   If you could outline what workplane tools you are using (by entity, by 3 points, by facet etc.).  And what snaps you are using (running snaps or Seke's).  I'm sure someone will be able to advice (probably better than what I can).

Logged


* November 12, 2018, 09:42:02 AM
#12
Hi everyone,

sorry. But in my opinion actually simple, I have measurements in meters with for example:

1m -> space, unity, accuracy 1
2m --> space, unity, accuracy 1
3,2m --> space, unity, accuracy 2
3,4m --> space, unity, accuracy 2
4,56m --> space, unity, accuracy 3
6,57m --> space, unity, accuracy 3

So I have to specify in the units always a unit more to get the right (desired) rounding.

P.S. Thus, it is not a TC problem, but a mathematical problem.

Logged
-----------------------------------------------------------------------------------
Very low knowledge of English - I ask for indulgence - Thanks
Currently installed
TurboCAD  Professional 32-bit V.17.2.77.1
TurboCAD 2016 ProPlatinum 64-bit V23.2-61.2 engl.
TurboCAD 2015 2D V.22.2.51.4
on Win 10.


* November 12, 2018, 10:08:01 AM
#13
My 2 bits from years ago.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


November 12, 2018, 04:49:04 PM
#14
As you suggest Andy I did this short video to show what's happen

The first video had been make with precision 0 and the second one with precision 6. I cannot add a new video on this post, I'll make a new post with the last video
« Last Edit: November 12, 2018, 05:45:17 PM by linuxbbas »

Logged
TC  Pro Platinum 2018
Windows 10, AMD Ryzen 2500u @ 2.0ghz
16 gigs RAM, Radeon Vega 8

Believe you can do something or not, in both cases you are right     Henry Ford


November 12, 2018, 05:12:47 PM
#15
Video with precision 6

Logged
TC  Pro Platinum 2018
Windows 10, AMD Ryzen 2500u @ 2.0ghz
16 gigs RAM, Radeon Vega 8

Believe you can do something or not, in both cases you are right     Henry Ford


November 12, 2018, 05:36:04 PM
#16
Thanks sauerkraut2018  and John R, it's gonna be helpfull! :)

Logged
TC  Pro Platinum 2018
Windows 10, AMD Ryzen 2500u @ 2.0ghz
16 gigs RAM, Radeon Vega 8

Believe you can do something or not, in both cases you are right     Henry Ford


* November 13, 2018, 08:15:25 AM
#17
Than you for the video Jean. 

I reset TC to closely match your setup, including which snaps were selected.  I drew 3 random sized boxes, and followed the procedure in the video.  Alas, I cannot replicate the problem you face. 

Sorry, but I've run out of ideas, Hopefully someone can replicate the problem.  If it was me, I'd delete the built in folder, and reset the configuration,  But I cannot suggest you do the same, as it may not make any difference. It could be something like corrupted templates, but all this is just pure guesswork.

Andy 

Logged


November 13, 2018, 08:49:18 AM
#18
Thanks Andy

I send the Unsolved mystery video  ::) (the same you opened) to the technical support

Have a great day!

Jean

Logged
TC  Pro Platinum 2018
Windows 10, AMD Ryzen 2500u @ 2.0ghz
16 gigs RAM, Radeon Vega 8

Believe you can do something or not, in both cases you are right     Henry Ford