TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Interested in some really terrific mobile apps? Visit www.turboapps.com for details.

Layer Settings
Read 327 times
* October 21, 2018, 04:12:23 AM
Hi. My layer settings keep changing by themselves. I will open the layer window, give my desired work layer a green check and make it visible. I then make all the other layers invisible. Usually I close the layer window, but sometimes I leave it open. Often, when I start working, the work layer changes itself. Sometimes I get a message saying I am working on an invisible layer. If I left the layer window open, I can see the green check mark pop from the layer I selected to another layer. Why is this happening, and how can I stop it?

Thanks,
Eric

Logged


* October 21, 2018, 04:26:29 AM
#1
Turbocad works differently to autocad. Each tools properties will switch to the last setting you used for that tool.

You can turn this behaviour off by going to options advanced preferences and checking the box "apply general property changes to all tools  presets"
Before doing this I would recommend reading the help on property toolsets as they can be very useful as you can save different combinations of properties ie layer, pen width , brush style and quickly switch between the toolsets as you work.

https://turbocaddoc.atlassian.net/wiki/spaces/T2UG/pages/90571059/Property+Value+Presets

Logged
Nikki
TC20 platinum
TC 2015 platinum
TC 2017 with lightworks


* October 21, 2018, 04:42:28 AM
#2
I then make all the other layers invisible.

One comment on layer '0'  unless for a special reason, like temporarily turning off to see what's on a certain layer,  I would advise -  Do not turn off layer '0'.  As well as a drawing layer it is also used internally by TC for some of its own operations. 

Logged


* October 21, 2018, 04:51:52 AM
#3
Thanks for the comment on layer 0. That turned out to be why my coordinate system disappeared. However, I would still like to leave it on all the time.

As to the layers changing. After Nikki's post, I tried creating different types of entities and indeed that is what triggered the work layer to change. However, I clicked the "apply general property changes to all tools presets"  box but the layers are still changing when I select  to create a different type of entity.

Thanks,
Eric

Logged