TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Remember to do a search before you ask a question!!!

Nodes are not Visible
Read 205 times
* October 16, 2018, 02:57:52 PM
Nodes have become invisible in several drawings. Pro Platimum 2017 working in 2d. I can select with rectangle, but there is no visual as to where the cursor clicks are. Objects are selected, but without nodes. Node edit works, but again there are no visible nodes, I have to remember where the nodes and reference point are located. Rotation handle is also invisible.

Logged


* October 17, 2018, 04:12:55 PM
#1
Don't know if you have it sorted yet or not. 

I can not think of one settings that would affect everything. the bounding box and rotation handles are controlled by the selector properties, but that doesn't normally  affect node edit mode as far as I know.  Does it still happen in a new from scratch file.

Logged


* October 17, 2018, 05:49:57 PM
#2
No, not sorted. I am able to see bounding box with the select arrow, but not with select edit. As well with any drawing tool, there is no visual clue as to where nodes have been placed until the tool has finished the element. The element then appears. I have a screen shot to post, but I'm not seeing how to post it. It happens with new files from scratch and from templates.
« Last Edit: October 17, 2018, 05:57:27 PM by David Mitchell »

Logged


* October 17, 2018, 06:22:04 PM
#3
David, please post a .tcw file that shows the problem.

Henry H

Logged


* October 17, 2018, 06:28:10 PM
#4
I think it a quirk.  Try one of these.

Draw a Square.
With no objects at all selected,   Select the edit tool.
On the inspection bar, there are some icons, the select arrow and next to that is On/Off node filter,  I suspect node filter may be turned on.  If so, turn it off (so its unselected).  Note, if you select an object with the edit tool the node filter will grey out so you can't turn it on or off.
Go back to select arrow, and draw another square, see if the nodes are now showing up.   

OR

Draw a square.
Select extrude tool.
Extrude the square to any height.
Select the edit tool.
On the inspection bar, there are some icons, the select arrow and next to that is On/Off node filter,  I suspect node filter may be turned on.  If so, turn it off (so its unselected).
Go back to select arrow, and draw another square, see if the nodes are now showing up.   

If that doesn't work, follow Henry's advice.

 
« Last Edit: October 18, 2018, 02:13:54 AM by Andy H »

Logged


* October 18, 2018, 11:04:24 AM
#5
Henry & Andy, I've attached a file. The issue seems to be program related, as any file behaves the same.

I've tried the node filter on/off switch solution, to no avail.

Appreciate the help.
« Last Edit: October 18, 2018, 11:06:02 AM by David Mitchell »

Logged


* October 18, 2018, 01:01:57 PM
#6
David.  I tried your file but it works fine for me.

Hopefully someone will detect the problem, but.  The only things left I can suggest are below.   Note, they will reset TC and you will lose any customisation if not previously save.

Reload Configuration.   Tools menu - customise - options tab, find the config you normally use from the dropdown list under 'load from', then click 'Load From'.   May work but I'm not confident.

Then if still not working,  delete the 'Built In' folder,   instructions here.

Lastly Repair or re-install.

As I say, hopefully someone will have a better solution.  But if no other options, I'd try the above.

Logged


* October 18, 2018, 02:54:38 PM
#7
Works fine for me, too. I concur with Andy's advice.

Henry H

Logged


* October 18, 2018, 03:17:30 PM
#8
Works fine her as well, and i follow Andy except i would do the Repair first and then Built in, less manual work if the Repair work out, i'm lazy ;)

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB