TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Interested in some really terrific mobile apps? Visit www.turboapps.com for details.

Flyout Menus Don't Fly in
Read 386 times
* October 14, 2018, 11:22:11 AM
Greetings, All.

I recently installed TC2018PP and everything seems to work fine except when the auto hide palettes retract, there are artifacts left on the screen.  The artifacts consist of several vertical stripes about 1" wide made up of portions of the palette which is retracting.  The artifacts remain until I zoom or perform some other screen operation.  The palette icons are along the right side of the screen in the default position.  I have tried retraction times of 1 and 2 seconds with no difference.

This is a new installation and I have manually entered all my configurations. 

Can anyone tell me a setting or adjustment I can make to fix this?

TC 2018 Pro Plat 64b ver 25.0 Build 43.5
Motherboard MSI Z170-A  Video Card Nvidia GTX960  Monitor Asus 27" 2560 x 1440

OS Microsoft Windows 7 Professional
Version   6.1.7601 Service Pack 1 Build 7601
System Manufacturer   MSI
System Model   MS-7971
System Type   x64-based PC
Processor   Intel(R) Core(TM) i5-6500 CPU @ 3.20GHz, 3201 Mhz, 4 Core(s), 4 Logical Processor(s)

Installed Physical Memory (RAM)   16.0 GB DDR4-2400
Total Physical Memory           16.0 GB
Available Physical Memory   12.0 GB
Total Virtual Memory           31.9 GB
Available Virtual Memory   27.6 GB
Page File Space                   16.0 GB
Page File   C:\pagefile.sys

 

Logged


* October 14, 2018, 11:38:47 AM
#1
Try "Options / Native Draw" and turn on the "Flicker free draw" option.

"F5" can also force the screen to refresh.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


* October 15, 2018, 06:47:14 AM
#2
Thanks, John.

For reasons I do not understand, the problem just went away yesterday.  I will keep your suggestion in mind in case it shows up again.

Logged


* October 15, 2018, 12:51:20 PM
#3
The problem is back.  It seems to be only with a certain drawing which has about 90 layers and was brought in from TC2016PP.  I turned on Flicker Free Draw but that made no difference.

Logged


* October 15, 2018, 01:08:02 PM
#4
Layer 0 is missing from the problem drawing.  I am also missing some other layers which did not transfer when I opened the 2016PP drawing in 2018PP.  I figure I can copy the missing layers to the new drawing but I do not know how to get layer 0 back.  I know it is essential to have layer 0 visible at all times.  I cannot find it in Layer Manager or in Design Director.

Logged


* October 15, 2018, 01:37:05 PM
#5
Does the "0" layer re-appear if you close and reopen the file?

You could click on the "Name" in the Design Director, which will put everything in alphabetical order (thus bringing "0" to the top of the list). I wouldn't do this if you have your layers set up in a certain pattern. It's near impossible to restore to the original order.

As to your ‘artifact’ problem, maybe updating to the latest video driver or ask Support ([email protected]).
« Last Edit: October 15, 2018, 01:38:37 PM by John R »

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


* October 15, 2018, 01:48:51 PM
#6
Yes, that seemed to work.  I closed everything and restarted the computer and opened the files again and all seems okay for now.  Layer 0 is back and some other missing layers as well.

Thanks, John!

Logged


* October 16, 2018, 03:07:30 PM
#7
...and, it's back.  Layer 0 gone, and only 85 out of 93 layers on Design Director.  I did disc cleanup, and memory check on the computer and will now try to contact support to see if they can help.

Logged


* October 16, 2018, 03:38:23 PM
#8
Normally when this happen earlier on my machine i just remade layer 0, works like a charm, the object's was not gone, only the layer so i could not select them if i had something on layer 0, make a new 0 fix the problem, no need of restart TC.

In my case it was Property Set that was the trigger, so get rid off Entety Marker and Property Set cured the problem back i v 2016.
I have not tested that so much in v 2018 so maybe a different issue.

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* October 16, 2018, 10:43:29 PM
#9
  I am also missing some other layers which did not transfer when I opened the 2016PP drawing in 2018PP. 

Open up the original file in TC 2016.
If everything looks as it should .... Then fire up TC2018 (Leave TC2016 open)

Try the following ....
1: TC2018 >> Create a New Blank File from Page Setup Wizard.
2: TC2016 >> (Using the Top line only / Not the mouse) >> EDIT / Select all / Copy.
3: TC2018 >> (Using the Top line only / Not the mouse) >>Then in the blank new file "Paste".
4: TC2018 >> Save the file / close / open it ....

Cheers
Mike

Save the New file .... and see how it goes.

Logged


* October 24, 2018, 05:15:21 PM
#10
Thanks, Mike and Torfinn.

I removed all the materials from the 2016PP file and brought it into 2018PP.  I looked for any defects in the various layers and found none.  After bringing the drawing into 2018PP, all the layers including Layer 0 came through and the drawing works fine.  The palettes still hand when they should retract, however.

I am not sure why the palettes will not retract.  When I only have a few layers open, the palettes retract fine, although they are a bit jerky when retracting.  If I have several layers open, then the palette will hang, leaving the aforementioned vertical strips of the palette, see attached screenshot and drawing file.

I was able to duplicate this problem with another drawing in 2016PP on a different computer which makes me think this may be a setting issue.  I have monkeyed with the Docked Palette settings in the Customized Controls (Toolbars and Palettes) menu.

At this time, all the layers are present and working and the only issue I have is the palette retraction.  It is annoying because I need to make a screen change to get it to disappear.  I can dock the palette permanently but prefer to have the space.  I also worry that the retraction issue could be an indication that something else is not right with the software or my computer.

I submitted a request for technical support to IMSI over a week ago.  They assigned a ticket number but never replied.


Logged


* October 24, 2018, 09:15:34 PM
#11
I tried your file in my anemic Windows 7 EMachine (2 cores) and the palettes left artifacts behind when they closed down. TurboCAD 2018 Platinum (32-bit).
When I used my Windows 10 Work Station (24 cores × 2), the palettes opened and closed without any problems. TurboCAD 2018 Platinum (64-bit).

"F5" clears up the artifacts for me.
« Last Edit: October 24, 2018, 09:18:31 PM by John R »

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


* October 25, 2018, 03:36:48 AM
#12
Just tried installing 2018 onto on Windows 7 64 bit with an old GT 610 graphics card, and I get the same thing, its OK in Windows 10.

Clicking on the palette name (whilst the palette is open), instantly closes it without any artefacts,  but I didn't find a way to stop the palette animation when it Auto-closes.

Logged


* October 25, 2018, 05:00:00 PM
#13

I removed all the materials from the 2016PP file and brought it into 2018PP.  I looked for any defects in the various layers and found none.  After bringing the drawing into 2018PP, all the layers including Layer 0 came through and the drawing works fine.  The palettes still hand when they should retract, however.

I am not sure why the palettes will not retract.

I've used TC since V4.
Some items that affect the performance of TC ....

TC is memory hungry .... i am at 16GB ... and going to upgrade to 32GB.
TC is Resource hungry.
The video card .... TC does not appear to take advantage of the (Video) Drivers software ...
When i installed 2016PP 64bit ... it crashed .... I had to install the 32bit version to get the TC 64bit to perform.

I looked at your screen shot and noticed that Chrome is open .... So try the following.
1: Defrag your computer.
2: Turn off all computer & monitor Sleep settings
3: Shut down all internet / Email programs
4: Turn off Anti virus.
5: Fire up TC 2018 >> and see if it performs better.

Also ... Did you try the suggested, Copy / Paste to Blank file method?

Cheers
Mike

Logged


* October 26, 2018, 02:23:42 PM
#14
John R:

The only remedy I have left to try, other than getting a bigger, better, faster CPU,  is to upgrade to Windows 10.  Since the sliding palette is the only issue I have not resolved, I will dock the palette permanently.  The only bummer is losing 3 1/2 inches of screen.

I know I can make the artifacts disappear by refreshing the screen or various mouse moves but I use the palettes a lot and switch between them, so I am not inclined to add another keystroke to the operation.

Andy H:

I looked at upgrading to Windows 10 but decided not to at this time.  I went back to 2016PP on this machine and it really has a very jerky action, even on a new drawing.  If I pull the palette a good way out onto the screen, there is a definite jerky motion as the palette retracts.

I think they wanted to create a cool looking effect to impress users.  Other menus and windows in Turbocad do not have this type of action when deploying or closing.  It seems to me the palette should just disappear when it times out, instead of sliding away.

Mike:

I was at 8GB of RAM when I built my machine.  I had not problem but recently added another 8GB, just to be sure.

The video card or software could always be a problem.  I may see if there is a new driver for it.  I really had not thought of the video card driver.

When I installed 2018PP, upgrading from 2016PP, it worked great.  I only had a problem bringing my 2016PP file into 2018PP.

1.  I defragged the HDD, no detectable change but it was a good thing to do, of course.
2.  Although I had Chrome open when I was taking the screenshot, I normally have only TC running.  I usually have a laptop alongside which I use any internet or files I need to look at.
3.  I usually don't run the internet and made sure all apps were closed when troubleshooting this problem.
4.  I have Norton Antivirus and it can be a problem.  Turning it off was the first thing I tried.  It made no difference.

I tried the Copy/to Blank file method and that worked.

At this point, everything seems to be working okay, except for the auto-hide palette operation.  Since I can see this in both my desktop computer, I suspect it is a flaw in the program, perhaps relating to older operating systems, video cards, or drivers.

I really appreciate all your assistance with this problem!


Logged


* October 26, 2018, 03:01:48 PM
#15
Updated the video card driver, no change.

Logged


* October 26, 2018, 04:58:47 PM
#16
To upgrade to win 10 ... i would recommend that you invest in a Brand new build, due to the complications of setting up ... and the amount of "down time" of crossing over.

If all your worried about is Screen area ::) .... well, there are ways to improve.

Attached is a screen shot of my setup

Toshiba laptop / i7 / win 8.1 .... screen is a 4K 65" .... Generic brand >>TV monitor on HDMI port 1 ...

Cheers
Mike
« Last Edit: October 26, 2018, 05:04:03 PM by Mike90RR »

Logged


* October 26, 2018, 09:51:13 PM
#17
Why not pick up a second monitor and put a palette ‘nest’ on it. Have your drawing area in one screen and the palettes nested in the other. I've been using that setup for years. I can roll up the palette nest when not needed to view applications under it.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit