TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When posting a problem be sure to include which version you are using.  Give as much information as possible.  If the problem is with a specific file be sure to attache it to your post.

"Copy in place" is way slow
Read 804 times
* October 13, 2018, 09:42:36 AM
Using PP2018 on Win 7 with a 25MB file on a slower system.

Any ideas why "copy in place" will freeze the program for a few seconds while "copy linear" or "copy mirror" or any of the others copies are instantaneous?  Even copying a polyline or a rectangle will freeze it for a couple seconds while I can "copy linear" or "copy mirror" hundreds of more complex entities at the same time without a noticeable delay.

My resource monitor doesn't show a jump in RAM usage, but does a noticeable jump in core utilization on 2 out of 4 cores.  No where near maxing the cores (10-20% to 50-60%).

This does not happen with an empty project with just a few lines/rectangles.

 

Logged
Cameron Miller
TurboCAD 2018PP, 2016PP, V20PP
Windows 7 pro


* October 13, 2018, 10:34:29 AM
#1
Maybe because it's a 32 bit program

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* October 13, 2018, 06:41:49 PM
#2
Maybe because it's a 32 bit program

Torfinn

If this is the case, why would all the other copy commands work fast and only "copy in place" be slow?

Logged
Cameron Miller
TurboCAD 2018PP, 2016PP, V20PP
Windows 7 pro


* October 13, 2018, 07:18:25 PM
#3
Because it's a special tool originally, made in a 32 bit system, and is "translated" to also work in 64 bit, the other copy tool's is 64 bit i believe in a 64 bit system
Have you tested another way for Copy in Place, by select object, check copy tool, then just click Tab and then the Enter button ??

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


October 13, 2018, 07:27:49 PM
#4
Because it's a special tool originally, made in a 32 bit system, and is "translated" to also work in 64 bit, the other copy tool's is 64 bit i believe in a 64 bit system
Have you tested another way for Copy in Place, by select object, check copy tool, then just click Tab and then the Enter button ??

Torfinn

I have no issues with the copy in place on my 64 bit computer. It is as fast as every, with no noticeable difference from other copy tools. As such, I would assume it is system specific to anyone who has issues with it.


* October 13, 2018, 07:39:54 PM
#5
I also have no problem with it, but it is a bit different from other copy tool that are re-written to 64 bit, this one is "translated" if i have understand it correct.
So maybe …

Torfinn

Edit: Another thing is to delete the wrapper as i believe that is the "translater" and if i dont remember wrong it will rebuild itself next time TC start, but just in case, copy it and place it somewhere outside of TC.

 C:\Program Files\IMSIDesign\TCW2018\Program64 >> dbautosrvwrapper.exe
« Last Edit: October 14, 2018, 07:51:09 AM by Torfinn »

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* October 15, 2018, 10:56:30 AM
#6
Thanks for the all details.  I'll just avoid using it!

Logged
Cameron Miller
TurboCAD 2018PP, 2016PP, V20PP
Windows 7 pro


* October 15, 2018, 01:51:49 PM
#7
I  rarely use "Copy in Place". I'll pick up the selection, hold the "Ctrl" key, then snap it to another location.

Logged
John R.

V17—V21, 2015—2019
Designer, Deluxe, (Professional, Expert, Basic), Platinum
RedSDK enabled
Windows 10 Pro (1803), 64-bit