TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Be sure your post is relevant to the current discussion.  Create a new topic within the appropriate board if you are unsure.

LTE problems
Read 331 times
* September 10, 2018, 04:54:36 PM
Hi all,
I switched to LTE.
I was really struggling with the default program defaulting to line every time I opened a file. I now know what has caused several problems in the past with space dust!! and I just got fed up with drawing lines straight off 8 out of 10 times I opened up a file.

So in LTE I have done something and I have lost the ability to rotate the object, all the mouse wheel does is pan the object. There is also a graphic I have not seen before, looks like a sort of padlock. This disappeared when I re-opened the file, but I still can't rotate it.

Also, how does one finish an operation? there is no finish flag and return or Esc. does not get me out of the tool.

TC21 Pro.

Logged


September 10, 2018, 10:39:18 PM
#1
Bring up the Customize popup menu and click on the Options tab at the top.

In the Workspace area, verify the desired Style is listed under the Load From: button, then press the Load From: button.

If that doesn't help, then get back to the Options area as described above and click on Additional Devices Setup at the bottom and review the mouse button settings.

If the above two suggestions don't fix your problem, then you can try clearing out the Built-In folder (see http://forums.turbocad.com/index.php/topic,9797.0.html).

But, personally, I'd just incorporate "TurboCAD starts with the Create Line function active" into my long-term memory and proceed from there.


Jeff

Logged
TC Pro Platinum 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* September 11, 2018, 08:33:12 AM
#2
Jeff,
Thank you.

Part of my problem is finding all these undocumented procedures.
How do  incorporate "TurboCAD starts with the Create Line function active" into my long-term memory. I can find no reference to this anywhere.

Will this give me a 'select' cursor on opening a file in TC default workspace ?

Marcel

Logged


* September 11, 2018, 08:28:45 PM
#3
TC is predicated on commencing a new drawing with each start, rather than editing an existing drawing.  A new drawing has nothing to select, select has no function, and you do have to change tool to do anything in that circumstance.   TC's been around for probably nearly as many years as AC, which does open with select active, and LTE's supposed to be a familiar interface for crossover AC users, I suppose an AC user who's starting a new drawing faces the converse scenario.   IMSI people have explained this reasoning many times over many years.  Maybe the new owners are open to changing that, but there's no current provision to change it other than by using the LTE interface.  TC has never had a provision to do anything else.

Logged


* September 11, 2018, 09:29:23 PM
#4
Hi all,
I switched to LTE.
I was really struggling with the default program defaulting to line every time I opened a file. I now know what has caused several problems in the past with space dust!! and I just got fed up with drawing lines straight off 8 out of 10 times I opened up a file.

So in LTE I have done something and I have lost the ability to rotate the object, all the mouse wheel does is pan the object. There is also a graphic I have not seen before, looks like a sort of padlock. This disappeared when I re-opened the file, but I still can't rotate it.

Also, how does one finish an operation? there is no finish flag and return or Esc. does not get me out of the tool.

TC21 Pro.

The Dynamic View Control layout is different in LTE.
   •Holding the mouse wheel gives you Dynamic Pan.
   •Holding the mouse wheel plus the "Shift" key gives you Dynamic Examine (what you're looking for).
   •Holding the mouse wheel plus the "Ctrl" key gives you Dynamic Turn.
   •Holding the mouse wheel plus the "Shift & Ctrl" keys gives you Dynamic Roll.
They did not assign "Dynamic Zoom" to anything. A big mistake in my opinion.

I think I've seen a large padlock image at some point in time, but can't remember why it occurred. There is a small padlock icon on the Dynamic Input fields (aka Inspector Bar) that is used to lock in whatever value you place in that field.

To finish an operation in LTE:
   •Alt+F
   •Right-click and select "Finish" in the Local Menu
   •Type in "finish" in the Input field or the Command Console.

Hopefully this is of some help.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


September 12, 2018, 12:00:02 AM
#5
How do  incorporate "TurboCAD starts with the Create Line function active" into my long-term memory. I can find no reference to this anywhere.

That was a play on words.  I meant that you should just remember that TurboCAD will always start with the Create Line function active and that you should remember that so you don't make a mistake.


Jeff

Logged
TC Pro Platinum 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* September 12, 2018, 12:14:29 PM
#6
Jeff,

I spent hours searching for those answers., the manual is woefull on detail of such things. It is probably in there somewhere, but finding it ????

I am still trying to decide if the LTE interface or the default interface is better. I get the reasoning behind starting a new drawing with a line, and have read a good amount of the discussions over this point. Personally I always start a drawing with construction lines. It was the way I was taught many years ago on pencil and paper, and it is kind of hard to get out of the habit.
However, when opening up an existing drawing the number of times I have drawn a line instead of selecting something is countless.

Jeff,

Sorry,

Now I understand.

Thanks All

Anyway; back to the project.

Logged


September 12, 2018, 04:28:19 PM
#7
Personally, I do not understand the need to have any function enabled by default.  It's not that way in my schematic capture or PCB layout software, nor my LabVIEW programming suite, or even Word or Excel.


Jeff

Logged
TC Pro Platinum 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1