TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Be sure your post is relevant to the current discussion.  Create a new topic within the appropriate board if you are unsure.

Cannot do Quality Render
Read 239 times
* August 19, 2018, 02:42:29 AM
I am running Turbocad 2016 Deluxe 64 bit version 23.2 on A Dell Inspiron 17 5000 series laptop under Window 10 Home.
The laptop has 16GB RAM, Intel UHD Graphics 620 and Radeon 530 Graphic interfaces and a 17.3 inch screen.

I have transferred Turbocad from my 8 year old desktop box where it ran reasonably well. As expected, it runs much faster on the new laptop. However, the Quality Rendering tool is disabled. When I first started Turbocad on the laptop I got a message stating that there were problems with REDsdk because the graphics card was either too new or too old. (Unfortunately I did not take a copy of the actual message.)

I assume that I need to update some drivers in Turbocad in order to make Quality rendering work. Any assistance would be gratefully accepted.

Regards,
Michael Milway.

Logged


* August 19, 2018, 03:43:42 AM
#1
What mode are you working in,   Options menu - Native draw (GDI or RedSDK)

Unless you purchased the lightworks plug-in for 2015 to 2017,  Quality render is not available in GDI mode,  you need to switch to RedSDK to get quality in RedSDK..  Just ignore any message and see if it render ok then.

## Edit ##. If native draw says you are in RedSDK.   Right click the render teacup, check if quality render type says RedSDK and a Render mode is selected.  Occasionally if an old file is opened, the Render type will be blank, preventing rendering until its been reset to RedSDK.  ## End Edit ##
« Last Edit: August 19, 2018, 04:01:53 AM by Andy H »

Logged


* August 20, 2018, 03:52:13 AM
#2
Thanks for the reply.
I have changed graphics mode to REDsdk. The Quality render tool is now enabled, but does not appear to do anything. The view --> visual styles menu does not have a tick against it after I select it, even though it appears active. I got the attached message when I changed modes. This indicates that I don't have the correct driver for my graphics adapter.

The device manager lists two graphics adapters: Intel UHD graphics 620 and Radeon 530. How do I find and install a suitable driver?

Regards,
Michael Milway

Logged


* August 20, 2018, 04:39:22 AM
#3
I just saw the comment about right clicking on the render tea cup and setting the render type to redsdk. Quality rendering now works.

However it appears that I do have to define the materials for each component.

Regards,
Michael Milway.

Logged


* August 20, 2018, 05:00:26 AM
#4
Glad it worked Michael.

With regards the driver, the message you see is normal.  somewhere in TC there will be a file with a list of tested drivers, anything not on that list will show up the error message,  things still (usually) work OK,  it just means RedSDK hasn't tested the drivers.  It is usually nothing to bother about really.  With most (if not all) windows 10 installations, Redway (RedSDK) recommend the operating systems drivers. so they don't even test new drivers.  If its working ok, and the message appears, tick the 'don't show again' box.

The main thing to check when one has two Graphic processors, is Options Menu - native draw (RedSDK) - 'Show Video System Info' button, and check TC is using the Radeon and not the intel one.  If it says Intel, there is a post on the forum on how to reset it in Windows.

 

Logged