TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Interested in some really terrific mobile apps? Visit www.turboapps.com for details.

TC 2018 questions warning messages?
Read 293 times
* August 12, 2018, 10:34:56 AM
Trying out 2018 Deluxe before upgrading.  Getting this message before rendering.  "Having any Foreground Wireframe options are on when OpenGL Hardware Acceleration is enabled may cause significantly lower performance.
Do you want to continue?"  What does that mean?

Logged
TuboCad Deluxe 2017. 
Newbie, but Getting There.


* August 12, 2018, 10:40:48 AM
#1
Also seems to hang up on draft render or Quality render.  Will go back to wireframe?

Logged
TuboCad Deluxe 2017. 
Newbie, but Getting There.


* August 12, 2018, 11:00:12 AM
#2
Also, button 3 on my mouse used to Rotate the object, or move it around the axis's.  Now it just zooms?  Is that something I will have to change in setup?  Sorry for so many questions at once.  But, trying to make sure I will be comfortable with 2018 before I purchase.  UI looks a lot different to me.

Logged
TuboCad Deluxe 2017. 
Newbie, but Getting There.


* August 12, 2018, 11:37:23 AM
#3
I don't know if you had the lightworks plug-in for 2017, but if not,  2018 uses GDI mode (options menu - native draw) and lightworks rendering, which is completely different to RedSDK.

As far as OpenGL,   when I work with DGI mode I make sure OpenGL hardware acceleration is turned off, (options menu - Desktop), because it does not play well with my old system.  you could try it both on and off to see whether it causes any problems with your system.  basically ( as far as I know),  if turned on it will have a look at your graphics card drivers and see if some rendering can be done on the card, but trying to render 2D stuff (foreground wireframe option) may not work properly.

As for the mouse button,  There is a section in tools menu - customise, Devises, additional device setup button. But on my mouse, if I single click my extra button it zooms extents, but if I click and hold it down, whilst moving the mouse it rotates the view, is this the type of thing you mean.  I did have to tell my mouse properties in windows, to operate the button as a wheel click.

Sorry.  Cannot comment on any hanging as I don't have 2018 Deluxe. (you could try turning off, OpenGL acceleration if it is turned on).  also right click the rendering teacup, and check if draft is set to Lightworks or OpenGL.
 

Logged


* August 12, 2018, 12:18:08 PM
#4
It also seems you have to physically choose to hide the grid when rendering in Quality, or the grid mucks up the drawing?  Then you have to turn it back on, if you want it in wireframe.  Or, is there a setting to make that default?

Logged
TuboCad Deluxe 2017. 
Newbie, but Getting There.


* August 12, 2018, 12:51:52 PM
#5
Also seems to leave a lot of junk layin aroung when rendering?  See the bottom right of the screen shot.  Redraw doesn't get rid of it, and you cant delete it? 

Logged
TuboCad Deluxe 2017. 
Newbie, but Getting There.


* August 12, 2018, 12:59:19 PM
#6
Same drawing moves flawlessly in TC2017, smooth when rotating in quality render.  In 2018, it is real ratchet and slow to render.  I finally figured out why it wouldn't rotate with my mouse button.  Had something to do with it being in "LTE" mode.  Which I put it in purposely, because it was a dynamic input similar to AC.  But, the dynamic input boxes didn't pop up when drawing anyway, so I put it back to default.  I wish they did, it would be a lot easier to draw dimensional objects.  Maybe someone can explain how to make it work.  Looked in the help, not much use.

Logged
TuboCad Deluxe 2017. 
Newbie, but Getting There.


* August 12, 2018, 01:02:00 PM
#7
I sure wish TC had online support that could remote in, and help with initial setup, and support.  That would be invaluable to people like me.  To help iron out the settings for optimal performance, and easier navigated UI.

Logged
TuboCad Deluxe 2017. 
Newbie, but Getting There.