TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Interested in some really terrific mobile apps? Visit www.turboapps.com for details.

RedSDK - Wireframe - GDI -- unvisible 2D-Objects
Read 778 times
* July 13, 2018, 06:19:29 AM
Hello everybody,

I try desperately (already several days) to adjust TC 2016 PP correctly. What has happened so far ...

I have a new computer (notebook) with a Nvidia GTX 1060 and 16GB Ram, SSD ..., Windows 10
On the computer I installed Turbocad 2016 PP.
The graphics card I have set so that it uses the preferences of the GTX 1060 preferred.
Otherwise, I have changed nothing in the settings of the graphics card.

If I now start TC and go to the options native drawing, I will see the GTX 1060 with driver version.

So far so good, now to my problems:

1. I am in RedSDK mode. I'm in wireframe mode.
Now I want to draw a 2D object and click on the corresponding command (line, rectangle, ...). Do I then draw the line,
I will not see the line That is, only when I have dropped the line, the line appears.
2. Furthermore, if I click the line in edit mode (EditTool), the blue dot will not be displayed.
3. Even with the FacetEditing tool, the points or facets are not displayed.

3. Now I switch to GDI mode.
Here it is that the previously drawn line is displayed immediately during the drawing.
The EditTool works as expected.

My questions would be -
How can I get RedSDK mode and Wireframe TC to correctly display the lines during the described action?
What settings must be made in / on the NVidia graphics card (settings)?
Which settings must still be made within TC.

As I said I have already searched the forum. I found the following links. These did not bring success.
Link: https://turbocaddoc.atlassian.net/wiki/spaces/TC2016UG/overview
Link: http://forums.turbocad.com/index.php/topic.21168.msg127146.html#msg127146
Link: http://forums.turbocad.com/index.php/topic.11543.msg70049.html#msg70049
Link: http://forums.turbocad.com/index.php/topic.21155.msg127208.html?PHPSESSID=6r4qq61jdn5jj4eetklifjuk86#msg127208

In the older contributions one finds again and again links to for example:
http: //www3.turbocadcommunity.com/tiki-index.php page = ....?
As soon as I want to call this, the message comes:
Not Found - The requested URL /tiki-index.php was not found on this server.
Additionally, a 404 Not Found error was encountered while trying to use on ErrorDocument to handle the request.

Can I still reach these sites via detours?

I thank you in advance for your contributions and suggestions, thank you.


Logged
-----------------------------------------------------------------------------------
Very low knowledge of English - I ask for indulgence - Thanks
Currently installed
TurboCAD  Professional 32-bit V.17.2.77.1
TurboCAD 2016 ProPlatinum 64-bit V23.2-61.2 engl.
TurboCAD 2015 2D V.22.2.51.4
on Win 10.


* July 13, 2018, 07:14:42 AM
#1
The wiki dont work anymore, is it closed or lost, who know as no one from managment say anything about it ;)

Typical a 2D Object with thickness set in the property will not show before you finish the Object, but guess this is not the reason as it will let you use the edit facet tool on a rectangle i.e. if there is a thickness preset to it

I just tested in v 2016 PP, New from scratch in metric system and have no problems with it in RedSDK native draw, or GDI

That lead to the card, some People have had issues if the driver is not updated and even if it's to New, deepend on the machine
Do you use latest Build of TC 23.2   61.2 ??

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* July 13, 2018, 08:10:17 AM
#2
Hi,

Quote - The wiki dont work anymore, is it closed...

Bad, there are many links from this forum there.

Quote - Typical a 2D Object with thickness set in the property will not show before you finish the Object,

That's exactly how it is, that makes no sense or useless.

Quote - but guess this is not the reason as it will let you use the edit facet tool on a rectangle i.e. if there is a thickness preset to it

I'm sorry I do not understand. What do I have to change or adjust?

Quote - I just tested in v 2016 PP, New from scratch in metric system and have no problems with it in RedSDK native draw, or GDI.

For me it is not in RedSDK, with GDI it works. It can only be the settings? But which?
Switching between modes is eliminated. The model is then dismembered in GDI mode / wireframe (faceted)

Quote - That lead to the card, some People have had issues if the driver is not updated and even if it's to New, deepend on the machine

Which is the right driver for the GTX 1060 and Turbocad?
My driver version for Geforce GTX 1060 is NVidia 398.11
GPU chipset: nvidia G400

Quote - Do you use latest Build of TC 23.2   61.2 ??

 Yes

Logged
-----------------------------------------------------------------------------------
Very low knowledge of English - I ask for indulgence - Thanks
Currently installed
TurboCAD  Professional 32-bit V.17.2.77.1
TurboCAD 2016 ProPlatinum 64-bit V23.2-61.2 engl.
TurboCAD 2015 2D V.22.2.51.4
on Win 10.


* July 13, 2018, 08:59:41 AM
#3
I an many else also miss the wiki as it was a great place for help about TC.

I dont find it so strange as it is in sort of convertion when we draw a 2D object with thickness and will be in 3D when it's closed/ finish, if use the Box tool we can se it when set  p1 and p2
So then it should be to open the property for 2D and take away the thickness and it should be visible when draw in 2D

You say if you use the Facet Editing tool it will not work, on a closed polyline with preset thickness it will, on a single line it will work on the "sides" of the lines.

I dont know "anything" about cards, that is more for the people that do so in here.
The reason i mention it is because not long time ago there was on guy that have problem with his latest update for his card on a HP machine, it turns out that his machine could not handle it, so when he roll back and used the latest version on the card from HP support, then everything was fine.

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


July 13, 2018, 09:59:51 AM
#4
It is only idea!

I mean you used too new driver for old version RedSDK. Maybe!
Try to use the oldest what you find for your graphics card!

I use now "Driver version: NVIDIA Forceware 385.69" but I have much older card.

Logged
WorkPC->HP Z620 2x E5-2680v2 2,8GHz, 64GB RAM,Quadro K4000, 400GB SSD+2TB HDD, Win10 Pro 64bit
HomePC->i7-3770 CPU 3,40GHz, 16GB RAM, GeForce GTX 760, 120+60GB SSD, Win7 HP 64bit

TC Pro Plat x64
www.invent-dizajn.sk, www.facebook.com/marian.jurcak


* July 14, 2018, 12:21:00 AM
#5
Hi,

first a thank you to Torfinn and Majo.

Is there someone who uses the Nvidia Geforce 1060 and TC 2016PP?
Which driver do you use?
Which settings do you use?

In the appendix I once tried to show my problem.

Logged
-----------------------------------------------------------------------------------
Very low knowledge of English - I ask for indulgence - Thanks
Currently installed
TurboCAD  Professional 32-bit V.17.2.77.1
TurboCAD 2016 ProPlatinum 64-bit V23.2-61.2 engl.
TurboCAD 2015 2D V.22.2.51.4
on Win 10.


July 14, 2018, 09:58:47 AM
#6
Hi,

try write to Kai Sannes -> profile - http://forums.turbocad.com/index.php?action=profile;u=722
and he posted info about his new laptop with the same graphic card *edit - (this link was removed) - thanks Torfinn for the alert  ;)

but I do not know if he works with TC 2016 PP on this laptop/notebook.

And you have this problem also with TC 2017 and 2018 versions?
« Last Edit: July 14, 2018, 04:00:27 PM by Majo »

Logged
WorkPC->HP Z620 2x E5-2680v2 2,8GHz, 64GB RAM,Quadro K4000, 400GB SSD+2TB HDD, Win10 Pro 64bit
HomePC->i7-3770 CPU 3,40GHz, 16GB RAM, GeForce GTX 760, 120+60GB SSD, Win7 HP 64bit

TC Pro Plat x64
www.invent-dizajn.sk, www.facebook.com/marian.jurcak


* July 14, 2018, 11:38:03 AM
#7
Kai is seldom here nowadays, he sort of drop out when he make video's :)

The tread Majo was linking to is on the Beta forum so doupt if you can see it, and the tread is about 13 months old, that means he only have had v 2017 and now v 2018 on it.

In 2016 Kai did'nt like RedSDK to much and basically was in GDI and used LW renders, it was in 2017 he sort of discover the benefits with RedSDK especial the Draft render ;) :)

I did call him to verify it just in case, and it was as i believed, only 2017 and 2018 on his pc.

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


July 14, 2018, 01:07:19 PM
#8
Is there someone who uses the Nvidia Geforce 1060 and TC 2016PP?

The GTX 1060 was introduced in August of 2016, while TurboCAD 2016 was released 6 months earlier.  Therefore, it is quite possible that they may not mate perfectly (I don't know).

So, it may be worth your while to experiment with earlier drivers, but I would be inclined to advise against it (the recommended driver is designed to work with the video card; earlier drivers not so much).


Jeff

Logged
TC Pro Platinum 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* July 14, 2018, 09:38:08 PM
#9
Hi,

I summarize:

very, very depressing and frustrating the whole. I bought the notebook assuming that the GTX 1060, Redsdk and Turbocad 2016PP would finally work together properly. Think, it does not work.

I have now reinstalled TC, because I had but some disfigured. (There were always internal errors).

I changed the settings as follows:
In the NVidia graphics card settings: TCW23.exe added
preferred graphics processor: integrated graphics

In turbocad under native draw:
Redsdk clicked
It will now be shown under "Show Video system info":
Intel HD Graphics 630 ... etc.

The success was:
2D objects are in wireframe mode as desired and !! while drawing !! displayed.
In Supress Hidden Lines I put on "Draw hidden lines dashed"
If necessary, tick "Nonrenderable Objects" (if desired)
In draft mode render type: RedSDK under RenderingMode: RedSDK Draft
In Quality mode: Rendering type: RedSDK under RenderingMode: Raytrace Preview

Under Advanced mode: I do not know, because under Renderstyle there are 8 possibilities? Which is recommended?

So now all I have to do is get TC to save all the settings. Every time I open a new drawing (New from Scratch)
I redo all settings.

I think I could have stayed with TC17 (not TC2017). Following the motto: "Never change a running system".
With the money, I could have made a great holiday.

Thanks again to everyone. Maybe you could still answer my questions about "Advanced Mode".

Until then and a nice weekend

Logged
-----------------------------------------------------------------------------------
Very low knowledge of English - I ask for indulgence - Thanks
Currently installed
TurboCAD  Professional 32-bit V.17.2.77.1
TurboCAD 2016 ProPlatinum 64-bit V23.2-61.2 engl.
TurboCAD 2015 2D V.22.2.51.4
on Win 10.


August 07, 2018, 02:12:17 PM
#10
So now all I have to do is get TC to save all the settings. Every time I open a new drawing (New from Scratch)
I redo all settings.

The next time you open TC, choose the Run As Administrator option (right-click on the TurboCAD icon to see the selection) , change all the settings, delete any objects (except, as you desire, a Title Block on a Paper space) and Save As Template.

When the File Requestor pops up and, assuming you accepted all the default locations when you installed TurboCAD (you can check at Options / File Locations / Templates), maneuver through the folder tree and specify a preferred name for your configuration.

From now on, open TurboCAD and select File / New / New from Template and select your pre-chosen name.


Jeff


Logged
TC Pro Platinum 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* August 09, 2018, 09:22:41 PM
#11
Hello Jeff,

thanks for your contribution.

My problem is that I work with several (many) templates.
For example one for customers, one for laser cutters (DXF, DWG), another for suppliers and so on.

I have already tried to pack everything in a single template, but that puffs up everything and is then confused again.

Maybe a guide for meaningful template management would not be bad?  8)

Logged
-----------------------------------------------------------------------------------
Very low knowledge of English - I ask for indulgence - Thanks
Currently installed
TurboCAD  Professional 32-bit V.17.2.77.1
TurboCAD 2016 ProPlatinum 64-bit V23.2-61.2 engl.
TurboCAD 2015 2D V.22.2.51.4
on Win 10.


August 10, 2018, 06:03:18 AM
#12
My problem is that I work with several (many) templates.

I have already tried to pack everything in a single template, but that puffs up everything and is then confused again.

Maybe a guide for meaningful template management would not be bad?  8)

There is already that.

When you select the New from Template option under the File / New command, you see a list of Templates to choose from.  You can create as many of your own templates as you want and store them where I described in my first post above.  I usually have a Portrait A-Size, a Landscape B-size and maybe a couple others.  There's nothing stopping you from doing the same.


Jeff


Logged
TC Pro Platinum 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* August 10, 2018, 07:57:47 AM
#13
Hello Jeff,

I know already, thanks.
I do not know how to describe it? I try again to explain what I intend.

The reason of my project: Do not take over old templates in a new Turbocad version. (Have I read it somewhere)

The old templates are available.
The new templates will be recreated.
I would like to change these templates at the same time.
For example: Workplanes and fixed point
In the old templates I had three workplanes (xy, xz, zy) and a fixpoint (0-0-0)
Another example:
In some templates I have text blocks
and so on ...

How do I get the different drawing frames (old version) in the paperspace in the new templates? Just copy and paste?

I'm just not sure how to handle this?
Especially since I have the feeling that Turbocad with the old templates (still) often crashes.

Logged
-----------------------------------------------------------------------------------
Very low knowledge of English - I ask for indulgence - Thanks
Currently installed
TurboCAD  Professional 32-bit V.17.2.77.1
TurboCAD 2016 ProPlatinum 64-bit V23.2-61.2 engl.
TurboCAD 2015 2D V.22.2.51.4
on Win 10.


* August 10, 2018, 08:17:28 AM
#14
Have you try'd to hide objects by Graphic for 1 object or Category for multiple ( inside Design Director palette ), then you can have many thing in the same template, on same layers but only visible when you want.

I have made my teplate based on a New from scratch in metric system, and you can just copyNpaste the frame if it's a sort of Advanced, i just use a single rectangle so by that i just Draw it the first time and later i copy the P space's because this "funny" thing they did in v 2015 to v 2017, Automatic set new layers ON in the viewports.
I do also just use viewports for title field's for the basic info and add some txt for the spesific P Space if needed.

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


August 10, 2018, 04:43:24 PM
#15
How do I get the different drawing frames (old version) in the paperspace in the new templates? Just copy and paste?

I'm just not sure how to handle this?
Especially since I have the feeling that Turbocad with the old templates (still) often crashes.

Using a file manager in Administrator mode, you can copy your older version templates to the current TC version's Templates folder.  I have done that for years. 

You might want to open each template (with TC in Administrator mode) and Save As, but I have never noticed a problem.  Any bugs you encountered should be left behind with the older TC version, not the templates (which don't have any code where bugs can live).


Jeff

Logged
TC Pro Platinum 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* August 10, 2018, 08:15:05 PM
#16
Hello Torfinn,

Thanks for the good advice. I had not even thought about graphics and / or category. I really have to test.

Later: Does not the template inflate infinitely?

Hello Jeff,

I will try copying the templates. Maybe first only one or two, to test.

Again a big thank you for your patience.

Logged
-----------------------------------------------------------------------------------
Very low knowledge of English - I ask for indulgence - Thanks
Currently installed
TurboCAD  Professional 32-bit V.17.2.77.1
TurboCAD 2016 ProPlatinum 64-bit V23.2-61.2 engl.
TurboCAD 2015 2D V.22.2.51.4
on Win 10.


* August 11, 2018, 05:34:20 AM
#17
Yes, the template will be bigger, deepending on what you put in to it.
New from scratch = 111 Kb, my template = 6,95 Mb :)

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17/ 18 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB