TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
All posts discussing pricing or where to buy TurboCAD will be deleted.

Problem With "Simple Extrude"
Read 90 times
* July 07, 2018, 02:41:17 PM
just upgraded to Turbocad 2018, Deluxe.  Going through the Intro/Tutorial where you are guided through making a 2d object kind of in the shape of a "D" with a circular hole in the middle.  All good.

Then, moving on to the 3d part of the tutorial, I'm instructed to move the 2d drawing into a Block.  Then, pull it out of the block onto a Workplane.  Finally, in sequence, Explode the object, Join Polylines and Simple Extrude.

All goes well till Simple Extrude.  Instead of a solid shape, as shown in the tutorial,  I get what I would describe as a vertical wall around the object.

Haven't been able to resolve this yet.  Anybody got any hints as to what I'm doing wrong?

Logged


* July 07, 2018, 03:59:48 PM
#1
The most likely cause, is that the profile is not fully close. Go into edit mode (right click anywhere in the drawing and choose the edit tool icon).  Click on the profile, which will show the blue nodes,  Right click and see if the option to 'close' is available at the bottom of the right click menu, (the 'close' is also an icon on the inspection bar if you do not want to use the right click menu)

If close is available, one could just select it,  But this can occasionally cause future problem so my preference is to find the culprit.  If the 'D' was a line or three, and a couple of arcs before using join polyline, then there shouldn't be a lot of node.   

In edit tool mode,   try moving each node and then note if it is fully attached, if you find one the is not attached at both side, it means the joint was not perfectly snapped in place before using join polyline.   There are a few ways of sorting this out, one way (if the node is one a line segment), is to press escape, the node will go back to where it was, but be highlighted a different colour to the rest, (this shows which node is selected).  Right click  and choose delete node,  this will open up a gap,  hover over any node, and then use the 'close' option.

If close was not available when you first tried it in edit mode.  please post the drawing,  workplanes can occasionally cause some problems, but if that was the case join polyline shouldn't have worked properly.


Logged


* July 07, 2018, 04:34:56 PM
#2
Bingo!  That did the trick.  Thank you.

Logged