TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Interested in some really terrific mobile apps? Visit www.turboapps.com for details.

ZOOMING IN TO SEE FINE DETAILS
Read 231 times
* July 04, 2018, 01:38:05 AM
I  used to be able to zoom right in to be able to work on fine details in my drawing but now when I try i just get an error beep on my computer and it wont Zoom any further can anyone tell me why this is and how to fix it? ive tried changing the scale and changing my screen resolution with no success

Logged
turbocad pro 11
windows 10
intel dual core 3.3 ghz


* July 04, 2018, 01:52:30 AM
#1
Can't be sure without seeing the file, but it sounds like 'space dust'

See This post and follow the link to John's post.  See if this helps in your case.

Logged


* July 04, 2018, 07:51:37 PM
#2
ok I couldnt follow the procedure exactly as I only have one hand so i moved the objects i wanted to keep onto a new layer  which i locked the selected all and deleted the rest but no change to the zoom problem

Logged
turbocad pro 11
windows 10
intel dual core 3.3 ghz


* July 04, 2018, 10:48:59 PM
#3
I assume you are able to zoom correctly if you start a new drawing.

If so.  Can you attach the original file, if you are allowed to.
« Last Edit: July 04, 2018, 10:50:36 PM by Andy H »

Logged


* July 04, 2018, 10:56:10 PM
#4
Is the drawing near to 0,0,0

Logged
Nikki
TC20 platinum
TC 2015 platinum
TC 2017 with lightworks


* July 05, 2018, 12:39:29 AM
#5
worked out how to attach the file hope this works!no Laughing at my Drawing okay

Logged
turbocad pro 11
windows 10
intel dual core 3.3 ghz


July 05, 2018, 03:45:23 AM
#6
The objects you have defined span a great deal of area:

X 1.1543888784449E+09 mm aka 1,154,388,878.4449E+09 mm
Y 521,311,643.028 mm
Z              836.6948 mm

TurboCAD can only zoom in so far, relative to the total size.  Fortunately, each of the objects is very tiny compared to this total area, so you can re-position them closer to each other.

Selecting them individually will be difficult, so I would suggest a phased invisibility by moving the objects you can find to a new Layer that is set to be invisible, then creating a new invisible Layer that will include the next grouping.  You can start with the ones you can see when you open the file you uploaded, then move from there.


Jeff


*******
EDIT ON 1
*******

As it turns out, selecting individual objects or sweep-selecting multiple objects is quite difficult.  This will take a bit more effort.

********
EDIT OFF 1
********


*******
EDIT ON 2
*******

Looking at Selection Info was revealing.  I ended up doing a Select All, Explode, then selected the Group and did another Explode.  After that, I was able to select individual objects.

********
EDIT OFF 2
********
« Last Edit: July 05, 2018, 03:57:30 AM by Jeffin90620 »

Logged
TC Pro Platinum 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* July 05, 2018, 08:49:36 AM
#7
worked out how to attach the file hope this works!no Laughing at my Drawing okay

Just tested in version 11.

The biggest problem you have is that you have some viewports associated with the objects,  so moving things about will mess up your views.  Anyway, this is what I tried. (note,   experiment on a copy of the file)

1. Open drawing
2. Create a new layer, and turn on all layers. #Edited# Unlock the layers, you can lock them again at the end if required.
3. In design director, click on layer 0 so its highlighted, and at the top of design director click the 'Select by' button
4. Do NOT click in the drawing, go to selection palette, and scroll down the selection to find object named 'viewport'.
5. Click on the word viewport in the selection palette so that it is highlighted. At the top of the selection palette click the button 'Select' (it may look like not much has happened except other things in the selection palette will be greyed out.)
6. Move it to the new layer.
7. in Design Director, Turn off the new layer, (or preferably right click it and delete the layer, as you shouldn't really have a viewport in model space, in my opinion.)
8. Zoom extents, and tidy drawing as necessary, i.e. things which are not associated with a viewport could be moved closed together)

The above leaves any associated viewports, except the weird one which was in model space for some reason.  However everything is still miles away from there it should really be.

If you don't mind remaking the views to a new position.  Then.

9. After doing the above, select all, and in position x and position y boxes type 0. (or whatever you wish)
10.  Tidy up the drawing as required including altering viewports. (you could move the Chain Box and stuff there closed to everything else)

## Edit ##  Forgot to mention unlock the layers at step 2, re-lock again once the steps are completed.  ## End Edit ##
« Last Edit: July 05, 2018, 09:06:09 AM by Andy H »

Logged