TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When posting a problem be sure to include which version you are using.  Give as much information as possible.  If the problem is with a specific file be sure to attache it to your post.

Why??? Help please........ as usual :)
Read 479 times
June 21, 2018, 12:22:31 PM
Hello,
Ok, so I open a drawing I made earlier and print it as a PDF and it comes out great (See capture 1) Using Quality Illumination Fine Render but I then notice I need to change something on there. I go back into the drawing and I turn back on the lights and the program crashes and kicks me out.
So I open back up the drawing but it then looks like sh*t (See Capture 2).
I didn't change anything in the file or save it before it kicked me out so why it is so different now?
I have tried the "Replace selection with same names from TC database, nothing changed.....

I had to try to change the material (Brass+redsdk) and lighting manually to make it look like the first image but I am struggling.(see Capture3).... grrrrrrrr so annoying.
It seems like the "Global Illumination" side of the render has failed or sumin??

Can anyone throw some light on as to why this happens? (Its not the first time :( )

James B


Logged
"Was" Using Plat Pro 2018
Windows 10 - 64-bit
Nvidia K620


June 21, 2018, 12:30:35 PM
#1
Ok so the last image (capture 3) was using Quality Global Illumination with one "Point" light on. But I turn that light off and refresh and low and behold its back to looking right????[email protected]??!?!?!?! WTAF!!!
Grrrrrrrr where is the consistency in this program????

James

Logged
"Was" Using Plat Pro 2018
Windows 10 - 64-bit
Nvidia K620


June 21, 2018, 12:52:43 PM
#2
Ok so after playing around a bit I have come to realize that there is something wrong with the "Quality Global Illumination Render" mode
I opened another drawing and rendered it using Quality "Raytrace Fine" and again with the "Quality Global Illumination" Render and took screen shots of them both, see attached ??!??!?!?!?!?   I don't see any difference between them, but I should.
Right?

James B

Logged
"Was" Using Plat Pro 2018
Windows 10 - 64-bit
Nvidia K620


June 22, 2018, 03:42:40 AM
#3
James

You wont see much difference if you are using lights that are bright and close to the geometry. Also have you got any materials applied?

The Global Illumination renders you do not actually need any lights to get a reasonably defined render as it uses the White Drawing Background as a light source so try turning all your lights off.

Logged
Daz...
V2017 64-Bit & 32 Bit Platinum Edition
RedSDK Only in 64 bit & 32 bit = RedSDK & Lightworks
TurboCAD user since V3 and Turbocad 3D V1.
OS Windows7 Pro 64bit Lenovo W701 Laptop, 24GB Ram, 2 x 128 SSD harddrives, NVIDIA Quadro FX 2800M Graphics, Intel i7 CPU...


June 25, 2018, 05:19:31 PM
#4
Hi Daz,
Sorry yes I have all the lights turned off I was using Brass Redsdk but I have also tried this with any other material and I still am getting the same results??

Attached is a picture of another product firstly rendered as "Quality - Raytrace Fine" and the second one is rendered as "Quality - Global Illumination fine" and as you will see I have no lights on in either image.

I don't think its working correctly because i don't see a difference between these two images.
Has anyone else had an issue with Global Illumination Fine not working???

James

Logged
"Was" Using Plat Pro 2018
Windows 10 - 64-bit
Nvidia K620


* June 25, 2018, 06:06:32 PM
#5
James,
Can you post a screen grab of your "render scene environment" and "render scene luminance"  properties window.

Go to "options" > "drawing setup"
see attachment

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2018-2017, TurboCad Platinum 21.Using Lightworks and Redsdk, Anilab lab 5. ATI Mobility Radeon HD 4500/5100


June 26, 2018, 08:24:07 AM
#6
James,
Can you post a screen grab of your "render scene environment" and "render scene luminance"  properties window.

Go to "options" > "drawing setup"
see attachment

Yes see attached :)
I was hoping this would have fixed itself overnight but sadly no :(
Again this image is rendered in Quality Global Illumination Fine and looks baaaaaad!

Thank you for helping

James


Logged
"Was" Using Plat Pro 2018
Windows 10 - 64-bit
Nvidia K620


June 26, 2018, 10:20:11 AM
#7
Hi Daz,
Sorry yes I have all the lights turned off I was using Brass Redsdk but I have also tried this with any other material and I still am getting the same results??

Attached is a picture of another product firstly rendered as "Quality - Raytrace Fine" and the second one is rendered as "Quality - Global Illumination fine" and as you will see I have no lights on in either image.

I don't think its working correctly because i don't see a difference between these two images.
Has anyone else had an issue with Global Illumination Fine not working???

James

Are you rendering in paperspace?....
I would not recommend this method at all for either Lightworks or RedSDK quality or AR modes as it's just to processor hungry.

I always render in Model Space and save out as a PNG image. I scale down the TC GUI to the same proportions that the higher resolution render will be when I save it after the Model Space Preview.

The most I would do in Paper Space is dimensioned drawings and hidden line print outs.

Could you attach your drawing for us to look at please...
« Last Edit: June 26, 2018, 10:24:01 AM by Darrel Durose »

Logged
Daz...
V2017 64-Bit & 32 Bit Platinum Edition
RedSDK Only in 64 bit & 32 bit = RedSDK & Lightworks
TurboCAD user since V3 and Turbocad 3D V1.
OS Windows7 Pro 64bit Lenovo W701 Laptop, 24GB Ram, 2 x 128 SSD harddrives, NVIDIA Quadro FX 2800M Graphics, Intel i7 CPU...


* June 26, 2018, 12:06:39 PM
#8
James,
Can you post a screen grab of your "render scene environment" and "render scene luminance"  properties window.

Go to "options" > "drawing setup"
see attachment

Yes see attached :)
I was hoping this would have fixed itself overnight but sadly no :(
Again this image is rendered in Quality Global Illumination Fine and looks baaaaaad!

Thank you for helping

James

Maybe you assigned a luminance to the object.
Check all the objects properties.
Select an object go to properties and click on luminance.
As Daz says, would help if you post the file  ;D

Logged
"What do I know, I'm still learning"..
Windows 7 64 bit HP > on a stock HP laptop with 4gb-2.4 GHz.Turbocad 2018-2017, TurboCad Platinum 21.Using Lightworks and Redsdk, Anilab lab 5. ATI Mobility Radeon HD 4500/5100


June 27, 2018, 09:04:26 AM
#9
I'm not sure I have explained what is happening correctly.
When I render an image in Paper space the Render uses the "Raytrace Fine" Render even when I choose "Global Illumination Fine"
The lights are all off and there is no illuminance turned on at all.

Darrell, thank you for the tip about not using Paper space, I have been doing it that way since I started, hahaha the training video told me to so I did hahahah, anyway I have been doing it the way you said and using "save as PNG" as well and I have not had any issues with the render not being correct so thank you very much for that :)  and its saving me so much time not waiting on the Paper space rendering :)  :) :D ;D

So I was playing around a little and I found my problem!!!!
I noticed that if I have "Raytrace Fine" selected as the "Quality" render within the Model space and the go to the Paper Space I chose "Global Illumination Fine" it only gives me the "Raytrace Fine" however if i go back into model space and change that to be the "Global
 Illumination Fine" and go back to paper space a refresh the screen it gives me the correct chosen "Global Illumination Fine" that I have selected. Stupid!! If you choose a desired render that is what you should get whatever is chosen on another space.

James

Logged
"Was" Using Plat Pro 2018
Windows 10 - 64-bit
Nvidia K620


* June 27, 2018, 11:04:43 AM
#10
I don't see any difference between them, but I should.
Right?
No.
If there are selected objects, then Draft (RedSDK) mode is automatically set.

Vlad

Logged


* June 28, 2018, 06:21:57 AM
#11
James,

Looks like the problem with Emissive Background initialization in paper space viewport (if no environment or environment is 'plane').
To work around the problem, you can use combination Luminance + Environment.

Please see attached example.

Vlad

Logged