TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Be sure your post is relevant to the current discussion.  Create a new topic within the appropriate board if you are unsure.

New Dell Workstation 7820 Tower ( draft renders are slow - what ?? )
Read 476 times
* June 07, 2018, 01:42:23 PM
I am hoping that perhaps someone would be willing to help me with this situation.  My workplace was able to get for me a Dell Workstation Precision 7820 Tower with a Quadro P4000.  Now, the file(s) that I often view and are used to seeing or rendering are really about the same and I can not see any difference in performance.

As a matter of fact, my personal PC at home has a Nvidia 960 that performs better.  This is hard for me to understand why.  For one thing, I am not a Graphics Card expert and all the settings in the Nvidia Control panel mean a little to me, but not much.  Then I got my IT guy at my office to look into the HP Workstation and he too is baffled.

It seems as if the Quadro is not really active even though this sounds strange, it is hard to explain. The only way I can explain is that it does not matter what setting or performance value I set the Nvidia Control panel settings, it does not make any difference.  its like "part" of the Quadro is working and not all of it. 

My IT guy is a gamer and he can't seem to understand either.  Just for mentioning it, I have my settings usually set up like Don Cheke as I have followed many of his tutorials. And like I said, my personal PC at home does better than this new box. ????  The Quality Renders are also quite painful to experience as well. 

As a real example, I drew Don Cheke's Radial Engine Tutorial.  Don claims about 3 min 20 seconds or so for a full render.  On my home PC, I get about 3 min and 45 seconds w my Geforce 960 (Draft Render).

This new HP workstation from Wireframe to Quality render is 6 min and 35 seconds. 
From Wireframe to Draft is 4 min and 20 seconds.

So, here are the specs on my new PC:

TC Pro Platinum 2017
Light Works 2017

CPU: Intel Xeon Bronze 3104 CPU @ 1.70Ghz
RAM: 16G
Quadro P4000
OS Win 10 @ 64 bit

Hardware vendor: NVIDIA Corporation
Renderer: Quadro P4000/PCIe/SSE2
GPU chipset: nVidia G400
Driver version: NVIDIA Forceware 391.74
OpenGL version: 4.6.0 NVIDIA 391.74
« Last Edit: June 08, 2018, 09:24:51 AM by DDriskell »

Logged


June 07, 2018, 02:35:11 PM
#1
Hi Don,

Unzip the attached render test to your desk top at home and at work. Double click the 800x600.bat and run to compare. Not sure what this will show other than one is faster than the other. THis was made by one of the TC programmers a few years ago.


* June 07, 2018, 04:33:57 PM
#2
Thanks Don.  I ran this at home and will do so at my office tomorrow.

Logged


* June 07, 2018, 04:51:56 PM
#3
What processor is on your home PC.  As far as I know, most rendering and indeed wireframe is done by the CPU processor, whether Lightworks or RedSDK,  there is a switch under options menu - Desktop - Multithreading Lightworks, but whether it makes any difference I've no idea.

You may need to compare processors on the two computers, although the works processor is 6 core, its 1.7 Ghz with no hyperthreading and no turbo-boost.  Using the same drawing, you could fire up task manager and see what's going on with the processors on each computer.  I've never owned a Xeon, so only guessing that is more likely to be the difference in cpu causing slower rendering.
« Last Edit: June 07, 2018, 05:04:28 PM by Andy H »

Logged


June 08, 2018, 01:52:04 AM
#4
3 minutes, 11 seconds on my system (hardware and software details below), but this utility only uses one core (my system has 6, multi-threaded to 12).  Therefore, it is no longer a good indicator of your system's capabilities with TurboCAD's multi-core rendering.

*******
EDIT ON
*******

Well, this is a puzzle.  I have a screen capture from Feb. 2017 where the rendering time popup is only 1 min, 42 sec.  I have the same hardware (but the OS has been 'updated' several times), so what has happened?

*******
EDIT OFF
*******


Jeff
« Last Edit: June 08, 2018, 02:00:28 AM by Jeffin90620 »

Logged
TC Pro Platinum 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* June 08, 2018, 07:55:14 AM
#5
First - thank you all (seriously) for helping and offering advice - interesting thoughts on all accounts.
Unfortunately, I am writing this post at my office and I can not remember the specs on my PC at home. I think it is a 4700 series i7 CPU with 16G of RAM and the GTX 960. I think the driver is in the 353.xx range that I got from Redsdk back a while back.

this is what I have found out.  For what ever reason, the Quadro P4000 driver is not picking up on things (not working). 
At a final go at it this morning. I decided to uninstall the driver.  I ran the 800x600. BAT file. 
There is NO difference in having the driver installed to not having it.

My PC at home has a GTX 960  Benchmark .BAT file runs at 1 min 18 seconds
My New Workstation with the Quadro P4000  is a staggering 3 min 9 Sec (same result w or wo drivers.

So, it should seem the obvious question why the P4000 is not seeing the driver ?

Thanks again to all helps - it is greatly appreciated.  I guess I could write an email to Nvidia. 

EDIT:
Now, what is even more strange that w NO driver installed, why is my TurboCAD telling me that I have this: (I thought I removed all the drivers ?)
Hardware vendor: NVIDIA Corporation
Renderer: Quadro P4000/PCIe/SSE2
GPU chipset: nVidia G400
Driver version: NVIDIA Forceware 388.16
OpenGL version: 4.6.0 NVIDIA 388.16

Donnie
« Last Edit: June 08, 2018, 08:02:33 AM by DDriskell »

Logged


* June 08, 2018, 09:26:14 AM
#6
So, I installed the latest Quadro driver and this time I checked "Custom" install and there is a checkbox that says to remove all previous and make a clean install.

Still No-Go.

Logged


June 08, 2018, 06:40:26 PM
#7
The Render Test program does not use the GPU, so it doesn't really matter which driver you have installed.  This is displayed in the attached image.

It only uses one core, so multi-core i6 or i7 (which adds hyper-threading) has no advantage.

The Quadro card, as good as it is, is not used by RedSDK unless you change the default for the Material (and, from my experiments, the lighting really needs to be changed afterwards).


Jeff

Logged
TC Pro Platinum 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* June 12, 2018, 12:50:33 PM
#8
I am still puzzled by this. I downloaded a Benchmark tool and I get about max 150 Frames Per Second.  It still seems as if there is a conflict between TC and the Quadro card.  I would like to reinstate that what caught my eye in the beginning was that "Hidden Line" was very slow and screen was constantly "refreshing" to keep up with (even with a somewhat simple file) my PC at home still beats this pro workstation by miles.
I have checked ALL configs in the TC setup and even made sure my settings at home and settings at office are identical.  My GTX 960 is like 5 times faster than this Dell Workstation that has a Xenon and Quadro p4000.

I am at a loss here.  I have a huge chunk of PC is that is basically a paper weight when it comes to TC.  (Sigh). 

Logged


* June 21, 2018, 07:41:45 AM
#9
Making the story short.  The Dell workstation is being returned.  I could never get the machine to perform of what it was allegedly spec'ed to be.

WIN 10 was reinstalled which did make the fps increase, but rendering horrible which dictates that it must be a CPU problem. 

I am thinking that TCW must share resources between the GPU and CPU

Logged