TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
Remember to do a search before you ask a question!!!

Disappering Cursor
Read 401 times
May 26, 2018, 08:10:30 AM
Good Morning All,

I got a new Laptop from HP... the HP ProBook 470 G5, The Specs are 32GB Ram, i7-8500, 2GB Discrete Nvidia Graphics - 1LR92AV GPU. NVidia GeForce 930MX (2GB DDR3) 106.            

 In TurboCad PP 2017 and some previous versions say my Video System Information is:
 Renderer:GeForce 930MX/PCIe/SS2
 GPU chipset: nVidia G400
 Driver version: NVIDIA Forceware 397.93
 OpenGL version 4.6.0 NVIDIA 397.93

Currently running TC2017PP and the problem is with RedSDK under options/preferences I get no Drawing cusor options...
What i mean is that I can only choose the arrow cursor, all other options will not work, whether I select them or not. Also when I select to show Crosshairs or show isometric the cursor disappears when I move it into the drawing. When I move the cursor out to the edges to select something I see the arrow again. But it disappears again when I move it into the drawing.
    I can go back to GDI and everything goes back to normal, I see isometric cursor when in the drawing. But I do not have the Lightworks plug in, so I can't do any rendering except in draft mode.
I have un-installed, re-installed, and also tried repair.... Nothing seems to correct it.
   Is there anything I can do to fix this?
   
   Thank you for any replies........
                                     wilbur9

Logged
Windows 10 Pro 64
Intel® Core™ i7-8550U (1.8 GHz, up to 4 GHz, 8 MB cache, 4 cores) + NVIDIA® GeForce® MX150 (4 GB GDDR5 dedicated)
32 GB DDR4-2400 SDRAM (2 x 16 GB)
17.3" diagonal 4K IPS WLED-backlit (3840 x 2160)
Windows 10 Home Premium 64 bit, 32 GB
TC 2016, 2017, 2018 All Pro Platinum


May 26, 2018, 03:12:41 PM
#1
For TurboCAD 2018, LightWorks returns as the default rendering engine and RedSDK is an optional plug-in (although, as yet, unreleased).

You might explore the free-to-try download to see if that resolves your problem.


Jeff

Logged
TC Pro Platinum 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* May 26, 2018, 03:49:45 PM
#2
Have you try'd to re-load you cfg, Customize/ Options/ Load from ??
Will it work if you use Default cfg ?? and then after that load your normal cfg ??

If that not work, delete or rename your Built-in folder when TC is of, TC will rebuild it when it start again, but like a New install, so if you have some special cfg you will need to re-load it,
If you have a lot of material and render setting's you may lose this, hence the rename of Built-in instead of deleting it

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


May 27, 2018, 05:42:54 AM
#3
No, I have tried all those things... Nothing seems to work. I guess TurboCad will not work on this system without Lightworks.
    I'm not sure I will continue with this program, which is sad as I have every purchased TurboCad since about Version 7.
I really appreciate the replies, Thank you....

                         Wilbur9

Logged
Windows 10 Pro 64
Intel® Core™ i7-8550U (1.8 GHz, up to 4 GHz, 8 MB cache, 4 cores) + NVIDIA® GeForce® MX150 (4 GB GDDR5 dedicated)
32 GB DDR4-2400 SDRAM (2 x 16 GB)
17.3" diagonal 4K IPS WLED-backlit (3840 x 2160)
Windows 10 Home Premium 64 bit, 32 GB
TC 2016, 2017, 2018 All Pro Platinum


May 28, 2018, 04:29:45 AM
#4
Well, I downloaded the trial version of TC2018 to see if Lightworks would fix my problem with the cursor...
    The problems are worse! TC2018 installed nicely, on opening everything seemed better! Everything worked as it should, until I did a render, didn't matter which I chose. After the render I lost the cursor unless I went back to options and unselected show isometric, which gave me the arrow cursor with no snap aperture. I also could not change the views or go back to wireframe. I have to close the program, which would re-start normally... Again everything would be fine, I would have the isometric cursor with aperture. Until I tried draft or quality rendering.  :'(
Pulling out my hair, no setting change seems to affect this problem. TC2017 or TC2018 show that my graphics chip is compatible, but it is not working!!!

                       OH WELL.....
                  
                                  Wilbur9


Logged
Windows 10 Pro 64
Intel® Core™ i7-8550U (1.8 GHz, up to 4 GHz, 8 MB cache, 4 cores) + NVIDIA® GeForce® MX150 (4 GB GDDR5 dedicated)
32 GB DDR4-2400 SDRAM (2 x 16 GB)
17.3" diagonal 4K IPS WLED-backlit (3840 x 2160)
Windows 10 Home Premium 64 bit, 32 GB
TC 2016, 2017, 2018 All Pro Platinum


* May 28, 2018, 05:35:29 AM
#5
I don't use the isometric nor aperture, but just gave it a go in 2017 and 2018. I get the opposite to you Wilbur9.  I get the isometric and aperture +  an image of the curser left behind whenever I click the left mouse. I'm using an old GTX 660, so the difference may be in the graphics driver.

Fortunately for me I just use the default cursor and no aperture.  All I can suggest is sending an E-mail to support stating its faulty in 2017 and 2018, and see what they say.  I doubt they will do anything about 2017, but they may look into it in 2018 as its only a few weeks old.

Logged


May 28, 2018, 12:18:31 PM
#6
Here's another way to possibly fix the problem.

Open a drawing, then open the Native Draw popup under the Options drop-down menu and select GDI to see how the cursor reacts.

If it displays properly, then try changing back to the previous drawing mode to see if it is still fixed.


Jeff

Logged
TC Pro Platinum 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1


* June 04, 2018, 05:14:36 AM
#7
Hi wilbur9

I can select all other options for cursor shape i am using TC Pro Platinum.Selecting "show crosshairs" overrides the normal cursor, displaying a screenwide horizontal and vertical line intersecting at the cursor position and selecting "Show Isometric" overrides the normal cursor displaying all three axes.I've checked these options for both GDI and Redsdk and got same results.

Logged


* June 04, 2018, 05:33:23 AM
#8
Hello Huma IMSI,

nice if it's work. Please let us know your sys-info.

Logged
-----------------------------------------------------------------------------------
Very low knowledge of English - I ask for indulgence - Thanks
TurboCAD 2016 ProPlatinum 64-bit V23.2-61.2 engl.


* June 04, 2018, 09:48:50 AM
#9
Look Up !

Configuration: TC 2017 + RedSDK, Graphic nVidia 9xxM, Driver 397.93
-----
The last functional driver for this configuration is 378.66. For higher versions, the cursor will disappear.
-----

The April update Windows uses as the minimum driver 397.64. The lower version of driver the Windows updates immediately on 397.64.
Solution: Disable the use of nVidia for TurboCAD and use only intergrated graphics in the processor


Logged