TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
All posts discussing pricing or where to buy TurboCAD will be deleted.

alternate units
Read 336 times
* May 23, 2018, 07:19:01 AM
In turbo cad V15 you could use both english and metric units when measuring a distance.
We tried to do it so in Turbocad 2017 , but the optin is no longer available.
In Mexico  we are used to work with both systems , but it is kind of annoying not to be able to do it so any longer.
Does anybody how to do it?
Reverse to both options?

Logged


* May 23, 2018, 07:57:48 AM
#1
Welcome.   Could you please clarify what you mean by measurement,  i.e. is this the measurement info panel, or using the dimension tools.  Also which Type of TC, Pro / Deluxe / Designer.

I just checked the measurement info panel in v15 and 2017 and all appears OK on my computer. with the measurement panel open (may be under tools - inquiry depending on configuration), selecting the units required from the inspection bar or right click menu changes the displayed measurement units, I didn't find a way to have imperial and metric at the same time.

Dimension alternate units appears the same in v15 and 2017   **edited** In Pro **end edit**   for me. set primary units and set the alternate units in the properties alternate units tab.

Of course I could have misunderstood the problem.
« Last Edit: May 23, 2018, 01:11:03 PM by Andy H »

Logged


* May 23, 2018, 12:42:32 PM
#2
The ability to use both English and Metric dimensions is only available in the Professional editions. It sounds like you have one of the other editions; Expert, Deluxe or Designer.

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit


* May 23, 2018, 03:50:24 PM
#3
I used TC15 Deluxe 64 bit and upgraded to TC2017 Deluxe 64 bit and the feature is gone.
It can read the 2015 version , but not write new ones.

Logged


* May 23, 2018, 05:05:15 PM
#4
Workaround - for alternate units in 2017 deluxe.   Create a new dimension style.

View menu or maybe Tools menu - palettes - style manager (depends on ones workspace configuration).  in the style manager expand dimension,  click standard (you can alter standard but personally I'd leave it as default), click the top icon -  create new style, and set it up as required with alternate units of choice, ensure rounding, precision and Multiplier are set correctly, or you can get some odd figures.  The new style will be available at the bottom of the dimension properties page.  If you right click the dimension icon and set the style before adding the dimension, the new style will be the default for further dimensions in that drawing.        NOTE you will not be able to alter them in the properties dialog but one can alter things in the style manager.  The style manager affects everything using that style, hence why I suggest keeping standard, for dimensions which you don't wish to have appended units.

These styles are drawing specific, so unless you create a template with everything set up, you would need to create a new style whenever you start a new drawing.   I don't have 2015 deluxe so I've no idea what was in there.

The above was tested in 2017 deluxe, and hopefully it will work for others.

Logged


* May 23, 2018, 09:04:24 PM
#5
Very good workaround Andy. I added the "\P" to the Units "Dim Suffix" to separate the inches from the millimeters.

I think Version 15 (not 2015) was the last time that Deluxe had alternate dimensions.
« Last Edit: May 23, 2018, 09:08:51 PM by John R »

Logged
John R.

V17—V21, 2015—2018
Designer, Deluxe, Expert, Basic, Platinum
RedSDK enabled, except in 2018
Windows 10, 64-bit