TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When replying to a specific statement be sure to quote the previous post.

Rendering (Draft, Quality & Advanced) causes lockup.
Read 205 times
* May 22, 2018, 04:24:11 AM
Whenever I select Draft, Quality & Advanced render the drawing becomes locked in that state, and won't revert to wireframe or suppress hidden lines. Sometimes the drawing becomes completely unresponsive, sometimes standard views still respond but nothing else. The only fix I can find is to close/ reopen the file.
TurboCad 20.2 Pro 64 bit. Windows 10.
I'd be very grateful for any advice on this. I'm not an advanced user and generally poor with the technology so please feel free to address me as you would a 6-year old.

Logged


* May 22, 2018, 05:21:28 AM
#1
Can't reproduce this issue attached is the video that shows applying "Draft,Quality or Advanced Rendering" didn't affect the TC response and you can easily revert them to "Wireframe or hidden" after applying any of the above render modes.

Logged


* May 22, 2018, 05:54:33 AM
#2
Maybe you can attach an exsample drawing where you have the problem, then someone will most likely figure out what's going on at your end.
And it can also be a good ide'a to put in some basic info about your machine, in your signature, as you will see the most people here have.

Have you try'd to do a Repair or Rename/ deleted the Built-in folder ??

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* May 22, 2018, 07:16:02 PM
#3
Thanks for the video Huma. I used to be able to do all that. This problem is recent. I can refine the symptoms slightly: whichever rendering style I select I only get Draft Rendering, not Quality or Advanced. All tools become unresponsive, but scrolling etc and standard views respond. When I select Wireframe or Suppress Hidden Lines, nothing happens and nothing responds, not even scrolling or standard views. I have to close and reopen to get back to Wireframe. Not just 1 drawing - it seems to be all of them.

Thanks for your reply Torfinn. Here's an example drawing, and all the info I can find is below.
"Repair or Rename/ delete the Built-in folder" - I've seen this mentioned in other threads but I've no idea how to do it. Could you talk me through? And will it cause any loss or damage to files?

Many thanks.

Alan Andrews

TurboCad 20.2 Pro (not platinum)
RedSDK enabled? (not sure. How do I check?)
Windows 10 Home Premium 64 bit
NVIDIA GeForce GT740M 2GB

Logged


* May 22, 2018, 11:50:35 PM
#4
Hi Alan

I've checked your file and still i was unable to reproduce the problem you are facing,simply go to "Options"-->"Native Draw" to check either your "Redsdk" is enabled or not.May be issue is occurring because you are working in "GDI" mode.

Logged


* May 23, 2018, 12:10:25 AM
#5
I tested your file and have no problem in LigthWork or RedSDK renders or anything at all, so the problem is at your end someplace i believe, but i dont have Pro, so used Pro Platinum.

When TC is closed, go to the folder where you save the drawing and see if there is .dwl files in there, if there is, delete them as they can make a lot of "fun", they are protectionfiles, but can be left over if you crash TC.
They will be named like "somename.tcw.dwl"

Repair; Run the installfile for TC again, and at some point you will get the choice of Un install/ Change or Repair, select Repair.
If that not help, then it's time for the Built-in.

The normal place for it is ;
C:\Users\Your username\AppData\Roaming\IMSIDesign\TurboCAD\20\Professional\Data\Profiles\Built-In
You can just rename the folder or delete it

Appdata is normally a Hidden folder, but by typing      %appdata%   in the Windows/ Run field it will bring you directly to he Roaming, and then you click from there.

When you do this you take away all your special setting's and TC will open like by Default and you will need to reload your cfg if you have made one ( if so, remember to save it first ) and set up your Templates, run the wisiard if needed and so on

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB


* May 23, 2018, 03:09:02 AM
#6
Thank you for these replies Huma and Torfinn, and thanks also for testing the file. Clearly something is wrong at my end.
Yes, I was in GDI, not RedSDK. That has improved things but not fixed. Now I can switch between wireframe and draft rendering without problem but no Quality or Advanced. Suppress Hidden Lines causes freeze but will allow switching back to wireframe.
It will take me a while to work through the processes you suggest, Torfinn. I'm very inexperienced in this. I'll report when done. No .dwl files though.
Many thanks again.
Alan Andrews

Logged


* May 23, 2018, 04:09:19 AM
#7
Alan

You can find .dwl file when drawing is opened in TC,just minimize TC window and open the folder where original file is located you can find .dwl file very next to it,further try other suggestions made by Torfinn hope this will fix your problem  :)

Logged


* May 23, 2018, 04:43:35 AM
#8
It dont help if he find a dwl when TC is open, they should be there then and it's not possible to delete, if they are there when TC is closed then delete them

Torfinn

Logged
V18, V19, V20, V21, 2015/ 16/ 17 Pro. Platinum
Deluxe V20, V21, 2015/ 16/ 17
RedSDK enabled
Windows 10 Home Premium 64 bit, 32 GB
NVIDIA Geforce GTX 780m, 1 GB