TurboCAD Forums

The Ultimate Resource for TurboCAD Knowledge

Register
 
When replying to a specific statement be sure to quote the previous post.

TurboCad 2018 Installation Problems
Read 264 times
* August 27, 2018, 07:12:44 AM
Hi,

I am a long time TurboCad user (back to V4).

I recently purchased TurboCad 2018 pro platinum as an upgrade from 2016 pro platinum.

After completing the download, I attempted to install, entering the necessary SNs and key.  I did get a window indicating that the software was fully activated.

However, when starting the program, there is first a huge (10 minutes) delay, and then an error message pops up. If you click repeatedly (many, many times) eventually the software will start and seems to run normally.

When I shut down and restart,  I am back to the huge delay.  The same problem is now affecting TurboCad 2016 pro platinum.  I did uninstall the TurboCad 2016 symbols and 2D/3D training package and that  may have changed things (though I don't see why it should).

Screenshots of the error message and my system configuration are attached.

Thanks,

Joseph Milanese
C.S. Engineering, LLC
440-953-9878

Logged


* August 27, 2018, 08:02:31 AM
#1

Logged
Nikki
TC20 platinum
TC 2015 platinum
TC 2017 with lightworks


* August 27, 2018, 11:14:44 AM
#2
Nikki,

Yes, that works!

Thanks very much for your help.

I should have done a thorough search before asking.

Joe

Logged


* October 19, 2018, 09:04:40 AM
#3
Hi,

I started this thread, and I am afraid I spoke too soon.  Relocating the two indicated files did allow TurboCAD (2018 and 2016) to start, but it is causing another weird problem.

TurboCad 2018 keeps trying to reinstall itself - sometimes when I just click on a folder, but most consistently when I start my .pdf printer, pdfcreator. I can generally get out of it by hitting cancel anywhere from one to ten times.  Does anyone know why this is happening and how I can avoid it?  I tried moving and renaming the TurboCad 2018.msi file, but it did not change things.

Thanks to all for their time.

Sincerely,

JoeM

UPDATE:

Just tried deleting only TCWelcomeSplashTest.exe, rather than both TCWelcomeSplashTest.exe AND dbautosrvwrapper.exe, and (tentatively) this seems to be working, i.e. Tcad starts and attempted reinstalls have ceased.

Thanks,

Joe
« Last Edit: October 19, 2018, 09:18:45 AM by JoeM »

Logged


October 20, 2018, 12:03:44 AM
#4
My go-to suggestion for this type of problem is to uninstall, reboot, then re-install in Administrator mode.

When starting TurboCAD for the first time, also use Administrator mode so that you can kill the pop-up advertisement and have the system remember it.

Following that, most people have no problems starting TurboCAD in regular user mode.


Jeff

Logged
TC Pro Platinum 2018, 2017, 2016 & 2015 (all with LightWorks & RedSDK) & V21
System: i7-5820K @ 3.30GHz, ASRock X99 Extreme4, 16GB DDR4-2133 RAM, Gigabyte GTX 970, Samsung NVMe SSD 950 (256GB), Windows 7 Pro (64-bit) SP1